MaximoAccess

Caro Usuário, antes de postar pela primeira vez, leia as regras do fórum.

Obrigado

Administração do MaximoAccess

Dicas Ms Access, Exemplos Ms Access, Codigos VBA Ms Access, SQL Ms Access

    [Resolvido]Não aceita a cor azul para linha

    Compartilhe

    ilvecchio
    Intermediário
    Intermediário

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 132
    Registrado : 16/11/2012

    [Resolvido]Não aceita a cor azul para linha

    Mensagem  ilvecchio em Qui 15 Maio 2014, 18:52

    Buenas!

    Estou usando este código para desenhar linhas em um relatório:
    -----------------------------------------------------------------
    Dim CorLinha As Integer
    CorLinha = 255 'vermelho

    Me.Line (0 * 567, 0 * 567)-(0 * 567, 6 * 567), CorLinha
    -----------------------------------------------------------------

    Funciona para o vermelho (255) e o preto (0). Preciso do código do azul.

    Tentei os formados RGB e QBColor.
    CorLinha = RGB(0,0,255) azul ou
    CorLinha = QBColor(1) azul

    Nenhum funciona. Funcionam para as cores vermelho e preto
    CorLinha = RGB(0,0,0) preto ou
    CorLinha = QBColor(0) preto

    CorLinha = RGB(255,0,0) vermelho ou
    CorLinha = QBColor(4) vermelho


    A cor azul (16711680) usada em uma linha criada manualmente não é aceita.

    O erro é: Erro em tempo de execução '6' : Estouro


    É algum bug?

    avatar
    Avelino Sampaio
    Moderador
    Moderador

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 3385
    Registrado : 04/04/2010

    Re: [Resolvido]Não aceita a cor azul para linha

    Mensagem  Avelino Sampaio em Qui 15 Maio 2014, 19:04

    Olá!

    Ou altere para

    Dim CorLinha As long
    corLinha = 16711680

    Ou utilize o valor vbBlue

    Me.Line (0 * 567, 0 * 567)-(0 * 567, 6 * 567), vbBlue

    Sucesso!

    ilvecchio
    Intermediário
    Intermediário

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 132
    Registrado : 16/11/2012

    Re: [Resolvido]Não aceita a cor azul para linha

    Mensagem  ilvecchio em Qui 15 Maio 2014, 19:52

    Grande Avelino!

    Como sempre, simples e objetivo.

    Valeu, cara. Um abraço.

      Data/hora atual: Qui 17 Ago 2017, 12:46