MaximoAccess

Caro Usuário, não tire as suas duvidas nas Salas de Repositório, abra sempre um novo tópico relacionado, nas salas destinadas para o efeito, como Sala de Tabelas, Consultas, Formulários, Relatórios, Macros, Módulos e VBA.

Obrigado

Administração do MaximoAccess

Dicas Ms Access, Exemplos Ms Access, Codigos VBA Ms Access, SQL Ms Access

    [Resolvido]uso de CopyFile não funcionando

    Compartilhe

    eduas65
    Novato
    Novato

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 10
    Registrado : 30/10/2012

    [Resolvido]uso de CopyFile não funcionando

    Mensagem  eduas65 em Dom 17 Ago 2014, 5:06 am

    Caros, peço ajuda quanto a se conhecem histórico ou explicação porque um rotina que usa CopyFile funcionaria em uma máquina e em outras não, isto está ocorrendo com máquinas que recentemente formatamos para migrar para o Windows7. Nesta máquinas não consigo salvar o arquivo como consigo plenamente em uma máquina que já veio com o W7 instalado. Já alterei todas as permissões de pasta e atualizei a scrrun.dll e não consigo salvar. Desta maneira pergunto aos colegas se podem opinar / contribuir nesta minha necessidade.

    Reafirmo que todos os parametros estão rodando/executando perfeitamente em um máquina, então inicialmente acredito não ser o código...

    ///
    Set CopiaSeg = CreateObject("Scripting.FileSystemObject")
    CopiaSeg.CopyFile sl, strCaminhoPasta & Me.cxNumeroCadastral.Value & ".jpg"

    ///

    Agradeço desde já as contribuições.

    Eduardo

    Fernando Bueno
    Developer
    Developer

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 1819
    Registrado : 13/04/2012

    Re: [Resolvido]uso de CopyFile não funcionando

    Mensagem  Fernando Bueno em Dom 17 Ago 2014, 5:13 am

    Boa noite colega, seu service pack esta atualizado como o da maquina que funciona?


    .................................................................................
    Um abraço
    Fernando Bueno


    O aumento do conhecimento é como uma esfera dilatando-se no espaço
    quanto maior a nossa compreensão,
    maior o nosso contacto com o desconhecido
    [Você precisa estar registrado e conectado para ver esta imagem.]

    eduas65
    Novato
    Novato

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 10
    Registrado : 30/10/2012

    Re: [Resolvido]uso de CopyFile não funcionando

    Mensagem  eduas65 em Dom 17 Ago 2014, 4:20 pm

    Caro Fernando, agradeço a atenção! Descobrí que na versão W7 das máquinas - ultimate - há restrições quanto as permissões dos usuários, alterei então o UAC e passou a funcionar.

    Agradeço a prontidão e bôa vontade.

    Dou o tópico como resolvido!

    Fernando Bueno
    Developer
    Developer

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 1819
    Registrado : 13/04/2012

    Re: [Resolvido]uso de CopyFile não funcionando

    Mensagem  Fernando Bueno em Dom 17 Ago 2014, 4:21 pm

    Legal, que bom que tenha resolvido... Qualquer coisa estamos por aqui.

    O forum agradece o retorno!


    .................................................................................
    Um abraço
    Fernando Bueno


    O aumento do conhecimento é como uma esfera dilatando-se no espaço
    quanto maior a nossa compreensão,
    maior o nosso contacto com o desconhecido
    [Você precisa estar registrado e conectado para ver esta imagem.]

      Data/hora atual: Qui 08 Dez 2016, 1:02 am