MaximoAccess

Caro Usuário, não tire as suas duvidas nas Salas de Repositório, abra sempre um novo tópico relacionado, nas salas destinadas para o efeito, como Sala de Tabelas, Consultas, Formulários, Relatórios, Macros, Módulos e VBA.

Obrigado

Administração do MaximoAccess

Dicas Ms Access, Exemplos Ms Access, Codigos VBA Ms Access, SQL Ms Access

    Problemas para ativar ribbon

    Compartilhe

    diegoamaral91
    Novato
    Novato

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 3
    Registrado : 20/08/2015

    Problemas para ativar ribbon

    Mensagem  diegoamaral91 em Qua 07 Out 2015, 13:48

    Pessoal,

    É me primeiro post aqui no fórum, não sei se essa é a área correta.
    Estou criando um bd utilizando ribbons, mas como não tive condições de adquirir o Monta Ribbons do Avelino, estou utilizando um outro.
    Peguei algumas funcionalidades do maestro, como o menu de login.
    Mas está dando um erro ao tentar fazer login, quando abre a tela do depurador informa que a váriavel fncCrip não é valida.
    Mas não encontro aonde devo colocá-la.

    'Verificando senha (vbBinaryCompare permite diferenciar letras maiúsculas de minúsculas)
    If StrComp(Me!Senha, fncCrip(.Column(2), 102030), vbBinaryCompare) = 0 Then

    'repassa a identificação do usuário para a variável login
    login.id = .Column(0) 'IdUsuário
    login.Usuario = .Column(1) 'Nome do usuário

    'esconde o formulário login
    Me.visible = False
    ---------------------------------------------------------------------

    Estou disponibilizando meu bd no link abaixo:

    [Você precisa estar registrado e conectado para ver este link.]

    Já tentei de tudo, mas não consigo rodar essa ribbon.
    Alguém poderia me ajudar?

    Obrigado.

    rubenscouto
    Super Avançado
    Super Avançado

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 551
    Registrado : 02/10/2011

    Re: Problemas para ativar ribbon

    Mensagem  rubenscouto em Qua 07 Out 2015, 15:02

    Procure no Arquivo Maestro do mestre avelino por esta função. Ela está faltando no seu banco de dados, por isto que está dando erro.

    rubenscouto
    Super Avançado
    Super Avançado

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 551
    Registrado : 02/10/2011

    Re: Problemas para ativar ribbon

    Mensagem  rubenscouto em Qua 07 Out 2015, 15:05

    Encontrei dois erros no seu arquivo: o primeiro é o modulo de vinculação que não está vinculando todas as tabelas e o outro é o comando do botão Cancelar do form login que não está habilitado. Corriga estes erros para que o arquivo funcione corretamente.

    diegoamaral91
    Novato
    Novato

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 3
    Registrado : 20/08/2015

    Re: Problemas para ativar ribbon

    Mensagem  diegoamaral91 em Qua 07 Out 2015, 16:01

    Muito obrigado rubens.

    Eu coloquei o módulo de vinculação que estava faltando e ativei o botão cancelar.
    Mas agora está dando outro erro..

    No módulo que carrega a Ribbon existe a declaração abaixo:

    Public gobjRibbon As IRibbonUI

    Public bolEnabled As Boolean    ' Used in Callback "getEnabled"
                                              ' Further informations in Callback "getEnabled"
                                              ' Fuer Callback "getEnabled"
                                              ' Genauere Informationen in Callback "getEnabled".
                                 
    Public bolVisible As Boolean    ' Used in Callback "getVisible"
                                            ' More information in Callback "getVisible
                                            ' Fuer Callback "getVisible"
                                            ' Further informations in Callback "getVisible

    ' Callbacks:

    Sub OnRibbonLoad(ribbon As IRibbonUI)
       ' Callbackname in XML File "onLoad"

       Set gobjRibbon = ribbon
    End Sub

    Quando vai carregar a ribbon da um erro na linha Public gobjRibbon As IRibbonUI
    Erro: O tipo definido pelo usuário não foi definido.

    E não executa a macro OnRibbonLoad

    Saberia me dizer o que pode ser?

    diegoamaral91
    Novato
    Novato

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 3
    Registrado : 20/08/2015

    Re: Problemas para ativar ribbon

    Mensagem  diegoamaral91 em Qua 07 Out 2015, 20:26

    Abaixo está o link para baixar o bd:

    [Você precisa estar registrado e conectado para ver este link.]

    Desde já agradeço pela ajuda pessoal.

      Data/hora atual: Qui 08 Dez 2016, 23:54