MaximoAccess

Caro Usuário, não tire as suas duvidas nas Salas de Repositório, abra sempre um novo tópico relacionado, nas salas destinadas para o efeito, como Sala de Tabelas, Consultas, Formulários, Relatórios, Macros, Módulos e VBA.

Obrigado

Administração do MaximoAccess

Dicas Ms Access, Exemplos Ms Access, Codigos VBA Ms Access, SQL Ms Access

    [Resolvido]Listview - Propriedades e métodos ausentes

    Compartilhe

    gefex
    Novato
    Novato

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 3
    Registrado : 23/11/2015

    [Resolvido]Listview - Propriedades e métodos ausentes

    Mensagem  gefex em Qua 13 Abr 2016, 16:09

    Olá pessoal !
    Eu uso o Access 2007 no windows 10 64 bits e tudo ía muito bem até eu me aventurar com o Listview....
    Consigo configurar a interface dele, com colunas, labels, etc.... mas não consigo acessar os métodos e propriedades do controle no vba mesmo fazendo tudo certo,
    como declarar ele como um Listitem etc....
    Se pego um exemplo aqui do fórum e tento compilar da erro de compilação como método não encontrado etc....
    Ou seja, ele está no meu form, mas sua referencia não está no vba...mesmo com aquele pacote Microsoft Windows Common Controls (6.0) setado no access.
    Já coloquei MSCOMCTL.OCX (versao 6.1.98.46) nas duas pastas de 32 e 64 bits e registrei novamente e nada muda.
    Já fucei pra caramba aqui e na net e as tentativas foram inúteis....

    Cheguei a ler algo que no office 64 bits esse controle não funciona, mas acho que o office 2007 é 32 bits.
    Só queria ver mesmo se isso é fato que vou voltar pra meu listbox de guerra.

    Vocês perdoem-me se a resposta estiver no fórum, mas eu realmente não consegui.

    Obrigado.

    gefex
    Novato
    Novato

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 3
    Registrado : 23/11/2015

    Funciona no Excel

    Mensagem  gefex em Qui 14 Abr 2016, 02:08

    Bom, como sou ansioso, fiz o teste no excel e lá funcionou perfeitamente. No entanto percebi que a referencia la está em 32 bits. Então deve ter algo haver com isso. No entanto no access não consigo setar pra 32 bits, mesmo procurando a referencia manualmente ela fica sempre em 64 bits. Deve ter algo pra mecher no registro do windows ou coisa parecida. Vou continuar tentando e quem tiver uma luz por favor ajude... rs.... Obrigado.

    gefex
    Novato
    Novato

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 3
    Registrado : 23/11/2015

    Resolvido.

    Mensagem  gefex em Qui 14 Abr 2016, 19:44

    Pode fechar o tópico. Obrigado.

      Data/hora atual: Qui 08 Dez 2016, 00:05