MaximoAccess

Caro Usuário, não tire as suas duvidas nas Salas de Repositório, abra sempre um novo tópico relacionado, nas salas destinadas para o efeito, como Sala de Tabelas, Consultas, Formulários, Relatórios, Macros, Módulos e VBA.

Obrigado

Administração do MaximoAccess

Dicas Ms Access, Exemplos Ms Access, Codigos VBA Ms Access, SQL Ms Access

    [Resolvido]Form com subform não funciona

    Compartilhe

    Mylton
    Avançado
    Avançado

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 479
    Registrado : 23/08/2010

    [Resolvido]Form com subform não funciona

    Mensagem  Mylton em Qui 26 Maio 2016, 19:58

    Boa tarde
    Nesta aplicação existem 2 tabelas;
    1 - Referente a processos.
    com 3 campos: automático para identificador do processo, numero do processo e identificação da impugnação.
    2 - Referente a impugnação destes.
    com campos: automático para identificação da impugnação, se houve ou não (sim/não). data, descrição e a resposta.

    Cada processo possui um único número, onde podem haver várias impugnações.
    Criei 02 form do Processo e 2 de impugnação para que possam ajudar ou dar uma ideia.

    A ideia seria que o form "Tbl_Impugnacao" abrisse dentro do form "Tbl_Processo1" da mesma forma que abre quando acionado de forma sozinha. Mas não abre.
    Então criei outro form "Tbl_Processo" com um subform "SubFrmImpugnacao" para que pudesse colocar os dados.
    Mas dá o erro vide figura erro.
    Contudo, uma vez resolvido esse erro, ficaria difícil escrever e ler num campo pequenos textos.

    Pensei.... o ideal seria o primeiro caso ou colocar uma lupa para abrir uma tela qualquer, exemplo "figura gostaria", que pudesse ler ou escrever adequadamente, para depois retornar a este subform.

    Alguém poderia ajudar?
    Obrigado
    lol!
    Anexos
    Teste01.zip
    Você não tem permissão para fazer download dos arquivos anexados.
    (143 Kb) Baixado 3 vez(es)

    FabioPaes
    Developer
    Developer

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 2302
    Registrado : 14/08/2013

    Re: [Resolvido]Form com subform não funciona

    Mensagem  FabioPaes em Qui 26 Maio 2016, 22:54

    Amigo, as imagens ficaram ilegiveis, Portanto fiz o que acho que quer

    A meu ver o seu Relacionamento Esta Errado! Ja que o mesmo processo pode ter varias Impgnação, certo? Entao o Relacionamento e 1 (tbProcesso) para Muitos (tbimpugnação). e Seu relacionamento estava invertido.

    Veja as opções, pelo menos serve pra lhe dar uma ideia.

    Se nao for isso, poste fotos mais legiveis. Resolução maxima...
    Anexos
    Teste01.zip
    Você não tem permissão para fazer download dos arquivos anexados.
    (125 Kb) Baixado 3 vez(es)


    .................................................................................
    _____________________________________________________________________
    Achou a solução para sua dúvida? Não seja Egoísta, Compartilhe com todos!
    A dica do Colega foi útil? Agradeça!

    O importante não saber tudo, mas sim a Onde procurar!

    Mylton
    Avançado
    Avançado

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 479
    Registrado : 23/08/2010

    Re: [Resolvido]Form com subform não funciona

    Mensagem  Mylton em Sex 27 Maio 2016, 00:36

    Fábio a 2 opção show.
    a 1 coloquei uns botões de registro e só zera na parte de cima. na parte de baixo não zera.
    Sabe o pq?
    Obrigado
    Anexos
    teste02.zip
    Você não tem permissão para fazer download dos arquivos anexados.
    (101 Kb) Baixado 2 vez(es)

    Mylton
    Avançado
    Avançado

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 479
    Registrado : 23/08/2010

    Re: [Resolvido]Form com subform não funciona

    Mensagem  Mylton em Sex 27 Maio 2016, 00:39

    Precisa ver as fotos?

    FabioPaes
    Developer
    Developer

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 2302
    Registrado : 14/08/2013

    Re: [Resolvido]Form com subform não funciona

    Mensagem  FabioPaes em Sex 27 Maio 2016, 00:52

    A primeira Opção amigo, eu fiz somente para continuar a que ja veio feita... Mas nao e o correto, ja que ele exibe todos os registros da tabela de Ipugnação...
    O correto mesmo é d segunda Opção, pois so aparecerao os registros das impugnação referentes ao processo mostrado na parte de Cima...

    O erro provavelmente era devido ao Relacionamento.


    .................................................................................
    _____________________________________________________________________
    Achou a solução para sua dúvida? Não seja Egoísta, Compartilhe com todos!
    A dica do Colega foi útil? Agradeça!

    O importante não saber tudo, mas sim a Onde procurar!

    Mylton
    Avançado
    Avançado

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 479
    Registrado : 23/08/2010

    Re: [Resolvido]Form com subform não funciona

    Mensagem  Mylton em Sex 27 Maio 2016, 00:57

    Fábio.
    Posso mandar uma MP para vc com o banco original.
    Ira entender. penso eu.

    FabioPaes
    Developer
    Developer

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 2302
    Registrado : 14/08/2013

    Re: [Resolvido]Form com subform não funciona

    Mensagem  FabioPaes em Sex 27 Maio 2016, 01:01

    A parte de baixo nao zera na primeira Opção, pois o formulario e do Tipo Dividido. Formulários assim, ele exibe um registro, e no Formato Folha de Dados, ele exibe TODOS os registros da Tabela ou Consulta. Ele serve apenas para uma visualização de Todos os registros.


    .................................................................................
    _____________________________________________________________________
    Achou a solução para sua dúvida? Não seja Egoísta, Compartilhe com todos!
    A dica do Colega foi útil? Agradeça!

    O importante não saber tudo, mas sim a Onde procurar!

    FabioPaes
    Developer
    Developer

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 2302
    Registrado : 14/08/2013

    Re: [Resolvido]Form com subform não funciona

    Mensagem  FabioPaes em Sex 27 Maio 2016, 01:02

    Pode mandar sim... MP


    .................................................................................
    _____________________________________________________________________
    Achou a solução para sua dúvida? Não seja Egoísta, Compartilhe com todos!
    A dica do Colega foi útil? Agradeça!

    O importante não saber tudo, mas sim a Onde procurar!

    Mylton
    Avançado
    Avançado

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 479
    Registrado : 23/08/2010

    Re: [Resolvido]Form com subform não funciona

    Mensagem  Mylton em Sex 27 Maio 2016, 01:46

    Oi.
    Acabei de enviar.

    Mylton
    Avançado
    Avançado

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 479
    Registrado : 23/08/2010

    Re: [Resolvido]Form com subform não funciona

    Mensagem  Mylton em Sex 27 Maio 2016, 02:40

    Obrigado Fábio.
    Boa semana

    FabioPaes
    Developer
    Developer

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 2302
    Registrado : 14/08/2013

    Re: [Resolvido]Form com subform não funciona

    Mensagem  FabioPaes em Sex 27 Maio 2016, 03:04

    Deu certo a solucao? Poste a solucao e marque como fechado, por favor. Para facilitar a busca ao Forum...

    Boa semana e ate a proxima, se Deus quiser.


    .................................................................................
    _____________________________________________________________________
    Achou a solução para sua dúvida? Não seja Egoísta, Compartilhe com todos!
    A dica do Colega foi útil? Agradeça!

    O importante não saber tudo, mas sim a Onde procurar!

    Mylton
    Avançado
    Avançado

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 479
    Registrado : 23/08/2010

    Re: [Resolvido]Form com subform não funciona

    Mensagem  Mylton em Dom 19 Jun 2016, 18:15

    Desculpe.
    esqueci de encerrar.
    Obrigado a todos.

      Data/hora atual: Dom 04 Dez 2016, 14:16