MaximoAccess

Caro Usuário, antes de postar pela primeira vez, leia as regras do fórum.

Obrigado

Administração do MaximoAccess

Dicas Ms Access, Exemplos Ms Access, Codigos VBA Ms Access, SQL Ms Access

    [Resolvido]Front-End não abre em pasta compartilhada na rede

    Compartilhe
    avatar
    Gilson
    Novato
    Novato

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 14
    Registrado : 11/06/2011

    [Resolvido]Front-End não abre em pasta compartilhada na rede

    Mensagem  Gilson em 17/11/2016, 20:43

    Olá amigos...

    Dividi um pequeno banco de dados e coloquei o front-end em uma pasta compartilhada em rede.
    Porém ao acessar este front-end em outro PC ele abre o aplicativo ACCESS e não o meu BD.
    Peço ajuda aos amigos para resolver isso.
    Desde já agradeço.

    Informações necessárias:
    -O BD está em modo compartilhado;
    -A pasta da rede está compartilhada com controle total.


    .................................................................................
    Um abraço a todos

    O MÍNIMO QUE DESENVOLVO SEMPRE CONTO COM O MÁXIMO.
    avatar
    ahteixeira
    Moderador Global
    Moderador Global

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Portugal
    Mensagens : 5386
    Registrado : 15/03/2013

    Re: [Resolvido]Front-End não abre em pasta compartilhada na rede

    Mensagem  ahteixeira em 17/11/2016, 21:02

    Olá,
    O Front End deve ficar no disco local de cada posto.
    O back end na rede que fica vinculado ao front end.
    Abraço
    avatar
    Gilson
    Novato
    Novato

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 14
    Registrado : 11/06/2011

    Re: [Resolvido]Front-End não abre em pasta compartilhada na rede

    Mensagem  Gilson em 17/11/2016, 21:24

    Obrigado ahteixeira, mas não funcionou.
    No servidor o BD abre normalmente, mas no Posto continua abrindo o aplicativo e não o BD.
    Se eu compartilhar o BD total sem dividi-lo ele abre no Posto normalmente, porém com as tabelas vinculadas ele não abre.
    No servidor uso WIN10 e no posto WIN7, ambos com o mesmo ACCESS 2016.


    .................................................................................
    Um abraço a todos

    O MÍNIMO QUE DESENVOLVO SEMPRE CONTO COM O MÁXIMO.
    avatar
    FabioPaes
    Moderador
    Moderador

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 3904
    Registrado : 14/08/2013

    Re: [Resolvido]Front-End não abre em pasta compartilhada na rede

    Mensagem  FabioPaes em 17/11/2016, 22:20

    Mas, vc refez os Vínculos das tabelas nessa maquina da Rede? Buscando o BD do servidor que contem as tabelas?


    .................................................................................
    _____________________________________________________________________
    Achou a solução para sua dúvida? Não seja Egoísta, Compartilhe com todos!
    A dica do Colega foi útil? Agradeça!

    O importante não saber tudo, mas sim a Onde procurar!
    avatar
    Gilson
    Novato
    Novato

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 14
    Registrado : 11/06/2011

    Re: [Resolvido]Front-End não abre em pasta compartilhada na rede

    Mensagem  Gilson em 18/11/2016, 00:11

    Olá Fabio...
    Não refiz os vínculos porque o BD não abre no Posto/Estação.
    Como eu disse antes, ao acessar o BD o que abre é o aplicativo ACCESS.


    .................................................................................
    Um abraço a todos

    O MÍNIMO QUE DESENVOLVO SEMPRE CONTO COM O MÁXIMO.
    avatar
    FabioPaes
    Moderador
    Moderador

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 3904
    Registrado : 14/08/2013

    Re: [Resolvido]Front-End não abre em pasta compartilhada na rede

    Mensagem  FabioPaes em 18/11/2016, 01:23

    Posta aqui para que possamos dar uma olhada...


    .................................................................................
    _____________________________________________________________________
    Achou a solução para sua dúvida? Não seja Egoísta, Compartilhe com todos!
    A dica do Colega foi útil? Agradeça!

    O importante não saber tudo, mas sim a Onde procurar!
    avatar
    Gilson
    Novato
    Novato

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 14
    Registrado : 11/06/2011

    Re: [Resolvido]Front-End não abre em pasta compartilhada na rede

    Mensagem  Gilson em 18/11/2016, 02:15

    Olá Fabio...
    Segue anexo este pequeno BD para sua análise.
    Talvez nem precisasse dividi-lo, mas como é um problema que pode
    ocorrer com outros BDs mais pesados seria interessante resolvermos.
    Anexos
    Agenda-de-Fornecedores.zip
    Agenda-de-Fornecedores
    Você não tem permissão para fazer download dos arquivos anexados.
    (72 Kb) Baixado 12 vez(es)


    .................................................................................
    Um abraço a todos

    O MÍNIMO QUE DESENVOLVO SEMPRE CONTO COM O MÁXIMO.
    avatar
    Silvio
    Developer
    Developer

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 3973
    Registrado : 20/04/2011

    Re: [Resolvido]Front-End não abre em pasta compartilhada na rede

    Mensagem  Silvio em 18/11/2016, 11:53

    Bom dia, se me permitem um pitaquinho.

    1- se o Back end está em um servidor de rede, então está pasta ( onde está o Back End ) deverá estar compartilhada ( mapeada não importando a letra se é Z: ou Y: ou X:) e com permissões de segurança para todos os usuários de sua rede ( gravar, excluir, ler ).
    2- ir em cada estação e mapear a unidade de rede, descrita e criada acima. Lembrando que deve colocar para refazer o vinculo da rede ( logon automático).
    3- após isso, deverá vincular em cada estação o Back End, fazendo isso pela unidade mapeada.
    4- isso supondo que cada estação esteja com o Front End.
    5- lembrando que as configurações de macro em cada Front End, devem estar desabilitadas para evitar erros.


    .................................................................................
    Caso tenha resolvido a tua duvida, coloque o tópico como resolvido.
    [Você precisa estar registrado e conectado para ver este link.]
    avatar
    Silvio
    Developer
    Developer

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 3973
    Registrado : 20/04/2011

    Re: [Resolvido]Front-End não abre em pasta compartilhada na rede

    Mensagem  Silvio em 18/11/2016, 12:00

    Melhor...
    Pelo que eu vi, retire ou comente essa linha

    Private Sub Form_Load()
    fAccessWindow "Hide", False, False
    End Sub


    do formulário Agenda_Fornecedores e faça um teste.


    .................................................................................
    Caso tenha resolvido a tua duvida, coloque o tópico como resolvido.
    [Você precisa estar registrado e conectado para ver este link.]
    avatar
    ahteixeira
    Moderador Global
    Moderador Global

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Portugal
    Mensagens : 5386
    Registrado : 15/03/2013

    Re: [Resolvido]Front-End não abre em pasta compartilhada na rede

    Mensagem  ahteixeira em 18/11/2016, 12:05

    Olá Silvio, todos os pitacos são bem-vindos.

    Entretanto, no exemplo que baixei não consegui abrir o FrontEnd.
    Criei uma base de dados nova e importei.
    Baixe o meu teste , ligue (vincular) ao Back End e teste
    meocloud.pt/link/c14c66cc-4016-428c-a9fb-825591bdea5f/agenda-de-fornecedores_FrontEnd.zip/
    Abraço
    avatar
    FabioPaes
    Moderador
    Moderador

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 3904
    Registrado : 14/08/2013

    Re: [Resolvido]Front-End não abre em pasta compartilhada na rede

    Mensagem  FabioPaes em 18/11/2016, 15:27

    Ahteixeira escreveu:Entretanto, no exemplo que baixei não consegui abrir o FrontEnd.

    Também nao consegui abrir...
    Office 2013.


    .................................................................................
    _____________________________________________________________________
    Achou a solução para sua dúvida? Não seja Egoísta, Compartilhe com todos!
    A dica do Colega foi útil? Agradeça!

    O importante não saber tudo, mas sim a Onde procurar!
    avatar
    Gilson
    Novato
    Novato

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 14
    Registrado : 11/06/2011

    Re: [Resolvido]Front-End não abre em pasta compartilhada na rede

    Mensagem  Gilson em 18/11/2016, 15:45

    Um ótimo dia a todos e obrigado pela ajuda.
    Quanto a sugestão do Silvio de retirar ou comentar a linha

    Private Sub Form_Load()
    fAccessWindow "Hide", False, False
    End Sub


    do formulário Agenda_Fornecedores não funcionou e está é a função que oculta o ACCESS.

    Quanto a sugestão do ahteixeira, funcionou parcialmente já que não havia mais a tabela vinculada
    e assim pude acessar o BD e revincular a tabela. Porém depois disto a consulta baseada na tabela ficou quebrada
    e o formulário abriu com erro.

    A solução que encontrei foi alterar a fonte de registro do form AGENDA DE FORNECEDORES para a tabela e não na consulta.
    Fiz isto porque era apenas uma tabela, mas seria inviável se fossem muitas tabelas.

    Já distribui outros BDs nesta rede e correu tudo bem, mas com este realmente continuo sem saber o que pode ter ocorrido.
    Vou continuar tentando encontrar a melhor solução e repassar aos amigos que aqui me ajudaram até agora.

    Agradeço a todos e não sei se devo fechar o tópico já que a solução encontrada acredito eu, não seja a melhor.
    Talvez os amigos tenham com certeza uma solução mais adequada.


    .................................................................................
    Um abraço a todos

    O MÍNIMO QUE DESENVOLVO SEMPRE CONTO COM O MÁXIMO.
    avatar
    Silvio
    Developer
    Developer

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 3973
    Registrado : 20/04/2011

    Re: [Resolvido]Front-End não abre em pasta compartilhada na rede

    Mensagem  Silvio em 18/11/2016, 16:08

    A principio, aqui também não abriu conforme o esperado.   Mas...importei todo o Fe para o Be para melhor analise.
    Eis o arquivo compactado, sem a linha que eu tirei ao carregar o referido formulário na mensagem anterior.
    Anexos
    Agenda_new.zip
    Você não tem permissão para fazer download dos arquivos anexados.
    (137 Kb) Baixado 13 vez(es)


    .................................................................................
    Caso tenha resolvido a tua duvida, coloque o tópico como resolvido.
    [Você precisa estar registrado e conectado para ver este link.]
    avatar
    ahteixeira
    Moderador Global
    Moderador Global

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Portugal
    Mensagens : 5386
    Registrado : 15/03/2013

    Re: [Resolvido]Front-End não abre em pasta compartilhada na rede

    Mensagem  ahteixeira em 18/11/2016, 22:58

    Olá Gilson,
    Vamos fazer um teste na sua rede.
    No link abaixo baixe o projecto.
    [Você precisa estar registrado e conectado para ver este link.]
    Copie para o disco c:
    Os ficheiros de dados copie para a sua rede (pasta partilhada)
    Execute o projecto, ao abrir a empresa, navegue até à pasta da rede e verifique se esta a funcionar.
    Acaba por ser um exemplo de front end / back end.
    Abraço
    avatar
    Gilson
    Novato
    Novato

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 14
    Registrado : 11/06/2011

    Re: [Resolvido]Front-End não abre em pasta compartilhada na rede

    Mensagem  Gilson em 19/11/2016, 15:16

    Obrigado ahteixeira pelo ótimo exemplo.
    Funcionou perfeitamente na minha pequena rede.


    .................................................................................
    Um abraço a todos

    O MÍNIMO QUE DESENVOLVO SEMPRE CONTO COM O MÁXIMO.
    avatar
    ahteixeira
    Moderador Global
    Moderador Global

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Portugal
    Mensagens : 5386
    Registrado : 15/03/2013

    Re: [Resolvido]Front-End não abre em pasta compartilhada na rede

    Mensagem  ahteixeira em 19/11/2016, 22:22

    Olá,
    Que tal importar o forms para o front end
    E dados para back end e testar .
    Estou no celular, apenas dica.
    Abraço
    avatar
    Gilson
    Novato
    Novato

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 14
    Registrado : 11/06/2011

    Re: [Resolvido]Front-End não abre em pasta compartilhada na rede

    Mensagem  Gilson em 20/11/2016, 19:33

    Olá ahteixeira...
    Testei conforme sua sugestão e funcionou perfeitamente.
    Agradeço a todos e principalmente a você, mas vou continuar sem saber
    o que realmente aconteceu com o meu BD original.
    Problema resolvido.


    .................................................................................
    Um abraço a todos

    O MÍNIMO QUE DESENVOLVO SEMPRE CONTO COM O MÁXIMO.
    avatar
    ahteixeira
    Moderador Global
    Moderador Global

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Portugal
    Mensagens : 5386
    Registrado : 15/03/2013

    Re: [Resolvido]Front-End não abre em pasta compartilhada na rede

    Mensagem  ahteixeira em 21/11/2016, 00:42

    Olá, obrigado pelo retorno.
    Aparentemente o seu projecto estaria com problemas.
    Uma solução talvez fosse criar base de dados novas e importar.

    Face ao exposto, não se esqueça de dar o tópico como resolvido, veja link abaixo como fazer:
    [Você precisa estar registrado e conectado para ver este link.]

    Abraço
    avatar
    Gilson
    Novato
    Novato

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 14
    Registrado : 11/06/2011

    Re: [Resolvido]Front-End não abre em pasta compartilhada na rede

    Mensagem  Gilson em 21/11/2016, 01:40

    Obrigado pela sugestão novamente, mas eu já fiz isto.
    O que me intriga é não ter encontrado o real problema.
    Mesmo assim agradeço e em breve espero contribuir com o Fórum.


    .................................................................................
    Um abraço a todos

    O MÍNIMO QUE DESENVOLVO SEMPRE CONTO COM O MÁXIMO.
    avatar
    ahteixeira
    Moderador Global
    Moderador Global

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Portugal
    Mensagens : 5386
    Registrado : 15/03/2013

    Re: [Resolvido]Front-End não abre em pasta compartilhada na rede

    Mensagem  ahteixeira em 21/11/2016, 08:26

    cheers

      Data/hora atual: 17/8/2018, 01:08