MaximoAccess

Caro Usuário, antes de postar pela primeira vez, leia as regras do fórum.

Obrigado

Administração do MaximoAccess

Dicas Ms Access, Exemplos Ms Access, Codigos VBA Ms Access, SQL Ms Access

    [Resolvido]Código não funciona no 2013

    Compartilhe
    avatar
    Assis
    Maximo VIP
    Maximo VIP

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Portugal
    Mensagens : 3014
    Registrado : 06/11/2009

    [Resolvido]Código não funciona no 2013

    Mensagem  Assis em Qui 06 Jul 2017, 12:37

    Boa tarde amigos

    Porque não funciona no 2013 ?
    Obrigado

    Private Sub Form_Open(Cancel As Integer)

    Dim Minhadata As String 'isto declara a variavel Minhadata
    Dim Dia As Date, Mes As Date, Ano As Date 'isto cria a variavel Dia, mes e ano
    Dia = 12 'isto especifica até que dia o programa irá funcionar
    Mes = 9 'isto especifica ate que mes o prgrama funcionará
    Ano = 2003 'e isto especifica até que ano
    Minhadata = Dia & "/" & Mes & "/" & Ano

    If Date > Minhadata Then
    MsgBox "Este programa expirou, contate o administrador para obter o acesso novamente", vbInformation, "Aviso"
    DoCmd.Quit
    End If

    End Sub


    .................................................................................
    *** Só sei que nada sei ***
    avatar
    Silvio
    Developer
    Developer

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 3672
    Registrado : 20/04/2011

    Re: [Resolvido]Código não funciona no 2013

    Mensagem  Silvio em Qui 06 Jul 2017, 13:57

    Boa tarde Assis....

    O que ocorre ?

    Já tentou passar tudo para o inglês ? Pode ser que funfe !!


    .................................................................................
    Caso tenha resolvido a tua duvida, coloque o tópico como resolvido.
    [Você precisa estar registrado e conectado para ver este link.]
    avatar
    JPaulo
    Moderador
    Moderador

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Portugal
    Mensagens : 9703
    Registrado : 04/11/2009

    Re: [Resolvido]Código não funciona no 2013

    Mensagem  JPaulo em Qui 06 Jul 2017, 14:37

    Varias coisas mal e como diz no Titulo, não funciona no 2013 nem nas proximas versões do Office,

    1º Dia, Mes e Ano são palavras reservadas do Access.

    2º  Minhadata você diz que é String, logo é Texto e você quer comparar ao Date, obvio que não funciona.

    Código:
    Dim Minhadata As Date 'isto declara a variavel Minhadata
    Dim Dy, My, Ay As Variant 'isto cria a variavel Dia, mes e ano
    Dy = 12 'isto especifica até que dia o programa irá funcionar
    My = 9 'isto especifica ate que mes o prgrama funcionará
    Ay = 2003 'e isto especifica até que ano
    Minhadata = CDate(Dy & "/" & My & "/" & Ay)

    If Date > Minhadata Then
    MsgBox "Este programa expirou, contate o administrador para obter o acesso novamente", vbInformation, "Aviso"
    DoCmd.Quit
    End If


    .................................................................................
    Contribua com o maximoaccess nos links abaixo, ajude a melhorar este que é o seu site na NET.

    [Você precisa estar registrado e conectado para ver este link.]
    [Você precisa estar registrado e conectado para ver este link.]

    Sucesso e Bons Estudos
    Success and Good Studies

    [Você precisa estar registrado e conectado para ver esta imagem.] [Você precisa estar registrado e conectado para ver este link.]
    [Você precisa estar registrado e conectado para ver esta imagem.] [Você precisa estar registrado e conectado para ver este link.]
    [Você precisa estar registrado e conectado para ver esta imagem.] [Você precisa estar registrado e conectado para ver este link.]
    avatar
    Assis
    Maximo VIP
    Maximo VIP

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Portugal
    Mensagens : 3014
    Registrado : 06/11/2009

    Re: [Resolvido]Código não funciona no 2013

    Mensagem  Assis em Qui 06 Jul 2017, 14:56

    Obrigado JPaulo


    .................................................................................
    *** Só sei que nada sei ***
    avatar
    JPaulo
    Moderador
    Moderador

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Portugal
    Mensagens : 9703
    Registrado : 04/11/2009

    Re: [Resolvido]Código não funciona no 2013

    Mensagem  JPaulo em Qui 06 Jul 2017, 15:01

    Assis não leve a mal, mas o Obrigado não chega.

    Ficaria mais feliz se você entende-se as instruções nos códigos, porque você já anda neste fórum á 8 anos.

    Bons estudos.


    .................................................................................
    Contribua com o maximoaccess nos links abaixo, ajude a melhorar este que é o seu site na NET.

    [Você precisa estar registrado e conectado para ver este link.]
    [Você precisa estar registrado e conectado para ver este link.]

    Sucesso e Bons Estudos
    Success and Good Studies

    [Você precisa estar registrado e conectado para ver esta imagem.] [Você precisa estar registrado e conectado para ver este link.]
    [Você precisa estar registrado e conectado para ver esta imagem.] [Você precisa estar registrado e conectado para ver este link.]
    [Você precisa estar registrado e conectado para ver esta imagem.] [Você precisa estar registrado e conectado para ver este link.]

      Data/hora atual: Ter 21 Nov 2017, 17:35