MaximoAccess

Caro Usuário, antes de postar pela primeira vez, leia as regras do fórum.

Obrigado

Administração do MaximoAccess

Dicas Ms Access, Exemplos Ms Access, Codigos VBA Ms Access, SQL Ms Access

    [Resolvido]Dados do Subformulário não são atualizados após comandos no Form

    Compartilhe

    greini
    Novato
    Novato

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 40
    Registrado : 27/03/2011

    [Resolvido]Dados do Subformulário não são atualizados após comandos no Form

    Mensagem  greini em Qua 26 Jul 2017, 15:54

    Bom dia.

    Estou criando um BD aqui e embora ja tenha quebra muito a cabeça pra deixa-lo do jeito que preciso ainda tem alguns detalhes a corrigir.

    Neste BD há um FORM de compras e um SUBFORM com detalhes da compra como descrição, qtde, valor de cada item e valor total.

    O problema é que quando executo comandos como a exclusão do registro no FORM ou a adição de um novo registro os valores do SUBFORM não são alterados.

    Tenho uma outra tabela de compra com estrutura semelhante e la funciona corretamente, qndo eu excluo um registro do form os dados so subform relacionados tb são excluidos e quando insiro um novo registro o subform fica em branco pra inserir novas informaços (isso não acontece na tabela compras)


    Alguém tem alguma idéia do que possa ser?

    Desde já obrigado
    avatar
    cafpr
    Developer
    Developer

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 934
    Registrado : 08/02/2011

    Re: [Resolvido]Dados do Subformulário não são atualizados após comandos no Form

    Mensagem  cafpr em Qua 26 Jul 2017, 22:07

    Boa tarde.

    Verificou na propriedade do subform na aba dados em vincular campos mestre e filho.

    greini
    Novato
    Novato

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 40
    Registrado : 27/03/2011

    Re: [Resolvido]Dados do Subformulário não são atualizados após comandos no Form

    Mensagem  greini em Qua 26 Jul 2017, 22:24

    Está vinculado o codigo da compra com o codigo do detalhe (que eh o mesmo da compra) mas nem assim funciona

    greini
    Novato
    Novato

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 40
    Registrado : 27/03/2011

    Re: [Resolvido]Dados do Subformulário não são atualizados após comandos no Form

    Mensagem  greini em Qua 26 Jul 2017, 22:28

    Descobri o problema.

    O campo filtrar ao esvaziar o mestre estava marcado como não.
    Mudei para sim e funcionou.

    Mas de toda forma obrigado pela ajuda.



      Data/hora atual: Ter 21 Nov 2017, 19:18