MaximoAccess

Caro Usuário, antes de postar pela primeira vez, leia as regras do fórum.

Obrigado

Administração do MaximoAccess

Dicas Ms Access, Exemplos Ms Access, Codigos VBA Ms Access, SQL Ms Access

    [Resolvido]soma de subformulario retorna "0"

    Compartilhe
    avatar
    marcelo marques
    Avançado
    Avançado

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 418
    Registrado : 12/04/2016

    [Resolvido]soma de subformulario retorna "0"

    Mensagem  marcelo marques em Qui 03 Ago 2017, 11:49

    bom dia pessoal eu mais uma vez precisando da preciosa ajuda de vocês tenho um formulário com um subformulario onde eu pesquiso "Receita" e "Despesas" diária, mensais, (todas) de um livro de caixa a soma esta funcionando perfeito o único erro se eu escolho a opção diária se não existir registro diário ele da erro no campo aonde esta a soma eu gostaria de retornar "0" (zero) se não existisse registro

    desde ja obrigado



    obs estou colocando no subformulario
    um campo chamado txtreceita =soma(nome do campo)
    e no formulário pai eu estou chamando o campo txtreceita

    avatar
    FabioPaes
    Moderador
    Moderador

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 3412
    Registrado : 14/08/2013

    Re: [Resolvido]soma de subformulario retorna "0"

    Mensagem  FabioPaes em Qui 03 Ago 2017, 14:28

    Ja experimentou utilizar o NX()?

    =soma(NZ(nome do campo))


    .................................................................................
    _____________________________________________________________________
    Achou a solução para sua dúvida? Não seja Egoísta, Compartilhe com todos!
    A dica do Colega foi útil? Agradeça!

    O importante não saber tudo, mas sim a Onde procurar!
    avatar
    marcelo marques
    Avançado
    Avançado

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 418
    Registrado : 12/04/2016

    Re: [Resolvido]soma de subformulario retorna "0"

    Mensagem  marcelo marques em Sex 04 Ago 2017, 11:02

    bom dia FabioPaes da fórmula que você me iniciou não funcionou, mais eu consegui resolver com o (seimed )

    muito obrigado por disponibilizar seu tempo pra me ajudar

    abraço
    avatar
    marcelo marques
    Avançado
    Avançado

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 418
    Registrado : 12/04/2016

    Re: [Resolvido]soma de subformulario retorna "0"

    Mensagem  marcelo marques em Sex 04 Ago 2017, 11:15

    desculpa havia esquecido do resolvido

    avatar
    FabioPaes
    Moderador
    Moderador

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 3412
    Registrado : 14/08/2013

    Re: [Resolvido]soma de subformulario retorna "0"

    Mensagem  FabioPaes em Sex 04 Ago 2017, 15:12


    Grato pelo retorno amigo, até a próxima se Deus Quiser!


    .................................................................................
    _____________________________________________________________________
    Achou a solução para sua dúvida? Não seja Egoísta, Compartilhe com todos!
    A dica do Colega foi útil? Agradeça!

    O importante não saber tudo, mas sim a Onde procurar!

      Data/hora atual: Sab 18 Nov 2017, 08:04