MaximoAccess

Caro Usuário, antes de postar pela primeira vez, leia as regras do fórum.

Obrigado

Administração do MaximoAccess

Dicas Ms Access, Exemplos Ms Access, Codigos VBA Ms Access, SQL Ms Access

    [Resolvido]Erro:InputBox No inicio do formulário.

    Compartilhe

    Kiora
    Novato
    Novato

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 48
    Registrado : 18/06/2016

    [Resolvido]Erro:InputBox No inicio do formulário.

    Mensagem  Kiora em Sex 01 Dez 2017, 18:38

    Olá prezados,

    Estou com um pequeno problema.

    Eu uso Caixa de listagem para o usuário, enxergar algumas tabelas, e muitas delas tem critérios que vem de um combobox.

    Esses combobox funciona tipo um fitro. Tudo estava funcionando normalmente, porem eu alterei um referencia a pouco tempo(Não lembro qual)
    e agora quando eu abro os meus forms ele aparece vários inputbox, um pra cada combobox que eu uso nos critérios de pesquisa.

    Só percebi que isso aconteceu quando eu rodei o client no runtime, já no access ele abre os forms normalmente.

    Daí todas as vezes que eu altero o combobox que funciona como filtro ele aparece esses inputbox.(Só pelo runtime)

    Alguém pode me ajudar??
    avatar
    ahteixeira
    Moderador Global
    Moderador Global

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Portugal
    Mensagens : 4647
    Registrado : 15/03/2013

    Re: [Resolvido]Erro:InputBox No inicio do formulário.

    Mensagem  ahteixeira em Sab 02 Dez 2017, 14:46

    Olá, já verificou a origem dos dados dessas combo.
    Não estará a faltar às tabelas no cliente.

    Pode sempre criar um atalho no seu PC para a base de dados e acrescentar /Runtime para testar.

    Se tiver dificuldades, poste a base de dados com os objetos envolvidos para se poder testar.
    Abraço

    Kiora
    Novato
    Novato

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 48
    Registrado : 18/06/2016

    Re: [Resolvido]Erro:InputBox No inicio do formulário.

    Mensagem  Kiora em Dom 03 Dez 2017, 12:57

    Ola prezados Ahteixeira,

    Eu fiz alguns teste, tipo:

    Eu desvinculei todas as tabelas e refis os vínculos.

    Apaguei a consulta e refiz ela assim como a caixa de listagem também foi apagada e refeita.

    Testei outros projetos tbm e os mesmo apresenta isso apenas com no runtime.

    Esse erro começou depois que eu criptografei e descriptografei a base de dados(estava testando como ficaria a velocidade de acesso dos dois modos) e depois que mudei uma referencia para implementar em um botão, o backup, precisava ativar, porem não lembro a referencia pq quando eu fiz os teste, só testei no access e não no runtime, e como no access passa normal, só vim perceber uma semana depois. Com tudo, não sei qual dos dois pode ter afetado, só que o mais logico seira a referencia.

    O que mais me intriga é que isso só acontece nas consultas que eu uso um combobox como critério.

    Muito obrigado pela atenção!!!!
    Anexos
    Runas.zip
    Você não tem permissão para fazer download dos arquivos anexados.
    (1.3 Mb) Baixado 3 vez(es)


    Última edição por Kiora em Dom 03 Dez 2017, 13:01, editado 1 vez(es)
    avatar
    Silvio
    Developer
    Developer

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 3698
    Registrado : 20/04/2011

    Re: [Resolvido]Erro:InputBox No inicio do formulário.

    Mensagem  Silvio em Dom 03 Dez 2017, 12:59

    Bom dia...

    Um pitaco...fatalmente tem campo ausente em alguma consulta ou tabela. Acredito que seja mais em consulta.


    .................................................................................
    Caso tenha resolvido a tua duvida, coloque o tópico como resolvido.
    [Você precisa estar registrado e conectado para ver este link.]

    Kiora
    Novato
    Novato

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 48
    Registrado : 18/06/2016

    Re: [Resolvido]Erro:InputBox No inicio do formulário.

    Mensagem  Kiora em Dom 03 Dez 2017, 13:06

    Bom dia Silvio,

    Cara eu verifiquei bastante isso, acredito que não pq ele roda normal no access e no runtime não.

    E isso apareceu depois do que descrevi, não tinha mudado nada das tabelas, nem nos forms ou nas consultas.

    O que postei foi só um exemplo, minha aplicação tem uns 25 forms e umas 40 consultas, e de repente, acontece isso!

    Poderia verificar o código?

    Grato!!
    avatar
    ahteixeira
    Moderador Global
    Moderador Global

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Portugal
    Mensagens : 4647
    Registrado : 15/03/2013

    Re: [Resolvido]Erro:InputBox No inicio do formulário.

    Mensagem  ahteixeira em Dom 03 Dez 2017, 13:30

    Olá a todos,

    Monsuete Matos, você usa as tabelas separadas (exemplo FrontEnd e BackEnd) no seu cliente?
    Acho que pode estar a questão na ligação (vinculo).

    Eu testei com o paramentro /Runtime e funcionou.
    Para despistar o erro, aconselho a testar o exemplo que postou no seu cliente e verificar se funciona ou não.

    Abraço

    Kiora
    Novato
    Novato

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 48
    Registrado : 18/06/2016

    Re: [Resolvido]Erro:InputBox No inicio do formulário.

    Mensagem  Kiora em Dom 03 Dez 2017, 14:35

    Testei varios exemplos, inclusive esse exemplo que postei foi um dos que eu testei estava dando o erro.

    Esse erro da em qualquer aplicação que tenha um critério, na consulta.

    Por isso estou desconfiando que tenha sido a referencia na qual eu modifiquei.

    não entendo muito de front end e back end, mais eu uso um client e um servidor, as tabelas são vinculadas, e rodava normalmente todos os forms, depois disso ele passou a aparecer esses inputbox.

    Tem uma parte do que eu uso la no trabalho, ficaria grato se puder analisar.

    Gostaria de saber tbm qual runtime vc esta usando, estava pensando em usar o 2016, porem minha aplicação esta salva com 2013.

    Será que pode ser isso?
    Anexos
    Nova pasta.zip
    Você não tem permissão para fazer download dos arquivos anexados.
    (469 Kb) Baixado 5 vez(es)
    avatar
    ahteixeira
    Moderador Global
    Moderador Global

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Portugal
    Mensagens : 4647
    Registrado : 15/03/2013

    Re: [Resolvido]Erro:InputBox No inicio do formulário.

    Mensagem  ahteixeira em Seg 04 Dez 2017, 15:05

    Olá Monsuete,
    Aqui com o 2010 está a funcionar.

    Vamos fazer o seguinte, para despistar.
    cld.pt/dl/download/842f0191-7425-4996-95a8-1f00c7e1b2e2/Kiora_Teste.zip

    Baixe o arquivo e descompacte para a unidade C:\
    E teste no cliente, deve ficar assim a pasta C:\Kiora_Teste\Cliente.accbb

    Também lembrei que poderá ser as configurações de segurança (no pc em Runtime) que possa estar a bloquear.
    Veja tópico abaixo e verifique:
    [Você precisa estar registrado e conectado para ver este link.]

    Abraço

    Kiora
    Novato
    Novato

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 48
    Registrado : 18/06/2016

    Re: [Resolvido]Erro:InputBox No inicio do formulário.

    Mensagem  Kiora em Ter 05 Dez 2017, 19:49

    Obrigado pelo apoio Ahteixeira,

    Estarei testando amanha, e darei um retorno!

    Até amanha!

    Kiora
    Novato
    Novato

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 48
    Registrado : 18/06/2016

    Re: [Resolvido]Erro:InputBox No inicio do formulário.

    Mensagem  Kiora em Qua 06 Dez 2017, 12:56

    Nobre Ahteixeira,

    O erro persiste, teste com o arquivo que vc me enviou e nada!

    Eu vou instalar o runtime 2016 pra testar, se não for isso,vou ter que refazer minha aplicação toda formatando meu pc, e reinstalando o access do zero!!!

    Muito obrigado pela ajuda.

    Alguma outra sugestão?

    Kiora
    Novato
    Novato

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 48
    Registrado : 18/06/2016

    Re: [Resolvido]Erro:InputBox No inicio do formulário.

    Mensagem  Kiora em Qua 06 Dez 2017, 13:17

    Nobre Ahteixeira,

    Só muito grato pela ajuda, consegui resolver o problema, eu desinstalei a versão 2013 do rumntime do pc e instalei o 2016.

    Funcionou normal.

    Eu fiz esse sistema no access 2013, mais logo depois eu instalei o 2016 na maquina e continuei programando na aplicação.

    Ainda sim acredito que foi uma referencia, pq esse erro só apareceu depois que eu alterei algo lá.

    Muito obrigado msm, a todos pela atenção!
    avatar
    ahteixeira
    Moderador Global
    Moderador Global

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Portugal
    Mensagens : 4647
    Registrado : 15/03/2013

    Re: [Resolvido]Erro:InputBox No inicio do formulário.

    Mensagem  ahteixeira em Qua 06 Dez 2017, 13:45

    Olá Monsuete, que bom que resolveu!
    Obrigado pelo retorno.

    No entanto não foi conclusivo a que se devia o erro.
    Uma pergunta, instalou o apenas o Runtime do 2016 ou Access 2016 ou Office?
    Abraço

      Data/hora atual: Seg 11 Dez 2017, 22:59