MaximoAccess

Caro Usuário, antes de postar pela primeira vez, leia as regras do fórum.

Obrigado

Administração do MaximoAccess

Dicas Ms Access, Exemplos Ms Access, Codigos VBA Ms Access, SQL Ms Access

    [Resolvido]Image Control - Access 2003

    Compartilhe

    ARNeiva
    Novato
    Novato

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Portugal
    Mensagens : 10
    Registrado : 19/02/2016

    [Resolvido]Image Control - Access 2003

    Mensagem  ARNeiva em 4/4/2018, 14:38

    Boa tarde.

    Tenho o seguinte problema e gostaria de saber se já aconteceu a alguém.

    Tenho um software desenvolvido em access 2003 que roda em 50 maquinas. Alguns dos forms contem images controls para mostrar imagens por link (ex: G:\SERVIDOR\...). Até aqui tudo bem.
    Em 3 máquinas novas que vieram instalei tudo igual e ficou a funcionar 5*. Passadas 3 semanas apenas nesses 3 pc's as imagens não aparecem (fica o image control em branco), tanto em forms como nos relatórios, nos outros 50 tudo ok como até agora.
    Alguém já passou por isto?

    Noobezinho
    Moderador
    Moderador

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 3632
    Registrado : 29/06/2012

    Re: [Resolvido]Image Control - Access 2003

    Mensagem  Noobezinho em 4/4/2018, 14:59

    Andre

    É necessário saber como é exibido essas imagens.

    A pasta onde elas estão, no servidor?

    Explique mais para que possamos ajudar.

    [ ]'s

    ARNeiva
    Novato
    Novato

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Portugal
    Mensagens : 10
    Registrado : 19/02/2016

    Re: [Resolvido]Image Control - Access 2003

    Mensagem  ARNeiva em 4/4/2018, 15:03

    As imagens estão guardadas numa NAS acessivel em toda a rede tipo "G:\COMERCIAL\CLIENTES\IMG.bnp" em que G está mapeado em todos os pc's.

    A localização das imagens (caminho) fica guardada num campo de uma tabela. O control source da Image control é esse campo da tabela.

    Ps. Funciona em 50 maquinas e nessas 3 funcionava também mas de repente deixou de funcionar.

    Noobezinho
    Moderador
    Moderador

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 3632
    Registrado : 29/06/2012

    Re: [Resolvido]Image Control - Access 2003

    Mensagem  Noobezinho em 4/4/2018, 15:15

    Se o Access não retorna algum erro, quer dizer que o problema não está no aplicativo, talvez

    no caminha de rede.

    Experimente ver se tem acesso à pasta das imagens pelo windows explorer, mas pelo mapeamento.

    Uma maneira de acessar a pasta é utilizando o caminho UNC que seria assim:

    \\NOMESERVIDOR\CLIENTES\IMG.bmp

    creio que seja isso.

    \\COMERCIAL\CLIENTES\IMG.bmp (veja que escrevestes .bnp, espero que seja na digitação aqui).

    Dessa maneira, não precisa fazer mapeamento.

    Aguardo...

    ARNeiva
    Novato
    Novato

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Portugal
    Mensagens : 10
    Registrado : 19/02/2016

    Re: [Resolvido]Image Control - Access 2003

    Mensagem  ARNeiva em 4/4/2018, 15:30

    Sim tem acesso a pasta de todas as maneiras.

    Sim o bnp foi lapso.

    O Access não retorna nenhum erro e funciona por mapeamento em todas as outras maquinas.

    Está-me a parecer que algum update ou algum programa alterou alguma coisa no windows que deixou de funcionar o image control (registos ou dll's ou assim)

    Já me aconteceu isto numa máquina aqui a tempos e desinstalei tudo (Apaguei todas as chaves e referencias) e voltei a instalar e ficou a funcionar. Desta vez fiz o mesmo mas já não resolveu o problema.


    Noobezinho
    Moderador
    Moderador

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 3632
    Registrado : 29/06/2012

    Re: [Resolvido]Image Control - Access 2003

    Mensagem  Noobezinho em 4/4/2018, 15:38

    Uma última tentativa.

    Acredito que guarde o caminho da imagem de cada registro num campo da tabela.

    Verifique se o campo está preenchido com o caminho.

    No controle imagem, teste digitando o caminho de uma imagem na propriedade fonte de registro

    e veja se ela é exibida no controle.

    De acordo com o resultado, poderá descobrir o que está ocorrendo.


    ARNeiva
    Novato
    Novato

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Portugal
    Mensagens : 10
    Registrado : 19/02/2016

    Re: [Resolvido]Image Control - Access 2003

    Mensagem  ARNeiva em 4/4/2018, 15:45

    O formulário é o seguinte:

    [Você precisa estar registrado e conectado para ver esta imagem.]

    O control Source do Image control está apontado para o caminho guardado numa tabela, tal como a a text box que está por baixo da imagem.

    Com as mesmas versões de sistema operativo e com o mesmo runtime do access nas maquinas que estou a ter problema essa imagem não aparece.

    Noobezinho
    Moderador
    Moderador

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 3632
    Registrado : 29/06/2012

    Re: [Resolvido]Image Control - Access 2003

    Mensagem  Noobezinho em 4/4/2018, 15:55


    Tem mais uma coisa a verificar, as referências.

    Verifique e compare com os outros computadores, se alguma referência está faltando.

    Tem referência que o Access não avisa a sua falta.

    Como são máquinas novas, pode ser isso.

    ARNeiva
    Novato
    Novato

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Portugal
    Mensagens : 10
    Registrado : 19/02/2016

    Re: [Resolvido]Image Control - Access 2003

    Mensagem  ARNeiva em 4/4/2018, 15:58

    Sim vou verificar essa situação. Mas duvido que seja isso pois funcionou direito pelo menos 3 semanas...


    ARNeiva
    Novato
    Novato

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Portugal
    Mensagens : 10
    Registrado : 19/02/2016

    Re: [Resolvido]Image Control - Access 2003

    Mensagem  ARNeiva em 4/4/2018, 17:51

    Verifiquei as Referencias e está tudo direito...
    avatar
    ahteixeira
    Moderador Global
    Moderador Global

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Portugal
    Mensagens : 5553
    Registrado : 15/03/2013

    Re: [Resolvido]Image Control - Access 2003

    Mensagem  ahteixeira em 4/4/2018, 18:04

    Olá a todos,

    Qual a versão do Access nesses 3 postos e dos outros que funcionam e respectivos Service Pack instalados?

    Sistema operativo e versão 32 ou 64?

    Aparentemente, sendo as mesmas versões não deveria acontecer.
    Unidades mapeadas para o Access não é o mais indicado, mas pode funcionar assim.

    Abraço

    ARNeiva
    Novato
    Novato

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Portugal
    Mensagens : 10
    Registrado : 19/02/2016

    Re: [Resolvido]Image Control - Access 2003

    Mensagem  ARNeiva em 5/4/2018, 10:06

    A versão é a mesma. É o runtime do access 2003.

    Quanto ao sistema operativo é o windows 10 PRO x64


    :/
    avatar
    ahteixeira
    Moderador Global
    Moderador Global

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Portugal
    Mensagens : 5553
    Registrado : 15/03/2013

    Re: [Resolvido]Image Control - Access 2003

    Mensagem  ahteixeira em 5/4/2018, 10:10

    Olá,

    Instalou o Service Pack 3

    Abraço

    Noobezinho
    Moderador
    Moderador

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 3632
    Registrado : 29/06/2012

    Re: [Resolvido]Image Control - Access 2003

    Mensagem  Noobezinho em 5/4/2018, 10:17

    André

    Uma coisa é certa, não é o Access e sim algo no S.O.

    As outras máquinas estão com a mesma versão do Windows?

    Caso essas novas máquinas tenham o windows diferentes das

    outras, no caso, o windows 10, é bem provável que seja ele.

    Para tirar a dúvida e se puder, teste com outra máquina

    que tenha um outro S.O.

    Veja esse site:

    support.office.com/pt-br/article/quais-vers%C3%B5es-do-office-funcionam-com-o-windows-10-0fc85c97-da69-466e-b2b4-54f7d7275705

    ARNeiva
    Novato
    Novato

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Portugal
    Mensagens : 10
    Registrado : 19/02/2016

    Re: [Resolvido]Image Control - Access 2003

    Mensagem  ARNeiva em 6/4/2018, 11:00

    Bom dia.

    Testei e reparei nas outras máquinas e com pc's com a mesma versão do windows funciona.

    Porem hoje aconteceu outra situação. Aconteceu o mesmo problema num pc que tinha sido formatado à dias e tinha ficado a funcionar. Hoje de manha quando o utilizador o ligou o pc deixou de funcionar.

    O que tem em comum as máquinas que deixaram de funcionar:
    - Windows 10 PRO (De origem, não por Upgrade de outras versões)
    - Funcionavam bem e depois passando um tempo deixaram de funcionar (ALGUM UPDATE????)


    Noobezinho
    Moderador
    Moderador

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 3632
    Registrado : 29/06/2012

    Re: [Resolvido]Image Control - Access 2003

    Mensagem  Noobezinho em 6/4/2018, 11:08

    Bom dia!

    Muito provável.

    O windows tem um arquivo de histórico de tudo o que acontece no computador, inclusive os updates.

    Como não uso o Windows 10, não posso dizer onde se localiza esse arquivo.

    Sugiro que procure na internet sobre  arquivo de histórico do windows 10, histórico, etc.

    Se caso eu encontre algo, repasso para ti, por aqui.

    Com esse histórico em mão, poderá fazer o downdate  de cada atualização e testar

    apos cada retirada de atualização e assim verificar se a coisa funfa novamente.


    [ ]'s
    avatar
    ahteixeira
    Moderador Global
    Moderador Global

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Portugal
    Mensagens : 5553
    Registrado : 15/03/2013

    Re: [Resolvido]Image Control - Access 2003

    Mensagem  ahteixeira em 6/4/2018, 13:57

    Olá a todos

    André Neiva, será de seguir a recomendação do amigo Nobb.

    Eu pessoalmente a partir da versão do SO 8.1 passei a utilizar o Runtime do 2007 32 bit com os Service Pack e não tive problemas.
    Mantive a mesma distribuíção em MDE (2003).

    Tive que fazer uns ajustes no codigo para ocultar o painel de navegação.
    Outra coisa que apresentava erros e nunca tive muito tempo em apurar foi o formato (separador) da data do SO
    Como podemos ver no canto inferior direito por defeito apresenta xx/xx/xxxx e alterando para xx-xx-xxxx deixa de apresentar o erro.

    Lembrei que também pode ser alguma configuração de segurança, tipo macros ou executar código que possa estar a provocar a anomalia, como tem em RunTime, essas alterações devem ser efetuados por código ou via Regedit.
    Vou ver se disponibilizo um exemplo para se testar.

    Mais uma para despiste, baixe exemplo do tópico abaixo e experimente em duas (a funcionar/e não funcionar) e compare se apresenta o mesmo valor:
    [Você precisa estar registrado e conectado para ver este link.]

    Abraço

    ARNeiva
    Novato
    Novato

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Portugal
    Mensagens : 10
    Registrado : 19/02/2016

    Re: [Resolvido]Image Control - Access 2003

    Mensagem  ARNeiva em 9/4/2018, 10:17

    Bom dia,

    ATUALIZAÇÃO:

    Retirei os OnError desses programas de visualização de imagens e consegui o seguinte erro:

    2114: PROGRAMA AAAAAAAA doesn't support the format of the file "AAAAAAAAAAAAAAAAAAAAAAAAAAAAA.jpg" or file is too large. Try converting the file to bmp or giff formart.

    Não é do formato das imagens nem dos tamanhos pois funcionam em outros pc's e neste tambem funcionavam mas de repente deixou de funcionar....

    Shocked Shocked Shocked Shocked

    Noobezinho
    Moderador
    Moderador

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 3632
    Registrado : 29/06/2012

    Re: [Resolvido]Image Control - Access 2003

    Mensagem  Noobezinho em 9/4/2018, 10:59

    Meu amigo

    É, não tem jeito.

    Sugiro que formate esse(s) computador(es).
    avatar
    ahteixeira
    Moderador Global
    Moderador Global

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Portugal
    Mensagens : 5553
    Registrado : 15/03/2013

    Re: [Resolvido]Image Control - Access 2003

    Mensagem  ahteixeira em 9/4/2018, 17:37

    Olá a todos,

    André, pode fazer um teste, baixe o Photo Editor do link abaixo, tente instalar e verifique se mantém o problema.
    [Você precisa estar registrado e conectado para ver este link.]

    Abraço a todos

    ARNeiva
    Novato
    Novato

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Portugal
    Mensagens : 10
    Registrado : 19/02/2016

    Re: [Resolvido]Image Control - Access 2003

    Mensagem  ARNeiva em 12/4/2018, 10:49

    Bom dia...

    obrigado @ahteixeira resolveu o problema.
    bastou instalar o photo editor na versão 32 bits que as imagens voltaram logo a funcionar.

    que alivio já estava a dar em tolo... mais uma vez obrigado a todos...

    abraço

    Noobezinho
    Moderador
    Moderador

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 3632
    Registrado : 29/06/2012

    Re: [Resolvido]Image Control - Access 2003

    Mensagem  Noobezinho em 12/4/2018, 11:21

    Ótimo que o Alvaro conseguiu te ajudar.  cheers

    Mas isso na realidade é apenas um paliativo, já que o photo editor é muito antigo e

    e teu aplicativo deveria estar funcionando, assim como em todas as 50 máquinas que

    você mesmo disse estar funcionando, sem a necessidade desse subterfúgio.

    Portanto, o paliativo serve para fazer o aplicativo funcionar nesses computadores com problema

    até você achar uma solução definitiva sem precisar depender de outros programas.

    Procure pesquisar a(s) dll(s) que o photo editor usa e veja se não é a falta dela(s) que está causando

    o problema no computador.

    Faça um comparativo com as outras máquinas.

    Boa sorte! Wink
    avatar
    ahteixeira
    Moderador Global
    Moderador Global

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Portugal
    Mensagens : 5553
    Registrado : 15/03/2013

    Re: [Resolvido]Image Control - Access 2003

    Mensagem  ahteixeira em 12/4/2018, 17:52

    Olá a todos,

    Concordo com o Noob, apesar de ter resolvido e tem 50 postos a trabalhar, deverá iniciar a migração no mínimo para o 2007, veja mensagem 17.

    Lembro que o 2007 também já não tem suporte do fabricante desde outubro de 2017, mas considero o risco menor com SO mais recentes.

    Creio que o problema que teve estar relacionado com o facto de usar o Runtime do 2003 é o Photo Editor faz parte apenas do Office.
    O Runtime poderia ter algum biblioteca que deixa de funcionar num SO mais recente.

    Portanto é uma solução, mas se numa versão futura o Photo Editor não for compatível,volta a ter o mesmo problema.
    Nota, esta é apenas a minha opinião pessoal. Wink

    Abraço a todos

      Data/hora atual: 23/10/2018, 15:29