MaximoAccess

Caro Usuário, antes de postar pela primeira vez, leia as regras do fórum.

Obrigado

Administração do MaximoAccess

Dicas Ms Access, Exemplos Ms Access, Codigos VBA Ms Access, SQL Ms Access

    Back-end ficando somente leitura sem motivo

    Compartilhe

    JPREVERT
    Novato
    Novato

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 7
    Registrado : 04/10/2018

    Back-end ficando somente leitura sem motivo

    Mensagem  JPREVERT em 26/10/2018, 22:48

    Boa noite mestres.

    Sou novo por aqui, mas já aprendi bastante com muitos dos tópicos existentes aqui no fórum. Espero estar postando no lugar certo.

    Criei um banco de dados na empresa, o qual atualmente 6 usuários utilizam. Conforme orientações, separei as consultas e formulários no front-end, e as tabelas em um back-end. Como meu chefe sempre pede que faça alguma alteração/acréscimo no front-end, ao invés de disponibilizar um arquivo para cada usuário, deixei o mesmo em rede, e os usuários acessam através de um atalho que fica em seu desktop. Isso facilita as alterações que preciso fazer, uma vez que apenas substituo o arquivo em rede no caso de alteração, ao invés de ter que mandar pra cada usuário novamente. O back-end também fica em pasta na rede.

    Pois bem, acontece que de uns dias pra cá percebemos que o BD (Front) abre normalmente, mas em algumas situações apenas como leitura (para todos os usuários), ou seja, campos que os usuários podem/devem editar eles conseguem apenas visualizar. Fiz o teste e em um desses momentos, entrei diretamente no arquivo back-end. Ao entrar no arquivo o mesmo já aparece aquela barra superior informando que é somente leitura, e ao abrir as tabelas não é possível editar nem incluir nada. Isso acontece esporadicamente e sem motivo aparente, até então estamos tendo que fechar o BD (todos os usuários) e entrar novamente e ele volta ao normal, até ocorrer novamente. Engraçado que o banco abre normalmente com usuários fazendo alterações, mas em algum dado momento, acontece esse travamento.

    Como informações adicionais, fiz o banco no Access 2013, mas alguns usuários possuem o 2016 e até mesmo o 2007, não sei se está ai o problema.

    Estou realmente precisando de ajuda, implantei esse BD na empresa e agora não estou sabendo como resolver essa situação.

    Muito obrigado!!
    avatar
    Assis
    Maximo VIP
    Maximo VIP

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Portugal
    Mensagens : 3548
    Registrado : 06/11/2009

    Re: Back-end ficando somente leitura sem motivo

    Mensagem  Assis em 27/10/2018, 17:52

    João Paulo

    O back-end fica pasta na rede.

    Mas o (Front) coloca um em cada computador de cada usuário ligados ao back-end da pasta na rede.


    .................................................................................
    *** Só sei que nada sei ***

    JPREVERT
    Novato
    Novato

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 7
    Registrado : 04/10/2018

    Re: Back-end ficando somente leitura sem motivo

    Mensagem  JPREVERT em 27/10/2018, 20:17

    Então Assis,

    O problema de deixar o front em cada máquina a ser utilizada, é que toda vez que eu criar uma nova versão, tenho que mandar pra todos os usuários e contar que eles substituirão em seu desktop. A intenção de deixar o front na rede é justamente eu mesmo alterar em apenas um local e todos acessarem através de atalho. Inclusive tenho outro BD que outra equipe usa, nos mesmos moldes, Back e Front tudo na rede. Este não apresentou problemas, ao menos até agora rs.

    E esse também está funcionando, em alguns momentos apenas isso acontece e não consigo entender o porque.
    avatar
    Assis
    Maximo VIP
    Maximo VIP

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Portugal
    Mensagens : 3548
    Registrado : 06/11/2009

    Re: Back-end ficando somente leitura sem motivo

    Mensagem  Assis em 27/10/2018, 22:41

    youtube.com/watch?v=zqsStBMu05s

    Copie o link acima e cole no navegador


    .................................................................................
    *** Só sei que nada sei ***
    avatar
    ahteixeira
    Moderador Global
    Moderador Global

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Portugal
    Mensagens : 5577
    Registrado : 15/03/2013

    Re: Back-end ficando somente leitura sem motivo

    Mensagem  ahteixeira em 28/10/2018, 01:50

    Olá a todos,

    João Paulo, deveria desenvolver o projeto em 2007, pelo que relatou.
    Pois existem funcionalidades nas versões superiores que não são suportadas no 2007.
    Alternativa atualizar os postos de 2007 para 2013.

    Quanto ao front end, deve ser como o colega Assis referiu, em cada posto.
    Quanto à atualização existe exemplos no fórum, ou um simples batch para copiar o último front end da rede para o disco local do Posto.

    Fica a minha opinião.

    Abraço a todos


    Última edição por ahteixeira em 29/10/2018, 21:35, editado 1 vez(es)

    JPREVERT
    Novato
    Novato

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 7
    Registrado : 04/10/2018

    Re: Back-end ficando somente leitura sem motivo

    Mensagem  JPREVERT em 29/10/2018, 17:31

    Obrigado pelo apoio mestres Assis e ahteixeira!

    O estranho é que o Back-end é que fica somente leitura. Entrei diretamente no BE quando ocorreu o problema e esse arquivo estava somente leitura. Claro, por esse motivo, ao acessar o FE o usuário não consegue editar/acrescentar nada também.

    Creio que não seja por conta do FE estar compartilhado na rede, pois os usuários conseguem acessar normalmente o programa na maior parte do tempo. Imagino que seja algum conflito, de repente algum usuário tentando cadastrar algo enquanto outro consulta, sei lá, pode ser algo do tipo?
    avatar
    Assis
    Maximo VIP
    Maximo VIP

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Portugal
    Mensagens : 3548
    Registrado : 06/11/2009

    Re: Back-end ficando somente leitura sem motivo

    Mensagem  Assis em 8/11/2018, 12:51

    João Paulo

    Resolveu ?


    .................................................................................
    *** Só sei que nada sei ***

    JPREVERT
    Novato
    Novato

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 7
    Registrado : 04/10/2018

    Re: Back-end ficando somente leitura sem motivo

    Mensagem  JPREVERT em 8/11/2018, 16:11

    Olá Assis,

    Ainda não, como eu disse, essa situação acontece aleatoriamente. Exclui algumas consultas que estavam vinculadas a formulários, e vinculei esses formulários diretamente com as tabelas pra ver se de repente pode ser isso.

    Como trabalho em rede corporativa, fica inviável pra mim ter que inserir um FE na máquina de cada usuário, até mesmo porque na maioria do tempo ele funciona bem assim.
    avatar
    Silvio
    Developer
    Developer

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 4105
    Registrado : 20/04/2011

    Re: Back-end ficando somente leitura sem motivo

    Mensagem  Silvio em 8/11/2018, 19:12

    Verifica os atributos de leitura / Segurança da pasta onde está o BE no " micro / servidor".
    Outra coisa, veja se o HD do " micro / servidor " não entra em " standy by " para economizar energia.


    .................................................................................
    Caso tenha resolvido a tua duvida, coloque o tópico como resolvido.
    [Você precisa estar registrado e conectado para ver este link.]

    JPREVERT
    Novato
    Novato

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 7
    Registrado : 04/10/2018

    Re: Back-end ficando somente leitura sem motivo

    Mensagem  JPREVERT em 9/11/2018, 17:23

    Então, não sou administrador da rede, apenas um usuário como os demais. Não sou profissional de TI, imagino que essa questão de verificar o HD do servidor seja acessível somente ao administrador da rede. A pasta na rede onde encontra-se o BE e FE todos os usuários tem acesso de leitura/gravação. Creio que não ocorra essa questão de entrar em standy by, uma vez que são centenas de usuários na rede, e arquivos são copiados/criados durante todo o dia por todos. Mas como eu disse, não sou da área, então é somente "achismo" meu.

    De qualquer forma agradeço a todos que aqui postaram e ajudaram de alguma forma. Como essa situação acontece esporadicamente como eu relatei, vou dar o tópico como resolvido e acompanhar como o banco se comporta após eu ter feito as alterações nas consultas e relatórios.

    Muito obrigado a todos, vocês são 10!

    JPREVERT
    Novato
    Novato

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 7
    Registrado : 04/10/2018

    Re: Back-end ficando somente leitura sem motivo

    Mensagem  JPREVERT em 9/11/2018, 17:27

    Não estou conseguindo dar como resolvido o tópico, clico no botão "Resolvido" mas nada acontece. Se algum administrador puder ajudar, fico grato.

    Obrigado!!
    avatar
    ahteixeira
    Moderador Global
    Moderador Global

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Portugal
    Mensagens : 5577
    Registrado : 15/03/2013

    Re: Back-end ficando somente leitura sem motivo

    Mensagem  ahteixeira em 10/11/2018, 00:35

    Olá João Paulo,

    veja como é efetuado:
    [Você precisa estar registrado e conectado para ver este link.]

    Abraço

    JPREVERT
    Novato
    Novato

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 7
    Registrado : 04/10/2018

    Re: Back-end ficando somente leitura sem motivo

    Mensagem  JPREVERT em 10/11/2018, 18:51

    Obrigado Assis. Já tinha visto este tópico e executado os procedimentos, mas no Firefox não havia surtido resultado. Tentei agora com o Microsoft Edge e também nada acontece quando clico em "Resolvido".

      Data/hora atual: 12/11/2018, 18:31