MaximoAccess

Caro Usuário, antes de postar pela primeira vez, leia as regras do fórum.

Obrigado

Administração do MaximoAccess

Dicas Ms Access, Exemplos Ms Access, Codigos VBA Ms Access, SQL Ms Access


    [Resolvido]Aplicativo lento

    avatar
    Luís Antunes
    Avançado
    Avançado

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Portugal
    Mensagens : 270
    Registrado : 05/04/2016

    [Resolvido]Aplicativo lento Empty [Resolvido]Aplicativo lento

    Mensagem  Luís Antunes em Dom Fev 24, 2019 11:24 pm

    Boa noite
    Tenho um problema com o meu aplicativo.
    Quando está em rede fica muito lento e, impossível de trabalhar nele.
    Há alguma solução para acelerar o processo.
    Penso que um dos problemas seja as viagens a três tabelas, de cada vez, pelos registos.

    Luís Antunes
    Marcelo David
    Marcelo David
    Moderador
    Moderador

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 2864
    Registrado : 21/04/2011

    [Resolvido]Aplicativo lento Empty Re: [Resolvido]Aplicativo lento

    Mensagem  Marcelo David em Seg Fev 25, 2019 1:57 am

    Boa noite,
    existem N motivos que podem causar isso...
    Você deve fazer testes na sua rede para ver
    se o problema não é nela.
    Se rede cabeada, verificar switchs e cabeamento, etc, etc..
    Se WIFI, aí o desastre é garantido... Access e rede WIFI é querer
    dor de cabeça.

    Também o problema pode ser no aplicativo, como foi programado,
    como está acessando os dados, como estão as consultas, etc, etc...

    Enfim meu amigo, isso deve ser examinado exaustivamente...


    .................................................................................
    Marcelo David
    www.mrdsystem.com.br (em construção)
    Silvio
    Silvio
    Developer
    Developer

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 4450
    Registrado : 20/04/2011

    [Resolvido]Aplicativo lento Empty Re: [Resolvido]Aplicativo lento

    Mensagem  Silvio em Seg Fev 25, 2019 11:15 am

    Bom dia...a todos.

    O que o Marcelo falou está correto.

    Mas também tem que ver o computador onde está o Back End. Normalmente, tem que ter um bom processador e memória.

    E claro ele não pode ser tão utilizado. Ou seja, é servidor do banco de dados e é usado no dia a dia para outras tarefas.


    .................................................................................
    Caso tenha resolvido a tua duvida, coloque o tópico como resolvido.
    www.maximoaccess.com/t860-resolucao-de-topicos

    "Quase tudo é possível quando se tem determinação e força de vontade. Não desista tão rápido."
    avatar
    Luís Antunes
    Avançado
    Avançado

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Portugal
    Mensagens : 270
    Registrado : 05/04/2016

    [Resolvido]Aplicativo lento Empty Re: [Resolvido]Aplicativo lento

    Mensagem  Luís Antunes em Seg Fev 25, 2019 6:06 pm

    Boa noite Mavelo e Silvio.
    O meu serviço tem uma Intranet dedicada que serve o Ministèrio da Justiça no seu todo
    Nela tenho Duas bases (BakEnds), uma de entrada de correspodência e ourta de contabilidade.
    Ambas têm uma tabela cada e, trbalham muito bem.
    A BD em questão é de contole de armazém que tem 9 tabelas no backEnd.
    Posso disponibilizar a BD para o caso de ter sido mal concebida.
    Luís Antunes
    Marcelo David
    Marcelo David
    Moderador
    Moderador

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 2864
    Registrado : 21/04/2011

    [Resolvido]Aplicativo lento Empty Re: [Resolvido]Aplicativo lento

    Mensagem  Marcelo David em Seg Fev 25, 2019 8:02 pm

    Se puder então disponibilizar, pode ser que percebamos algo.


    .................................................................................
    Marcelo David
    www.mrdsystem.com.br (em construção)
    avatar
    Luís Antunes
    Avançado
    Avançado

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Portugal
    Mensagens : 270
    Registrado : 05/04/2016

    [Resolvido]Aplicativo lento Empty Re: [Resolvido]Aplicativo lento

    Mensagem  Luís Antunes em Seg Fev 25, 2019 9:12 pm

    Aqui vai o projecto e, agradeço-lhe a disponibilidade.

    Luís Antunes
    Anexos
    [Resolvido]Aplicativo lento AttachmentArmazém.zip
    Você não tem permissão para fazer download dos arquivos anexados.
    (458 Kb) Baixado 31 vez(es)
    Marcelo David
    Marcelo David
    Moderador
    Moderador

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 2864
    Registrado : 21/04/2011

    [Resolvido]Aplicativo lento Empty Re: [Resolvido]Aplicativo lento

    Mensagem  Marcelo David em Ter Fev 26, 2019 12:28 am

    Há algum momento específico em que a lentidão ocorre?


    .................................................................................
    Marcelo David
    www.mrdsystem.com.br (em construção)
    Assis
    Assis
    Maximo VIP
    Maximo VIP

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Portugal
    Mensagens : 3925
    Registrado : 06/11/2009

    [Resolvido]Aplicativo lento Empty Re: [Resolvido]Aplicativo lento

    Mensagem  Assis em Ter Fev 26, 2019 9:20 am

    Bom dia

    Deu erro ao vincular.

    Motivo ver imagem

    [Resolvido]Aplicativo lento Sem_tz80


    [Resolvido]Aplicativo lento 2sem_t13


    .................................................................................
    *** Só sei que nada sei ***
    avatar
    Luís Antunes
    Avançado
    Avançado

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Portugal
    Mensagens : 270
    Registrado : 05/04/2016

    [Resolvido]Aplicativo lento Empty Re: [Resolvido]Aplicativo lento

    Mensagem  Luís Antunes em Ter Fev 26, 2019 2:23 pm

    Bom dia Assis
    Obrigado pela correcção.
    O Módulo foi tirado de outro projecto, só que, não me lembtrei de alterar o nome da tabela.
    Mais uma vez te agradeço.


    Luís Antunes
    ahteixeira
    ahteixeira
    Moderador Global
    Moderador Global

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Portugal
    Mensagens : 6334
    Registrado : 15/03/2013

    [Resolvido]Aplicativo lento Empty Re: [Resolvido]Aplicativo lento

    Mensagem  ahteixeira em Ter Fev 26, 2019 3:36 pm

    Olá a todos,

    Luis Antunes, o problema como já foi dito pode ser devido a vários elementos.

    No caso da velocidade da rede para melhorar tente o seguinte:

    1) Ligar tabelas do Back End via UNC em que pode ser o nome da maquina ou IP, exemplo:

    \\NomeMaquina_ou_IP\Pasta\Ficheiro.accdb
    \\192.xxx.xxx.xxx\Pasta\Ficheiro.accdb

    Estive a verificar as relações, e sou da opinião de criar Indexação para os campos relaionados.
    Deve verificar nas restantes tabelas

    Exemplo da verificação na Tbl_ComprasDet
    [Resolvido]Aplicativo lento 046

    Quanto ao programa e código ainda não explorei.

    Abraço

    Ver perfil do usuário
    avatar
    Luís Antunes
    Avançado
    Avançado

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Portugal
    Mensagens : 270
    Registrado : 05/04/2016

    [Resolvido]Aplicativo lento Empty Re: [Resolvido]Aplicativo lento

    Mensagem  Luís Antunes em Ter Fev 26, 2019 9:48 pm

    AHTeixeira Boa noite
    Fiz as alterações Sugeridas, quanto à indexação.
    Quanto à ligação da tabela ao IP da máqina,via UNC, não entendi.
    Estando O BackEnd em rede, qual da máquinas a tabela deve esar ligada?
    Obrigado pelo interesse
    Luís Antunes
    ahteixeira
    ahteixeira
    Moderador Global
    Moderador Global

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Portugal
    Mensagens : 6334
    Registrado : 15/03/2013

    [Resolvido]Aplicativo lento Empty Re: [Resolvido]Aplicativo lento

    Mensagem  ahteixeira em Qui Fev 28, 2019 6:02 pm

    Olá Luis Antunes,

    A base de dados do back end deve estar num "servidor".
    Normalmente em windows o normal é mapear uma letra (f:\ , z:\) à unidade (disco) ou pasta partilhada.
    Quando ligamos às tabelas em vez de colocar a letra da unidade, exemplo:

    F:\PastaRede\BackEnd.accdb

    Colocamos o caminho UNC exemplo para Maquina com nome SRV001

    \\SRV001\PastaRede\BackEnd.accdb

    Verifique como tem na sua rede e Envie mais detalhes se mantiver a dúvida.

    Abraço
    avatar
    Luís Antunes
    Avançado
    Avançado

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Portugal
    Mensagens : 270
    Registrado : 05/04/2016

    [Resolvido]Aplicativo lento Empty Re: [Resolvido]Aplicativo lento

    Mensagem  Luís Antunes em Qui Fev 28, 2019 6:40 pm

    ahteixeira Boa Tarde
    Só posso fazer essa verificação para a semana.
    Luís Antunes
    avatar
    Luís Antunes
    Avançado
    Avançado

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Portugal
    Mensagens : 270
    Registrado : 05/04/2016

    [Resolvido]Aplicativo lento Empty Re: [Resolvido]Aplicativo lento

    Mensagem  Luís Antunes em Sab Abr 13, 2019 12:28 am

    Só agora me foi possível responder a esta questão.
    Reomeei a BD (//servusrfiles\cebv\base\StckCEBV-be)
    Quando dei enter desapareceram as barras que ficou como; (servusrfilescebvbaseStckCEBV-be).
    Mesmo assim corri a BD mas, continuou com a mesma lentidão.
    Fiz alguma coisa mal?

    Luís Antunes

    ahteixeira
    ahteixeira
    Moderador Global
    Moderador Global

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Portugal
    Mensagens : 6334
    Registrado : 15/03/2013

    [Resolvido]Aplicativo lento Empty Re: [Resolvido]Aplicativo lento

    Mensagem  ahteixeira em Seg Abr 15, 2019 11:20 pm

    Olá Luis Antunes,

    Relativamente à barra que desapareceu deve ser como exemplifiquei, ou seja:

    \\NomeDaMaquina_ou_IP\NomeDaPastaPartilhada\NomdeDoFicheiroBackEnd.accdb

    Deve verificar a estrutura dos dados e indexacoes.

    Ainda não tive mais tempo nem oportunidade de explorar o seu projeto.

    Abraço

    avatar
    Luís Antunes
    Avançado
    Avançado

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Portugal
    Mensagens : 270
    Registrado : 05/04/2016

    [Resolvido]Aplicativo lento Empty Re: [Resolvido]Aplicativo lento

    Mensagem  Luís Antunes em Qua Abr 24, 2019 6:08 pm

    Boa tarde A H Teixeira
    Coloquei o IP antes do nome da BD mas esqueci-me de indicar a pasta.
    Vou ter que esperar mais uns dias.
    10.176.126.254CEBVSTOCK_be.mdb

    Luís Antunes
    maguim
    maguim
    Avançado
    Avançado

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 446
    Registrado : 15/05/2013

    [Resolvido]Aplicativo lento Empty Re: [Resolvido]Aplicativo lento

    Mensagem  maguim em Qui Abr 25, 2019 2:42 pm

    da uma lida no meu topico, confira os itens acredito que possa ajudar vc.

    http://www.maximoaccess.com/t34822-resolvidoback-end-corrompendo-diversas-vezes-no-dia


    .................................................................................
    O conhecimento é a Dadiva da Vida. Sem ele o que seriamos ?! Surprised
    ahteixeira
    ahteixeira
    Moderador Global
    Moderador Global

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Portugal
    Mensagens : 6334
    Registrado : 15/03/2013

    [Resolvido]Aplicativo lento Empty Re: [Resolvido]Aplicativo lento

    Mensagem  ahteixeira em Seg Maio 06, 2019 11:39 am

    Olá a todos,

    Luís Antunes, aguardamos desenvolvimento.

    Abraço a todos
    avatar
    Luís Antunes
    Avançado
    Avançado

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Portugal
    Mensagens : 270
    Registrado : 05/04/2016

    [Resolvido]Aplicativo lento Empty Re: [Resolvido]Aplicativo lento

    Mensagem  Luís Antunes em Qua Maio 08, 2019 5:39 pm

    Boa tarde H Teixeira
    Só vou ao meu serviço para a semana. O assunto não está esquecido.
    Quanto ao tópico de Manguim, verifiquei todos os códigos e corrigi alguns. Agora só falta testar.
    Até lá
    Luís Antunes
    avatar
    Luís Antunes
    Avançado
    Avançado

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Portugal
    Mensagens : 270
    Registrado : 05/04/2016

    [Resolvido]Aplicativo lento Empty Re: [Resolvido]Aplicativo lento

    Mensagem  Luís Antunes em Ter Maio 21, 2019 6:15 pm

    Boa tarde H Teixeira
    Já fiz o teste e continuou na mesma.
    Alterei o nome do BE, os primeiros números são o IP da máquina, para 10.176.126.254\\Srvusrfiles\cebv_adm\CEBV3\Base\CEBVSTOCK_be.mdb
    Depois do enter ficou assi: 10.176.126.254Srvusrfilescebv_admCEBV3BaseCEBVSTOCK_be.mdb.

    Luís Antunes
    ahteixeira
    ahteixeira
    Moderador Global
    Moderador Global

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Portugal
    Mensagens : 6334
    Registrado : 15/03/2013

    [Resolvido]Aplicativo lento Empty Re: [Resolvido]Aplicativo lento

    Mensagem  ahteixeira em Qua Maio 22, 2019 12:03 pm

    Olá Luís Antunes,

    Da forma que descreveu não deve ter conseguido efetuar a ligação.

    Veja um exemplo de uma ligação efetuada manualmente como fica.
    [Resolvido]Aplicativo lento 113


    Considereando o caminho que mencionou na mensagem nº 20, no seu aplicativo ficaria assim:
    [Resolvido]Aplicativo lento 510

    Ficamos aguardar feedback.

    Abraço
    avatar
    Luís Antunes
    Avançado
    Avançado

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Portugal
    Mensagens : 270
    Registrado : 05/04/2016

    [Resolvido]Aplicativo lento Empty Re: [Resolvido]Aplicativo lento

    Mensagem  Luís Antunes em Sex Jul 12, 2019 10:55 pm

    Nada Feito.
    A pasta partilhada não aceita os traços "\\" dá a mensage de todos os sinai que não aceita incluido este.
    Crying or Very sad

    Luís Antunes

    Conteúdo patrocinado

    [Resolvido]Aplicativo lento Empty Re: [Resolvido]Aplicativo lento

    Mensagem  Conteúdo patrocinado


      Data/hora atual: Qua Out 16, 2019 6:33 pm