MaximoAccess

Caro Usuário, antes de postar pela primeira vez, leia as regras do fórum.

Obrigado

Administração do MaximoAccess

Dicas Ms Access, Exemplos Ms Access, Codigos VBA Ms Access, SQL Ms Access


    [Resolvido]Não consigo lançar dados em um subformulário.

    avatar
    alantardivo
    Intermediário
    Intermediário

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 103
    Registrado : 27/02/2018

    [Resolvido]Não consigo lançar dados em um subformulário. Empty [Resolvido]Não consigo lançar dados em um subformulário.

    Mensagem  alantardivo em 31/3/2019, 13:40

    Olá pessoal, bom dia!

    Estou fazendo alguns testes em um banco e queria ajuda de vocês no seguinte problema.
    Tenho um formulário registrar pedido e lancei neles alguns produtos como teste. Esse formulário se chama Registrar_Pedidos
    segue abaixo a foto.

    https://1drv.ms/u/s!AnlxzVyaVHf4pGhIf3shErm7q255

    Quando eu termino de lançar todo que preciso eu clico no botão finalizar que está abaixo e logo me abrirá uma tela de lançamento no contas a pagar.

    https://1drv.ms/u/s!AnlxzVyaVHf4pGoQcXFza6VjdPx1

    Após atualizar o número de parcelas ele gera na tabela as parcelas mas no subformulário como mostra na imagem acima, ele gera um erro como mostra na imagem abaixo.

    https://1drv.ms/u/s!AnlxzVyaVHf4pGlZeP9nTvyMp0bm

    Ele diz que não existe relação mas o subformulário não tem como fazer uma relação somente entre tabelas e consultas, alguém pode me ajudar???

    Desde já agradeço a todos!!! cheers cheers
    ronaldojr1
    ronaldojr1
    Avançado
    Avançado

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 418
    Registrado : 01/08/2011

    [Resolvido]Não consigo lançar dados em um subformulário. Empty Re: [Resolvido]Não consigo lançar dados em um subformulário.

    Mensagem  ronaldojr1 em 31/3/2019, 16:00

    bom dia,
    Seria mais fácil se você puder mandar o BD para análise,
    mas esse tipo de erro normalmente acontece pq o registro que esta ativo no formulario pai
    ainda não foi salvo e com isso o subformulario nao o localiza pq ele ainda nao existe de certa forma ou pq o registro
    esta bloqueado para edição ai fica pendente que vc o salve antes.
    tente usar o comando abaixo em algum momento do seu código:
    docmd.RunCommand acCmdSaveRecord



    avatar
    alantardivo
    Intermediário
    Intermediário

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 103
    Registrado : 27/02/2018

    [Resolvido]Não consigo lançar dados em um subformulário. Empty Re: [Resolvido]Não consigo lançar dados em um subformulário.

    Mensagem  alantardivo em 31/3/2019, 16:36

    já resolvi amigo, obrigado!

    Conteúdo patrocinado

    [Resolvido]Não consigo lançar dados em um subformulário. Empty Re: [Resolvido]Não consigo lançar dados em um subformulário.

    Mensagem  Conteúdo patrocinado


      Data/hora atual: 21/9/2019, 16:52