MaximoAccess

Caro Usuário, antes de postar pela primeira vez, leia as regras do fórum.

Obrigado

Administração do MaximoAccess

Dicas Ms Access, Exemplos Ms Access, Codigos VBA Ms Access, SQL Ms Access

    [Resolvido]Erro: O tipo definido pelo usuário não foi definido.

    liviskneo
    liviskneo
    Novato
    Novato

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 9
    Registrado : 20/03/2012

    [Resolvido]Erro: O tipo definido pelo usuário não foi definido. Empty Erro: O tipo definido pelo usuário não foi definido.

    Mensagem  liviskneo em 24/4/2012, 16:34

    Pessoal, me ajudem.

    Porque as vezes eu volto a programar em Delphi, por causa de alguns erros que não consigo encontrar solução. Espero que pra esse eu encontre. Tenho um formulário que estava abrindo normalmente, até ontem. Pois hoje fui abrir o formulário e tava o seguinte erro antes de aparecer o formulário:

    "A expressão Ao abrir que você inseriu como definição da propriedade de evento gerou o seguinte erro: O tipo definido pelo usuário não foi definido." E depois vem uns blá blá blá que não explica nada!

    Quando eu excluo o código, ele volta a abrir novamente. Mas quando eu insiro, volta o erro. Então coloquei assim:

    Código:

    Private Sub Form_Open(Cancel As Integer)
        MsgBox "Oi"
    End Sub

    E sabe o que acontece? Novamente o erro! O que eu devo fazer? Obrigado e estou com o projeto aqui parado pra então tá sanando isso e dá a devida continuidade!

    E viva o Access, mesmo que tardia!
    Marcelo David
    Marcelo David
    Moderador
    Moderador

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 2685
    Registrado : 21/04/2011

    [Resolvido]Erro: O tipo definido pelo usuário não foi definido. Empty Re: [Resolvido]Erro: O tipo definido pelo usuário não foi definido.

    Mensagem  Marcelo David em 24/4/2012, 17:04

    Qual a versão do seu Access? Já deu uma olhada nas referencias? Isso parece falta de alguma referencia...

    Veja se a referencia "Visual Basic For Applications" está marcada. Caso não esteja, marque. Caso ainda não resolva, poste aqui seu banco que olharemos para você.


    .................................................................................
    Marcelo David
    www.mrdsystem.com.br (em construção)
    liviskneo
    liviskneo
    Novato
    Novato

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 9
    Registrado : 20/03/2012

    [Resolvido]Erro: O tipo definido pelo usuário não foi definido. Empty Re: [Resolvido]Erro: O tipo definido pelo usuário não foi definido.

    Mensagem  liviskneo em 25/4/2012, 18:07

    Então nobre amigo. Está habilitado sim.

    Inclusive todos os outros formulários estão funcionando perfeitamente, somente este está com defeito.

    Meu Office é o 2007 com SP3 instalado.

    Olhem só o que eu fiz. Criei um novo formulário. Copiei todos os componentes para este formulário. Entrei no modo Visual Basic, e copiei tudo também, deu o mesmo defeito.

    Acredito que seja erro de algum código que eu tenha inserido. O mais interessante é que quando retiro o Form_Open, da pau no Form_Unload. Acabo de descobri também que qualquer coisa que eu acionar o Visual Basic neste formulário ele dá pau, ou seja, essa mesma mensagem... somente neste e exclusivo documento...

    Anexos
    [Resolvido]Erro: O tipo definido pelo usuário não foi definido. AttachmentParaConserto.zip
    Você não tem permissão para fazer download dos arquivos anexados.
    (214 Kb) Baixado 37 vez(es)
    liviskneo
    liviskneo
    Novato
    Novato

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 9
    Registrado : 20/03/2012

    [Resolvido]Erro: O tipo definido pelo usuário não foi definido. Empty Re: [Resolvido]Erro: O tipo definido pelo usuário não foi definido.

    Mensagem  liviskneo em 25/4/2012, 18:08

    Estou precisando urgente disso quem puder me ajudar, desde já antecipo meus agradecimentos!
    liviskneo
    liviskneo
    Novato
    Novato

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 9
    Registrado : 20/03/2012

    [Resolvido]Erro: O tipo definido pelo usuário não foi definido. Empty Re: [Resolvido]Erro: O tipo definido pelo usuário não foi definido.

    Mensagem  liviskneo em 25/4/2012, 18:47

    Atenção caros amigos,


    Acabo de resolver o problema. Acho que desesperei a toa. Eu compilei o Banco de Dados e vi que havia declarado uma variável errada no escopo pública.

    Mesmo assim, obrigado pela calorosa atenção!
    Marcelo David
    Marcelo David
    Moderador
    Moderador

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 2685
    Registrado : 21/04/2011

    [Resolvido]Erro: O tipo definido pelo usuário não foi definido. Empty Re: [Resolvido]Erro: O tipo definido pelo usuário não foi definido.

    Mensagem  Marcelo David em 25/4/2012, 19:06

    É realmente vi uma declaração do tipo Bytel...
    Você usa um módulo de Ribbons personalizadas, terá que marcar a referencia:
    Microsoft Office 12.0 Object Library... Aqui nesse exemplo não está marcada...



    .................................................................................
    Marcelo David
    www.mrdsystem.com.br (em construção)
    Gilberto Rocha
    Gilberto Rocha
    Developer
    Developer

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 1025
    Registrado : 21/01/2010

    [Resolvido]Erro: O tipo definido pelo usuário não foi definido. Empty Re: [Resolvido]Erro: O tipo definido pelo usuário não foi definido.

    Mensagem  Gilberto Rocha em 25/4/2012, 19:13

    Recomendação, a cada alteração de código, compile o banco para ver se existem erros e depois utilize o compactar /reparar, assim nunca terá problemas do tipo.
    liviskneo
    liviskneo
    Novato
    Novato

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 9
    Registrado : 20/03/2012

    [Resolvido]Erro: O tipo definido pelo usuário não foi definido. Empty Aos meus nobres colegas

    Mensagem  liviskneo em 25/4/2012, 21:38

    Meu muitíssimo obrigado!

    Que Deus abençoe sempre vocês!
    Marcelo David
    Marcelo David
    Moderador
    Moderador

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 2685
    Registrado : 21/04/2011

    [Resolvido]Erro: O tipo definido pelo usuário não foi definido. Empty Re: [Resolvido]Erro: O tipo definido pelo usuário não foi definido.

    Mensagem  Marcelo David em 25/4/2012, 22:22

    Grato pelo retorno, bom trabalho!


    .................................................................................
    Marcelo David
    www.mrdsystem.com.br (em construção)
    crysostomo
    crysostomo
    Super Avançado
    Super Avançado

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 557
    Registrado : 23/01/2018

    [Resolvido]Erro: O tipo definido pelo usuário não foi definido. Empty Re: [Resolvido]Erro: O tipo definido pelo usuário não foi definido.

    Mensagem  crysostomo em 12/8/2018, 01:07

    Meus amigos, já habilitei as referencias e continua o mesmo problema " O tipo definido pelo usuário não foi definido"

      Data/hora atual: 26/4/2019, 01:21