MaximoAccess

Caro Usuário, antes de postar pela primeira vez, leia as regras do fórum.

https://www.maximoaccess.com/t48-regras-do-forum

Obrigado

Administração


Participe do fórum, é rápido e fácil

MaximoAccess

Caro Usuário, antes de postar pela primeira vez, leia as regras do fórum.

https://www.maximoaccess.com/t48-regras-do-forum

Obrigado

Administração

MaximoAccess

Gostaria de reagir a esta mensagem? Crie uma conta em poucos cliques ou inicie sessão para continuar.

Dicas Ms Access, Exemplos Ms Access, Codigos VBA Ms Access, SQL Ms Access

3 participantes

    [Resolvido]Alterei a Máscara de Entrada da minha tabela, porém não atualizou para os formulários existentes.

    avatar
    lukinhaxdx
    Novato
    Novato


    Respeito às regras : Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 21
    Registrado : 14/01/2012

    [Resolvido]Alterei a Máscara de Entrada da minha tabela, porém não atualizou para os formulários existentes. Empty [Resolvido]Alterei a Máscara de Entrada da minha tabela, porém não atualizou para os formulários existentes.

    Mensagem  lukinhaxdx Sab 02 Fev 2013, 7:11 pm

    Bom Dia a todos do Fórum.

    Tenho um Banco de Dados que por sinal já está muito bem estruturado e bem complexo, porém o burrão aqui cometeu um erro.

    Tenho diversos tipos de cadastros e seus códigos para cada registro (Numeração automática).

    Como o BD gerencia uma Organização muito diversa, tenho diversos cadastros e então resolvi colocar uma sigla anterior ao número para evitar complicações.

    Ex. Cadastro de Associados "RCA-0000" - "MCA-0000" - "MNC-0000" - "CLS-0000"

    Porém depois de alterado na tabela, os formulários não atenderam e continuam no formato "0000".

    Como posso tentar resolver isso sem correr o risco de danificar meus dados cadastrados.
    HARYSOHN
    HARYSOHN
    Maximo VIP
    Maximo VIP


    Respeito às regras : Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 12226
    Registrado : 01/03/2011

    [Resolvido]Alterei a Máscara de Entrada da minha tabela, porém não atualizou para os formulários existentes. Empty Re: [Resolvido]Alterei a Máscara de Entrada da minha tabela, porém não atualizou para os formulários existentes.

    Mensagem  HARYSOHN Sab 02 Fev 2013, 8:29 pm

    Se na tabela estas assim, verifique a formatação da tua caixa texto no form ou veja se o mesmo tem mascara de entrada.

    Se possivel disponibilize um form e uma tabela para vermos.

    Cumprimentos.
    Lupércio
    Lupércio
    VIP
    VIP


    Respeito às regras : Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 1145
    Registrado : 06/05/2011

    [Resolvido]Alterei a Máscara de Entrada da minha tabela, porém não atualizou para os formulários existentes. Empty Re: [Resolvido]Alterei a Máscara de Entrada da minha tabela, porém não atualizou para os formulários existentes.

    Mensagem  Lupércio Dom 03 Fev 2013, 1:09 pm

    Tem como postar o bd, ou parte dele!
    avatar
    lukinhaxdx
    Novato
    Novato


    Respeito às regras : Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 21
    Registrado : 14/01/2012

    [Resolvido]Alterei a Máscara de Entrada da minha tabela, porém não atualizou para os formulários existentes. Empty Re: [Resolvido]Alterei a Máscara de Entrada da minha tabela, porém não atualizou para os formulários existentes.

    Mensagem  lukinhaxdx Dom 03 Fev 2013, 3:03 pm

    Obrigado por responderem.

    Vou tentar recriar isso em outro BD ou procurar por uma versão de teste. Esse BD que chamo de SIGAH tem dados cadastrais de centenas de pessoas.

    Mais uma informação.

    Quando verifico PROPRIEDADES > DADOS > Mascara Entrada no formulário, mesmo depois de atualizar na Tabela o campo para a nova mascara, no formulário fica igual a anterior.

    Ex.
    Antes: FORMATO: 0000 e MASCARA 0000;0;"0"
    Agora: FORMATO: "RCA-"0000 e MASCARA "RCA-"0000;0;"0"

    As mascaras funcionam perfeitamente, porém caso não tenha outro jeito, terei q atualizar Form por Form, Relatório por Relatório para as novas mascaras.

    O quanto antes postarei o BD de exemplo. Muito obrigado mesmo.
    Lupércio
    Lupércio
    VIP
    VIP


    Respeito às regras : Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 1145
    Registrado : 06/05/2011

    [Resolvido]Alterei a Máscara de Entrada da minha tabela, porém não atualizou para os formulários existentes. Empty Re: [Resolvido]Alterei a Máscara de Entrada da minha tabela, porém não atualizou para os formulários existentes.

    Mensagem  Lupércio Dom 03 Fev 2013, 3:21 pm

    Vou te dar uma ideia!

    1 - Crie uma consulta, só com o campo que vc alterou a mascara de entrada.
    2 - Crie um formulário continuo só com este campo, com origem na consulta que vc criou!
    3 - Abra o formulário.
    4 - Não adicione botão algum e segure o enter apertado, ele atualizará rapidinho.


    Última edição por PILOTO em Ter 26 Fev 2013, 7:29 pm, editado 1 vez(es) (Motivo da edição : Tópico marcado como resolvido por falta de resposta - MODERAÇÃO)

      Data/hora atual: Seg 05 Dez 2022, 1:46 pm