MaximoAccess

Caro Usuário, antes de postar pela primeira vez, leia as regras do fórum.

https://www.maximoaccess.com/t48-regras-do-forum

Obrigado

Administração


Participe do fórum, é rápido e fácil

MaximoAccess

Caro Usuário, antes de postar pela primeira vez, leia as regras do fórum.

https://www.maximoaccess.com/t48-regras-do-forum

Obrigado

Administração

MaximoAccess

Gostaria de reagir a esta mensagem? Crie uma conta em poucos cliques ou inicie sessão para continuar.

Dicas Ms Access, Exemplos Ms Access, Codigos VBA Ms Access, SQL Ms Access

2 participantes

    [Resolvido]Valor padrão

    Luciana-bio
    Luciana-bio
    Avançado
    Avançado


    Respeito às regras : Respeito às Regras 100%

    Sexo : Feminino
    Localização : Brasil
    Mensagens : 204
    Registrado : 16/02/2011

    [Resolvido]Valor padrão Empty Valor padrão

    Mensagem  Luciana-bio 15/7/2013, 02:09

    Tenho um campo em uma tabela que gostaria que tivesse o texto "NÃO" sempre que fosse aberto um novo registro. Como se fosse o padrão do campo. Como posso fazer isso?
    Nivaldo
    Nivaldo
    Developer
    Developer


    Respeito às regras : Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 708
    Registrado : 08/12/2009

    [Resolvido]Valor padrão Empty Re: [Resolvido]Valor padrão

    Mensagem  Nivaldo 15/7/2013, 03:41

    Boa noite Luciana,

    No formulário, na folha de propriedades do campo, guia Dados, Valor Padrão.
    Pode também colocar diretamente na tabela
    Modo estrutura (tabela), propriedades do campo, Valor Padrão.

    Se entendi bem, deve resolver.


    Nivaldo.


    Última edição por Nivaldo em 15/7/2013, 03:45, editado 1 vez(es)
    Luciana-bio
    Luciana-bio
    Avançado
    Avançado


    Respeito às regras : Respeito às Regras 100%

    Sexo : Feminino
    Localização : Brasil
    Mensagens : 204
    Registrado : 16/02/2011

    [Resolvido]Valor padrão Empty Re: [Resolvido]Valor padrão

    Mensagem  Luciana-bio 15/7/2013, 03:44

    Boa noite Nivaldo!!!!

    Já tentei, mas não consegui.

    Eu quero que apareça a palavra "NÃO".

    Já coloquei essa palavra, mas não aparece.
    Nivaldo
    Nivaldo
    Developer
    Developer


    Respeito às regras : Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 708
    Registrado : 08/12/2009

    [Resolvido]Valor padrão Empty Re: [Resolvido]Valor padrão

    Mensagem  Nivaldo 15/7/2013, 03:47

    Você tentou na tabela ou no formulário??


    Nivaldo.
    Luciana-bio
    Luciana-bio
    Avançado
    Avançado


    Respeito às regras : Respeito às Regras 100%

    Sexo : Feminino
    Localização : Brasil
    Mensagens : 204
    Registrado : 16/02/2011

    [Resolvido]Valor padrão Empty Re: [Resolvido]Valor padrão

    Mensagem  Luciana-bio 15/7/2013, 03:50

    Na tabela.

    Vou tentar explicar melhor: Na minha tabela eu tenho um campo onde quero apenas dois valores possíveis. Ou "SIM" ou "NÃO", Sendo que quero abrir o formulário dessa tabela e apareça o "NÃO" como padrão.
    Nivaldo
    Nivaldo
    Developer
    Developer


    Respeito às regras : Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 708
    Registrado : 08/12/2009

    [Resolvido]Valor padrão Empty Re: [Resolvido]Valor padrão

    Mensagem  Nivaldo 15/7/2013, 03:57

    Então vamos lá:

    - Abra sua tabela no modo estrutura (Design);
    - Clique em cima do campo que você quer colocar o valor padrão;
    - Na parte de baixo (propriedades do campo) vá em Valor Padrão (5º item de cima para baixo) e coloque o valor que você deseja.


    Nivaldo.
    Luciana-bio
    Luciana-bio
    Avançado
    Avançado


    Respeito às regras : Respeito às Regras 100%

    Sexo : Feminino
    Localização : Brasil
    Mensagens : 204
    Registrado : 16/02/2011

    [Resolvido]Valor padrão Empty Re: [Resolvido]Valor padrão

    Mensagem  Luciana-bio 15/7/2013, 04:01

    Nivaldo fiz exatamente o que mandou e nada.

    Tenho que colocar a palavra que eu quero entre aspas ou solta mesmo?
    Nivaldo
    Nivaldo
    Developer
    Developer


    Respeito às regras : Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 708
    Registrado : 08/12/2009

    [Resolvido]Valor padrão Empty Re: [Resolvido]Valor padrão

    Mensagem  Nivaldo 15/7/2013, 04:04

    Luciana,

    Seria solta mesmo, sem aspas.

    Qual é o tipo de dados do campo em questão???


    Nivaldo.
    Luciana-bio
    Luciana-bio
    Avançado
    Avançado


    Respeito às regras : Respeito às Regras 100%

    Sexo : Feminino
    Localização : Brasil
    Mensagens : 204
    Registrado : 16/02/2011

    [Resolvido]Valor padrão Empty Re: [Resolvido]Valor padrão

    Mensagem  Luciana-bio 15/7/2013, 04:06

    Está selecionado como texto. Tem outra sugestão?
    Nivaldo
    Nivaldo
    Developer
    Developer


    Respeito às regras : Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 708
    Registrado : 08/12/2009

    [Resolvido]Valor padrão Empty Re: [Resolvido]Valor padrão

    Mensagem  Nivaldo 15/7/2013, 04:07

    Já tentou no formulário????


    Nivaldo.
    Luciana-bio
    Luciana-bio
    Avançado
    Avançado


    Respeito às regras : Respeito às Regras 100%

    Sexo : Feminino
    Localização : Brasil
    Mensagens : 204
    Registrado : 16/02/2011

    [Resolvido]Valor padrão Empty Re: [Resolvido]Valor padrão

    Mensagem  Luciana-bio 15/7/2013, 04:24

    Acho que já sei o que está acontecendo. Eu esperava que aparecesse o "NÃO" até nos registros que já estão salvos antes da adição desse campo, mas só está aparecendo para os novos. Metade do problema resolvido.

    O que estou achando estranho é que para os novos aparece a palavra "NO" ao invés de "NÃO". Por que será?


    Luciana-bio
    Luciana-bio
    Avançado
    Avançado


    Respeito às regras : Respeito às Regras 100%

    Sexo : Feminino
    Localização : Brasil
    Mensagens : 204
    Registrado : 16/02/2011

    [Resolvido]Valor padrão Empty Re: [Resolvido]Valor padrão

    Mensagem  Luciana-bio 15/7/2013, 04:26

    Olhe só como aparece NO ao invés de NÃO neste exemplo.
    Anexos
    [Resolvido]Valor padrão AttachmentTESTE.zip
    Você não tem permissão para fazer download dos arquivos anexados.
    (22 Kb) Baixado 3 vez(es)
    Nivaldo
    Nivaldo
    Developer
    Developer


    Respeito às regras : Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 708
    Registrado : 08/12/2009

    [Resolvido]Valor padrão Empty Re: [Resolvido]Valor padrão

    Mensagem  Nivaldo 15/7/2013, 04:28

    Você deve estar colocando Não com o til ( ~).

    Retira e ver se dar certo.


    Nivaldo.
    Luciana-bio
    Luciana-bio
    Avançado
    Avançado


    Respeito às regras : Respeito às Regras 100%

    Sexo : Feminino
    Localização : Brasil
    Mensagens : 204
    Registrado : 16/02/2011

    [Resolvido]Valor padrão Empty Re: [Resolvido]Valor padrão

    Mensagem  Luciana-bio 15/7/2013, 04:40

    Isso mesmo. Acertou no alvo!!!!!

    Abusando mais um pouquinho de vc, pode me ajudar com relação a esse mesmo campo?

    Pelo que já viu, o valor padrão é NAO. Quando esse valor for modificado para SIM, gostaria que aparecesse o seguinte aviso:

    "A Carta de Encaminhamento já foi gerada?"

    Caso a pessoa tecle sim, ela tem permissão de alterar o campo para sim. Caso tecle não, ela não consegue alterar o campo para SIM.

    Pode me ajudar?



    Nivaldo
    Nivaldo
    Developer
    Developer


    Respeito às regras : Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 708
    Registrado : 08/12/2009

    [Resolvido]Valor padrão Empty Re: [Resolvido]Valor padrão

    Mensagem  Nivaldo 15/7/2013, 12:00

    Olá Luciana,

    Existem outras maneiras mais profissionais de se fazer isso, más pode ser feito assim.


    Nivaldo.
    Anexos
    [Resolvido]Valor padrão AttachmentTESTELUCIANA.zip
    Você não tem permissão para fazer download dos arquivos anexados.
    (17 Kb) Baixado 11 vez(es)
    Luciana-bio
    Luciana-bio
    Avançado
    Avançado


    Respeito às regras : Respeito às Regras 100%

    Sexo : Feminino
    Localização : Brasil
    Mensagens : 204
    Registrado : 16/02/2011

    [Resolvido]Valor padrão Empty Re: [Resolvido]Valor padrão

    Mensagem  Luciana-bio 15/7/2013, 12:49

    Nivaldo, acabei de ver o seu modelo. Vou tentar aplicar. Vou dar esse tópico como encerrado, porque a questão principal já foi resolvido porem volto a te perturbar aqui mesmo para dizer se consegui aplicar sua sugestão.

    Valeu!!!!!
    Nivaldo
    Nivaldo
    Developer
    Developer


    Respeito às regras : Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 708
    Registrado : 08/12/2009

    [Resolvido]Valor padrão Empty Re: [Resolvido]Valor padrão

    Mensagem  Nivaldo 15/7/2013, 22:52

    Ok Luciana,

    Qualquer dúvida é só gritar.

    Nivaldo.

      Data/hora atual: 22/1/2022, 17:29