MaximoAccess

Caro Usuário, antes de postar pela primeira vez, leia as regras do fórum.

Obrigado

Administração do MaximoAccess


Participe do fórum, é rápido e fácil

MaximoAccess

Caro Usuário, antes de postar pela primeira vez, leia as regras do fórum.

Obrigado

Administração do MaximoAccess

MaximoAccess

Gostaria de reagir a esta mensagem? Crie uma conta em poucos cliques ou inicie sessão para continuar.

Dicas Ms Access, Exemplos Ms Access, Codigos VBA Ms Access, SQL Ms Access

    Ajuda com aplicativo

    avatar
    dimi
    Novato
    Novato

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 5
    Registrado : 28/06/2014

    Ajuda com aplicativo Empty Ajuda com aplicativo

    Mensagem  dimi 1/7/2014, 20:55

    Boa tarde!

    Criei um aplicativo no Acess 2007. Porém, toda vez que tentou entrar nele aparece uma mensagem de erro, dizendo que o aplicativo será fechado. Já instalei este aplicativo em várias máquinas e acontece o mesmo erro. O que será que esta acontecendo?
    ahteixeira
    ahteixeira
    Moderador Global
    Moderador Global

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Portugal
    Mensagens : 7100
    Registrado : 15/03/2013

    Ajuda com aplicativo Empty Re: Ajuda com aplicativo

    Mensagem  ahteixeira 1/7/2014, 22:49

    Ola


    Tente abrir com a tecla Shift primida (ao clicar duas vezes no nome do seu projeto)
    avatar
    dimi
    Novato
    Novato

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 5
    Registrado : 28/06/2014

    Ajuda com aplicativo Empty Re: Ajuda com aplicativo

    Mensagem  dimi 2/7/2014, 00:16

    Boa noite!

    Já tentei esse procedimento. O problema é quando estou em pleno uso. O aplicativo para do nada. Uma mensagem aparece dizendo que o Acess será fechado.
    ahteixeira
    ahteixeira
    Moderador Global
    Moderador Global

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Portugal
    Mensagens : 7100
    Registrado : 15/03/2013

    Ajuda com aplicativo Empty Re: Ajuda com aplicativo

    Mensagem  ahteixeira 2/7/2014, 00:35

    Tenta compliar codigo para ver se tem algum erro

    e compactar
    avatar
    dimi
    Novato
    Novato

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 5
    Registrado : 28/06/2014

    Ajuda com aplicativo Empty Re: Ajuda com aplicativo

    Mensagem  dimi 2/7/2014, 21:50

    Como realizo esse procedimento?
    ahteixeira
    ahteixeira
    Moderador Global
    Moderador Global

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Portugal
    Mensagens : 7100
    Registrado : 15/03/2013

    Ajuda com aplicativo Empty Re: Ajuda com aplicativo

    Mensagem  ahteixeira 2/7/2014, 22:54

    Ola,

    Abre o teu projeto em Acceess pode ser com tecla Shift, e depois abre a janela de código (ALT+F11)
    Depois na opção do menu Debug na sub-opção Compile ...

    Também poderás verificar se tem alguma referencia em falta.
    Verifica mensagem nº 4 do artigo abaixo como exemplo:

    http://maximoaccess.forumeiros.com/t19192-access-nao-abre-imagem-jpg-de-8-bits-escala-de-cinza

    Se estiver em faltá aparece MISSING
    avatar
    Kaynan
    Maximo VIP
    Maximo VIP

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 2573
    Registrado : 09/04/2012

    Ajuda com aplicativo Empty Re: Ajuda com aplicativo

    Mensagem  Kaynan 3/7/2014, 01:44

    Ola dimi,se não der certo poste o banco pra gente ver que esta acontecendo.
    Abçs.
    ahteixeira
    ahteixeira
    Moderador Global
    Moderador Global

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Portugal
    Mensagens : 7100
    Registrado : 15/03/2013

    Ajuda com aplicativo Empty Re: Ajuda com aplicativo

    Mensagem  ahteixeira 12/8/2014, 12:30

    Olá Dimi, como vai a situação o forum agradece o retorno.

    Se está concluído, não se esqueça de dar o tópico como resolvido, veja link abaixo:
    http://maximoaccess.forumeiros.com/t860-resolucao-de-topicos
    avatar
    Jasmim Lirio
    Novato
    Novato

    Respeito às Regras 100%

    Sexo : Feminino
    Localização : Brasil
    Mensagens : 6
    Registrado : 22/01/2014

    Ajuda com aplicativo Empty Re: Ajuda com aplicativo

    Mensagem  Jasmim Lirio 13/8/2014, 03:24

    Não implantei as soluções sugeridas, pois como disse, tal erro passou a ocorrer recentemente e além disso somente com as versão 2010 do Access. Além disso, meus conhecimentos em Access são muito básicos e eu não quero criar novos problemas...

    Só gostaria de fazer uma correção quando relatei o problema. Observei melhor e constatei que o erro NÃO ocorre quando o usuário abre o banco de dados no Access 2010.

    Eu criei um menu principal, onde o usuário tem a opção de CRIAR NOVO, EDITAR ou CONSULTAR o registro com as informações da empresa (como nome, endereço, telefones de contato etc..). Então, toda vez que o usuário clica no ícone do "editar" e o arquivo já está aberto em outra máquina, aparece (mas não aparecia) uma janelinha com uma mensagem que diz + ou - assim: “há usuário com o arquivo aberto no modo design, você não tem acesso exclusivo ao banco de dados. Se você continuar a fazer alterações, você não poderá salvá-las." Aí, o usuário clica em “OK” várias vezes até fechar a janela. Então, aparece o formulário como o último registro cadastrado e, a partir daí o usuário trabalha normalmente, ou seja, pode alterar as informações da "ficha" da empresa.

    A janelinha com a mensagem não aparece se o usuário apenas consultar o registro ou criar um novo.

    Com esta nova informação, alguma ideia do motivo do problema?
    ahteixeira
    ahteixeira
    Moderador Global
    Moderador Global

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Portugal
    Mensagens : 7100
    Registrado : 15/03/2013

    Ajuda com aplicativo Empty Re: Ajuda com aplicativo

    Mensagem  ahteixeira 13/8/2014, 14:36

    Olá, não eram implementações, mas sim procedimentos de verificação, devemos compilar o código para verificar se temos alguma instrução que não esteja bem. No entanto adiante.
    Parece que detetaste que em determinada situação é que acontece o erro, deves então verificar.
    Relativamente à ficha da identidade da empresa (nome, morada, etc) deves ter algum problema no código.
    Existem duas possibilidades para funcionamento em rede (apesar de não ser um campo que se está a alterar todos os dias)

    a) Ao abrir a aplicação (num posto), faz uma consulta à tabela e passar para variaveis publicas (tem um contra é que se um utilizador alterar, só na proxima abertura é que vai atualizar as variaveis)
    b) Conforme utilizo nas minhas apps
    1) quando necessito num formulário ao abrir faz consulta e atribui a campos independentes
    2) nos relatórios já tenho um relatório chamado CABEÇALHO que é incluído em todos os relatórios que tenho como subformulário (apresentado sempre os dados da entidade)

    Verifique se consegues resolver, se não tenta colocar uma base de dados com os campos necessarios apenas para testar esse formulario.

    Abraço

      Data/hora atual: 4/3/2021, 12:31