MaximoAccess

Caro Usuário, antes de postar pela primeira vez, leia as regras do fórum.

https://www.maximoaccess.com/t48-regras-do-forum

Obrigado

Administração


Participe do fórum, é rápido e fácil

MaximoAccess

Caro Usuário, antes de postar pela primeira vez, leia as regras do fórum.

https://www.maximoaccess.com/t48-regras-do-forum

Obrigado

Administração

MaximoAccess

Gostaria de reagir a esta mensagem? Crie uma conta em poucos cliques ou inicie sessão para continuar.

Dicas Ms Access, Exemplos Ms Access, Codigos VBA Ms Access, SQL Ms Access

    [Resolvido]Relatório perdendo formatação

    avatar
    kitsuneelt
    Intermediário
    Intermediário

    Respeito às regras : Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 52
    Registrado : 25/08/2014

    [Resolvido]Relatório perdendo formatação Empty [Resolvido]Relatório perdendo formatação

    Mensagem  kitsuneelt 3/11/2014, 18:21

    Galera alguém pode dar uma ajuda, quando mando gerar o relatório o valor fica assim como está abaixo

    Valor
    0,607999992370606
    0,16
    1,07199996948242

    Está tudo certo, deixei o formato como padrão com duas casas decimais.

    Alguém sabe o que posso estar errando, eu tenho uma outra tabela não com as mesmas informações e sai tudo normal só esse que está dando este erro.

    Este valor vem de uma multiplicação exemplo:

    3,8 * 0,16
    1,0 * 0,16
    6,7 * 0,16
    Alexandre Neves
    Alexandre Neves
    Moderador Global
    Moderador Global

    Respeito às regras : Respeito às Regras 100%

    Sexo : Masculino
    Localização : Portugal
    Mensagens : 7930
    Registrado : 05/11/2009

    [Resolvido]Relatório perdendo formatação Empty Re: [Resolvido]Relatório perdendo formatação

    Mensagem  Alexandre Neves 3/11/2014, 20:34

    Boa noite,
    Onde coloca a instrução de multiplicação, coloque a formatação que pretende


    .................................................................................
    Access 2010. Mande bd que dê para testar (indique a versão). Não peça para fazer o que já tem feito. Dê todos os detalhes.
    Não coloquem entraves como senhas, esconder controlos, etc. Disponibilizem o mais limpo possível
    Só respondo a mensagens privadas, se forem de assunto privado; às outras não respondo.
    Quem trabalha e mata a fome não come o pão de ninguém; mas quem não trabalha e come, come sempre o pão de alguém. António Aleixo
    avatar
    kitsuneelt
    Intermediário
    Intermediário

    Respeito às regras : Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 52
    Registrado : 25/08/2014

    [Resolvido]Relatório perdendo formatação Empty Re: [Resolvido]Relatório perdendo formatação

    Mensagem  kitsuneelt 4/11/2014, 12:37

    Consegui resolver meu problema.

    Quando crio meu campo virtual eu coloquei o FormatNumber([coluna];1) e ficou como queria ai quando faço a multiplicação ficou certa.

      Data/hora atual: 11/4/2021, 14:25