MaximoAccess

Caro Usuário, antes de postar pela primeira vez, leia as regras do fórum.

https://www.maximoaccess.com/t48-regras-do-forum

Obrigado

Administração


Participe do fórum, é rápido e fácil

MaximoAccess

Caro Usuário, antes de postar pela primeira vez, leia as regras do fórum.

https://www.maximoaccess.com/t48-regras-do-forum

Obrigado

Administração

MaximoAccess

Gostaria de reagir a esta mensagem? Crie uma conta em poucos cliques ou inicie sessão para continuar.

Dicas Ms Access, Exemplos Ms Access, Codigos VBA Ms Access, SQL Ms Access

    [Resolvido]Relatório Ficando em Branco Ao Gerar PDF

    avatar
    vailson
    Intermediário
    Intermediário

    Respeito às regras : Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 160
    Registrado : 08/05/2015

    [Resolvido]Relatório Ficando em Branco Ao Gerar PDF Empty [Resolvido]Relatório Ficando em Branco Ao Gerar PDF

    Mensagem  vailson 13/5/2015, 17:58

    Olá Senhores,
    Após a geração do relatório, na tela ele exibe as informações corretamente.
    Porém ao exportar para PDF, ou Imprimir, aparece um pop-up me pedindo informações do critério da busca utilizada para gerar o relatório.

    Esse critério é utilizado para filtrar o período do relatório:
    Entre [Formulários]![frmAbreRelatórios]![dtInicial] E [Formulários]![frmAbreRelatórios]![dtFinal]

    O interessante é que o relatório aparece normal na tela. Esse erro é só ao solicitar Impressão ou Exportação em PDF.
    Qual o problema?


    Normal na Visualização:
    [Resolvido]Relatório Ficando em Branco Ao Gerar PDF J0i5mw


    Erro ao exportar:
    [Resolvido]Relatório Ficando em Branco Ao Gerar PDF J58osn
    avatar
    Function Computers
    Novato
    Novato

    Respeito às regras : Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 29
    Registrado : 23/02/2015

    [Resolvido]Relatório Ficando em Branco Ao Gerar PDF Empty Re: [Resolvido]Relatório Ficando em Branco Ao Gerar PDF

    Mensagem  Function Computers 13/5/2015, 19:22

    Boa Tarde

    No formulário "frmAbreRelatório" no botão que gera o relatório coloque:

    Me.visible = false

    E ao fechar o relatório (se pretender abrir o formulário "frmAbreRelatório") coloquei:

    Forms!frmAbreRelatório.visible=true


    Eu uso isso há algum tem esta dando certo.
    Silvio
    Silvio
    Developer
    Developer

    Respeito às regras : Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 4719
    Registrado : 20/04/2011

    [Resolvido]Relatório Ficando em Branco Ao Gerar PDF Empty Re: [Resolvido]Relatório Ficando em Branco Ao Gerar PDF

    Mensagem  Silvio 13/5/2015, 20:11

    Apenas um pitaco...

    O mesmo está pedindo a data inicial para gerar esse relatório ! Provavelmente esse critério deve estar em alguma consulta como filtro.



    .................................................................................
    Caso tenha resolvido a tua duvida, coloque o tópico como resolvido.
    www.maximoaccess.com/t860-resolucao-de-topicos

    "Quase tudo é possível quando se tem determinação e força de vontade. Não desista tão rápido."
    Uilson Brasil
    Uilson Brasil
    VIP
    VIP

    Respeito às regras : Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 1037
    Registrado : 23/04/2013

    [Resolvido]Relatório Ficando em Branco Ao Gerar PDF Empty Re: [Resolvido]Relatório Ficando em Branco Ao Gerar PDF

    Mensagem  Uilson Brasil 13/5/2015, 22:49

    Vailson provavelmente você está fechando o formulário ao clicar no botão que gera o relatório. Se for isso, a dica da Mensagem nº2 resolve o teu problema.


    Abraços,


    .................................................................................
    ::: Uilson Brasil
    ::: Design in Microsoft Access
    avatar
    vailson
    Intermediário
    Intermediário

    Respeito às regras : Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 160
    Registrado : 08/05/2015

    [Resolvido]Relatório Ficando em Branco Ao Gerar PDF Empty Re: [Resolvido]Relatório Ficando em Branco Ao Gerar PDF

    Mensagem  vailson 14/5/2015, 01:04

    Uilson Brasil, vc está certo. Eu sou iniciante e dei esse mole.
    Para deixar mais "bonito", coloquei uma macro fechando o formulário ao abrir o relatório Embarassed
    Quando retirei a macro e deixei o formulário aberto, funcionou.

    Só a título de aprendizagem, esse é o código que está no botão:

    Private Sub cmdAbrirRel_Click()
    If IsNull(Me.dtInicial) Or IsNull(Me.dtFinal) Then
      MsgBox "Um dos campos do período está em branco." + vbCrLf + "Favor digitar.", vbInformation, "Período"
      Exit Sub
    End If
    DoCmd.OpenReport "rptRelatório", acViewPreview
    End Sub

    Tentei inserir o comando me.visible = false e não deu certo. Em que lugar devo inserir ele? Sei que não pode depois do End Sub What a Face

    Vou clicar em resolvido, mas se puder me responda isso aí.


    Última edição por vailson em 14/5/2015, 01:14, editado 1 vez(es)
    Silvio
    Silvio
    Developer
    Developer

    Respeito às regras : Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 4719
    Registrado : 20/04/2011

    [Resolvido]Relatório Ficando em Branco Ao Gerar PDF Empty Re: [Resolvido]Relatório Ficando em Branco Ao Gerar PDF

    Mensagem  Silvio 14/5/2015, 01:12

    Aqui temos um erro...vamos corrigir ele...

    Private Sub cmdAbrirRel_Click()
    If IsNull(Me.dtInicial) Or IsNull(Me.dtFinal) Then
    MsgBox "Um dos campos do período está em branco." + vbCrLf + "Favor digitar.", vbInformation, "Período"
    Exit Sub
    else
    DoCmd.OpenReport "rptRelatório", acViewPreview
    end if
    End Sub


    .................................................................................
    Caso tenha resolvido a tua duvida, coloque o tópico como resolvido.
    www.maximoaccess.com/t860-resolucao-de-topicos

    "Quase tudo é possível quando se tem determinação e força de vontade. Não desista tão rápido."
    avatar
    vailson
    Intermediário
    Intermediário

    Respeito às regras : Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 160
    Registrado : 08/05/2015

    [Resolvido]Relatório Ficando em Branco Ao Gerar PDF Empty Re: [Resolvido]Relatório Ficando em Branco Ao Gerar PDF

    Mensagem  vailson 14/5/2015, 01:16

    Vc pode explicar a diferença Silvio?
    Silvio
    Silvio
    Developer
    Developer

    Respeito às regras : Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 4719
    Registrado : 20/04/2011

    [Resolvido]Relatório Ficando em Branco Ao Gerar PDF Empty Re: [Resolvido]Relatório Ficando em Branco Ao Gerar PDF

    Mensagem  Silvio 14/5/2015, 01:23

    Vamos lá....


    Private Sub cmdAbrirRel_Click()
    If IsNull(Me.dtInicial) Or IsNull(Me.dtFinal) Then -> se estiver nulo a minha data inicial ou é nulo a minha final então
    MsgBox "Um dos campos do período está em branco." + vbCrLf + "Favor digitar.", vbInformation, "Período" --> aparece a mensagem
    Exit Sub --> saia da rotina, aqui está um provável erro sem um else, mas somente testando
    End If --> fim do comando se
    DoCmd.OpenReport "rptRelatório", acViewPreview abra o relatorio tal, no modo "previu" !!!
    End Sub


    Explicando: faltou um Else ( senão ) na linha de comando.

    Outra coisa que poderia ajudar, é disponibilizar o projeto para ajudarmos você, pois estamos no campo das especulações e achismo.


    .................................................................................
    Caso tenha resolvido a tua duvida, coloque o tópico como resolvido.
    www.maximoaccess.com/t860-resolucao-de-topicos

    "Quase tudo é possível quando se tem determinação e força de vontade. Não desista tão rápido."
    avatar
    vailson
    Intermediário
    Intermediário

    Respeito às regras : Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 160
    Registrado : 08/05/2015

    [Resolvido]Relatório Ficando em Branco Ao Gerar PDF Empty Re: [Resolvido]Relatório Ficando em Branco Ao Gerar PDF

    Mensagem  vailson 14/5/2015, 01:59

    Claro, olha ele aí:
    Como vc viu acima, eu encontrei o erro. Eu tinha colocado a macro pra fechar o formulário.

    Agora eu estou com uma dúvida em consulta
    https://www.maximoaccess.com/t22871-totalizar-resultados-iguais-em-uma-consulta

    A versão atual é essa:
    http://www.4shared.com/file/kk9B0Cv5ba/Sistema16CenopV43.html
    Não a da dúvida.
    Se puder me ajudar...
    avatar
    vailson
    Intermediário
    Intermediário

    Respeito às regras : Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 160
    Registrado : 08/05/2015

    [Resolvido]Relatório Ficando em Branco Ao Gerar PDF Empty Re: [Resolvido]Relatório Ficando em Branco Ao Gerar PDF

    Mensagem  vailson 14/5/2015, 02:51

    cheers

      Data/hora atual: 13/4/2021, 14:15