MaximoAccess

Caro Usuário, antes de postar pela primeira vez, leia as regras do fórum.

https://www.maximoaccess.com/t48-regras-do-forum

Obrigado

Administração


Participe do fórum, é rápido e fácil

MaximoAccess

Caro Usuário, antes de postar pela primeira vez, leia as regras do fórum.

https://www.maximoaccess.com/t48-regras-do-forum

Obrigado

Administração

MaximoAccess

Gostaria de reagir a esta mensagem? Crie uma conta em poucos cliques ou inicie sessão para continuar.

Dicas Ms Access, Exemplos Ms Access, Codigos VBA Ms Access, SQL Ms Access

    [Resolvido]Soma da consulta, não aparece no relatório !

    Silvio
    Silvio
    Developer
    Developer

    Respeito às regras : Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 4719
    Registrado : 20/04/2011

    [Resolvido]Soma da consulta, não aparece no relatório ! Empty [Resolvido]Soma da consulta, não aparece no relatório !

    Mensagem  Silvio 25/11/2016, 20:03

    Prezados, boa tarde a todos.

    Não sei porque " cargas dágua" a soma que eu fiz na consulta ( que gera o relatório ) não está aparecendo.

    A ideia é separar o que entra em cheques e em dinheiro para prestação de contas.

    Segue a imagem para melhor compreensão dos colegas.

    Abraços.

    [Resolvido]Soma da consulta, não aparece no relatório ! 2edme77


    .................................................................................
    Caso tenha resolvido a tua duvida, coloque o tópico como resolvido.
    www.maximoaccess.com/t860-resolucao-de-topicos

    "Quase tudo é possível quando se tem determinação e força de vontade. Não desista tão rápido."
    FabioPaes
    FabioPaes
    Maximo VIP
    Maximo VIP

    Respeito às regras : Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 3913
    Registrado : 14/08/2013

    [Resolvido]Soma da consulta, não aparece no relatório ! Empty Re: [Resolvido]Soma da consulta, não aparece no relatório !

    Mensagem  FabioPaes 25/11/2016, 20:36

    Esse seu Campo [ValorLanc] é onde tem os valores(Valor)?


    Uma alternativa, ja que tem os valores separados, e mandar somar apenas o campo TotalDinheiro
     

    Qualquer coisa posta aqui pra batermos cabeça e ver o pq de nao dar certo, pois a soma com SeImed é pra Funcionar normalmente...


    .................................................................................
    _____________________________________________________________________
    Achou a solução para sua dúvida? Não seja Egoísta, Compartilhe com todos!
    A dica do Colega foi útil? Agradeça!

    O importante não saber tudo, mas sim a Onde procurar!
    Celso Roberto
    Celso Roberto
    VIP
    VIP

    Respeito às regras : Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 1071
    Registrado : 01/03/2014

    [Resolvido]Soma da consulta, não aparece no relatório ! Empty Re: [Resolvido]Soma da consulta, não aparece no relatório !

    Mensagem  Celso Roberto 25/11/2016, 20:49

    Olá silvio

    Tive um problema identico ao seu e resolvi colocando na fonte de controle do campo no relatório

    =Soma(SeImed([dinheiro]=Verdadeiro;[ValorLanc];0))

    Tenta ai, quem sabe dá certo

    Abraços


    .................................................................................


    Você fica satisfeito ao ter sua dúvida solucionada?.
    Quem te ajuda também fica quando você da o tópico por "Resolvido".
    Veja como neste Link: https://www.maximoaccess.com/t860-resolucao-de-topicos



    A Única coisa que sei é que ainda nada sei, Mas em breve Saberei.....
    Silvio
    Silvio
    Developer
    Developer

    Respeito às regras : Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 4719
    Registrado : 20/04/2011

    [Resolvido]Soma da consulta, não aparece no relatório ! Empty Re: [Resolvido]Soma da consulta, não aparece no relatório !

    Mensagem  Silvio 25/11/2016, 22:36

    Boa noite...

    Celso, matou a pau !!!

    Eu já tinha colocado essa função, mas mesmo assim não aparecia. Simplesmente copiei e colei, alterando os dados...e funfou !!

    Vai entender...vai entender.....

    Abraços a todos.


    .................................................................................
    Caso tenha resolvido a tua duvida, coloque o tópico como resolvido.
    www.maximoaccess.com/t860-resolucao-de-topicos

    "Quase tudo é possível quando se tem determinação e força de vontade. Não desista tão rápido."
    Celso Roberto
    Celso Roberto
    VIP
    VIP

    Respeito às regras : Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 1071
    Registrado : 01/03/2014

    [Resolvido]Soma da consulta, não aparece no relatório ! Empty Re: [Resolvido]Soma da consulta, não aparece no relatório !

    Mensagem  Celso Roberto 28/11/2016, 16:20

    Olá Silvio...

    Quando usava a expressão 0 ou -1 no campo sim/não, Não gerava o valor
    Usando a expressão True ou False Gerava normal, talvez seja como o Nobelzinho me disse outro dia
    "Coisas do Access".
    Mas o importante é que sempre tem uma solução.

    Abraços



    .................................................................................


    Você fica satisfeito ao ter sua dúvida solucionada?.
    Quem te ajuda também fica quando você da o tópico por "Resolvido".
    Veja como neste Link: https://www.maximoaccess.com/t860-resolucao-de-topicos



    A Única coisa que sei é que ainda nada sei, Mas em breve Saberei.....

      Data/hora atual: 17/4/2021, 14:49