MaximoAccess

Caro Usuário, antes de postar pela primeira vez, leia as regras do fórum.

https://www.maximoaccess.com/t48-regras-do-forum

Obrigado

Administração


Participe do fórum, é rápido e fácil

MaximoAccess

Caro Usuário, antes de postar pela primeira vez, leia as regras do fórum.

https://www.maximoaccess.com/t48-regras-do-forum

Obrigado

Administração

MaximoAccess

Gostaria de reagir a esta mensagem? Crie uma conta em poucos cliques ou inicie sessão para continuar.

Dicas Ms Access, Exemplos Ms Access, Codigos VBA Ms Access, SQL Ms Access

    [Resolvido]Não filtra Nomes

    avatar
    alantb
    Avançado
    Avançado

    Respeito às regras : Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 212
    Registrado : 25/07/2017

    [Resolvido]Não filtra Nomes Empty [Resolvido]Não filtra Nomes

    Mensagem  alantb 16/10/2017, 17:06

    Olá, tenho 3 relatórios: o primeiro ao simplesmente clicar no botão VISUALIZAR carrega os dados sem filtros, todos(RelBoletimResumo), tá funcionando. O segundo(RelBoletimDatas2) eu preencho data inicial e final e seleciona TODOS do período selecionado,funcionando OK também. O problema é quando seleciono período de datas + nome de um funcionário (RelBoletimDatas )em um combobox. A forma que estou fazendo peguei do tutorial do Gilberlânio : https://www.youtube.com/watch?v=Jkk2Lmu5qVo. O relatório continua selecionando as datas corretamente, mas não filtra o nome. Estou chamando os relatórios dessa forma:

    Private Sub cmdVisualizarRelBoletimResumo_Click()

    If Me.txtInicial <> 0 And Me.txtFinal <> 0 Then
    DoCmd.OpenReport "RelBoletimDatas2", acViewPreview
    ElseIf Me.txtInicial <> 0 And Me.txtFinal <> 0 And ComboNome.ListIndex <> -1 Then
    DoCmd.OpenReport "RelBoletimDatas", acViewPreview
    Else
    DoCmd.OpenReport "RelBoletimResumo", acViewPreview
    End If

    End Sub

    ALAN
    avatar
    alantb
    Avançado
    Avançado

    Respeito às regras : Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 212
    Registrado : 25/07/2017

    [Resolvido]Não filtra Nomes Empty Re: [Resolvido]Não filtra Nomes

    Mensagem  alantb 16/10/2017, 18:09

    Pessoal, fiz mais uns testes e pude perceber que a Consulta está certa. Ao executar o Relatório diretamente ele pede a data inicial e final e solicita um nome e filtra corretamente. Sendo assim o meu erro está no código do form que chama o relatório, parece que não está identificando o combobox.....

    ALAN
    thiagomcosta
    thiagomcosta
    Avançado
    Avançado

    Respeito às regras : Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 368
    Registrado : 23/01/2017

    [Resolvido]Não filtra Nomes Empty Re: [Resolvido]Não filtra Nomes

    Mensagem  thiagomcosta 17/10/2017, 11:58

    Teria que dar uma olhada nas consultas de origem dos relatórios. Tem como colocar esta parte do banco para darmos uma olhada?
    avatar
    alantb
    Avançado
    Avançado

    Respeito às regras : Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 212
    Registrado : 25/07/2017

    [Resolvido]Não filtra Nomes Empty Re: [Resolvido]Não filtra Nomes

    Mensagem  alantb 17/10/2017, 13:23

    thiagomcosta, a poucos minutos, depois de revirar a net encontrei um post que tinha exatamente o que precisava. Obrigado pela visualização do tópico. Obrigado também aos outros colegas que também visualizaram...

    Segue o link do tópico que encontrei a solução:
    http://www.redeaccess.com.br/viewtopic.php?t=91

    ALAN

      Data/hora atual: 17/4/2021, 14:41