MaximoAccess

Caro Usuário, antes de postar pela primeira vez, leia as regras do fórum.

Obrigado

Administração do MaximoAccess

Dicas Ms Access, Exemplos Ms Access, Codigos VBA Ms Access, SQL Ms Access


    [Resolvido]Access 2010 não abre

    avatar
    vileman
    Super Avançado
    Super Avançado

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 567
    Registrado : 25/05/2011

    [Resolvido]Access 2010 não abre Empty [Resolvido]Access 2010 não abre

    Mensagem  vileman em 19/11/2018, 22:04

    Boa noite a todos. Mais uma vez solicito a ajuda de vocês no seguinte:

    Estou usando o Access 2010 32 bits com Windows 10 64 bits, mas desde semana passada está acontecendo algo inesperado.
    Do nada deixou de abrir a estrutura do arquivo .accdb usado como Front-end, pois quando tento abrir segurando o Shift mostra a tela inicial do Access para criar novo arquivo, mostrando os modelos disponiveis, etc.. sem mensagem nenhuma de erro, mas o Back-end abre normalmente.

    Formatei o computador, reinstalei o Office 2010 32 bits. Antes disso tudo acontecer já tinha visto as Referências que estavam todas corretas. Fiz a Depuração e Compilação e não apresentou nenhum erro.

    Então, hoje observei que havia criptografado e colocado uma senha para o Back-end, e quando testei retirando essa Senha, voltou a abrir normalmente a estrutura do Front-end.
    Fiz novo teste, colocando novamente a senha no Back-end e mais uma vez não abre a estrutura do Front-end sem aparecer mensagem alguma, e sim mostrando a tela inicial do Access, como já citado anteriormente.

    Pergunto: O que pode ser isso? Pois até então funcionava normalmente mesmo eu colocando uma Senha no Back-end, conseguia abrir o Front-end normalmente, mas agora não funciona mais assim, o que devo fazer?

    PS: Caso este tópico não esteja no local correto, favor remover para o local correto.

    Complemento: Fiz uma busca no site, mas não vi nada semelhante a este fato.
    Marcelo David
    Marcelo David
    Moderador
    Moderador

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 2899
    Registrado : 21/04/2011

    [Resolvido]Access 2010 não abre Empty Re: [Resolvido]Access 2010 não abre

    Mensagem  Marcelo David em 19/11/2018, 22:18

    Boa noite meu amigo.
    O problema realmente está relacionado a senha.

    Vamos as possíveis soluções:

    Quando você põe senha no back-end, o gerenciador de tabelas vinculadas não funciona
    direito, pois ele não solicita a senha.

    Mas se você, ir nas guia dados externos, e vincular usando a opção do "Microsoft Access" ele irá solicitar a senha
    e funcionará.

    Dê uma verificada nisso. Não lembro ao certo o caminho, pois não uso mais o 2010, mas esse é o caminho das
    pedras...


    .................................................................................
    Marcelo David
    www.mrdsystem.com.br (em construção)
    avatar
    vileman
    Super Avançado
    Super Avançado

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 567
    Registrado : 25/05/2011

    [Resolvido]Access 2010 não abre Empty Access 2010 não abre

    Mensagem  vileman em 20/11/2018, 01:36

    Boa noite, amigo

    Vou seguir esse caminho das pedras e depois posto o resultado, valeu!
    Marcelo David
    Marcelo David
    Moderador
    Moderador

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 2899
    Registrado : 21/04/2011

    [Resolvido]Access 2010 não abre Empty Re: [Resolvido]Access 2010 não abre

    Mensagem  Marcelo David em 20/11/2018, 01:45

    E nesse caso, exclua os vínculos (selecione todas as tabelas vinculadas no front-end e delete-ás) e após, crie-os novamente com a opção que falei anteriormente.


    .................................................................................
    Marcelo David
    www.mrdsystem.com.br (em construção)
    avatar
    vileman
    Super Avançado
    Super Avançado

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 567
    Registrado : 25/05/2011

    [Resolvido]Access 2010 não abre Empty Access 2010 não abre

    Mensagem  vileman em 21/11/2018, 11:56

    Bom dia, amigo

    Segui o caminho das pedras e fiz o seguinte:

    1. BE retirei senha e fechei
    2. FE abri no modo estrutura e exclui todos os vínculos das tabelas
    3. BE abri, coloquei senha e fechei
    4. FE em Dados Externos vinculei as tabelas. Pediu a senha do BE: após colocar senha fez a vinculação das tabelas
    5. FE fechei
    6. FE agora fecha e abre no modo estrutura

    Então, valeu pela ajuda, muito obrigado.

    Conteúdo patrocinado

    [Resolvido]Access 2010 não abre Empty Re: [Resolvido]Access 2010 não abre

    Mensagem  Conteúdo patrocinado


      Data/hora atual: 6/12/2019, 17:53