MaximoAccess

Caro Usuário, antes de postar pela primeira vez, leia as regras do fórum.

https://www.maximoaccess.com/t48-regras-do-forum

Obrigado

Administração


Participe do fórum, é rápido e fácil

MaximoAccess

Caro Usuário, antes de postar pela primeira vez, leia as regras do fórum.

https://www.maximoaccess.com/t48-regras-do-forum

Obrigado

Administração

MaximoAccess

Gostaria de reagir a esta mensagem? Crie uma conta em poucos cliques ou inicie sessão para continuar.

Dicas Ms Access, Exemplos Ms Access, Codigos VBA Ms Access, SQL Ms Access


    Problema de Filtragem em Subformulário

    avatar
    josephreis
    Novato
    Novato

    Respeito às regras : Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 1
    Registrado : 25/11/2020

    Problema de Filtragem em Subformulário Empty Problema de Filtragem em Subformulário

    Mensagem  josephreis 29/11/2020, 13:20

    Olá,

    Sou novo aqui no fórum e também tenho pouca experiência com o Access então gostaria de pedir a juda de vocês.

    Tenho um banco de dados e nele criei uma consulta para exibir os dados de 2 tabelas.

    Em seguida, criei um subformulário, a partir desta consulta, para exibir os dados dentro de um formulário principal.

    Entretanto, a ferramenta de filtro do Access (aquela setinha que clicamos ao lado do nome do campo para filtrar) não está funcionando para alguns campos dentro do subformulário.

    Não sei o que pode estar causando isso pois este filtro está funcionando normalmente na tabela e na consulta, ele só para de funcionar no subformulário.

    Já tentei Compactar e Reparar o Arquivo, já coloquei todos os nomes dos campos em letra minúscula e sem caracteres especiais e já tentei refazer a consulta e o subformulário do zero mas o erro persiste.

    Alguém teria alguma sugestão do que pode estar acontecendo?

    Desde já agradeço pela atenção.
    avatar
    Ismael Silva
    Super Avançado
    Super Avançado

    Respeito às regras : Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 749
    Registrado : 11/12/2017

    Problema de Filtragem em Subformulário Empty Re: Problema de Filtragem em Subformulário

    Mensagem  Ismael Silva 29/11/2020, 14:21

    Jose,

    Quem sabe posta o teu banco aqui para ver o que ocorre. Pra mim, isso já ocorreu, porém quando esse campo no subformulário, é um campo calculado na consulta, não sei se esse é o seu caso.

      Data/hora atual: 14/5/2021, 11:24