MaximoAccess

Caro Usuário, antes de postar pela primeira vez, leia as regras do fórum.

https://www.maximoaccess.com/t48-regras-do-forum

Obrigado

Administração


Participe do fórum, é rápido e fácil

MaximoAccess

Caro Usuário, antes de postar pela primeira vez, leia as regras do fórum.

https://www.maximoaccess.com/t48-regras-do-forum

Obrigado

Administração

MaximoAccess

Gostaria de reagir a esta mensagem? Crie uma conta em poucos cliques ou inicie sessão para continuar.

Dicas Ms Access, Exemplos Ms Access, Codigos VBA Ms Access, SQL Ms Access

2 participantes

    [Resolvido]Formatação de campo relativo a medição de tempo (em aa-mm-dd)

    avatar
    VCF
    Novato
    Novato


    Respeito às regras : Respeito às Regras 100%

    Sexo : Masculino
    Localização : Portugal
    Mensagens : 11
    Registrado : 26/12/2011

    [Resolvido]Formatação de campo relativo a medição de tempo (em aa-mm-dd) Empty Formatação de campo relativo a medição de tempo (em aa-mm-dd)

    Mensagem  VCF 22/7/2012, 15:55

    Utilizo o Access 2010 para tratamento de listagens que recebo em Excel.
    Um dos campos a utilizar refere-se à determinação do tempo decorrido entre duas datas e que me é enviado (no Excel) em formato número (Exemplo: 701 que se refere a 7 meses e 1 dia). Quer formatando o campo no Excel, quer após a importação para o access não consigo obter o resultado final desejado que seria, no exemplo acima "00-07-01".
    Tentei de várias formas mas não consegui.
    Alguem me pode ajudar.
    Obrigado
    Leandro
    Leandro
    Developer
    Developer


    Respeito às regras : Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 1601
    Registrado : 12/11/2009

    [Resolvido]Formatação de campo relativo a medição de tempo (em aa-mm-dd) Empty Re: [Resolvido]Formatação de campo relativo a medição de tempo (em aa-mm-dd)

    Mensagem  Leandro 23/7/2012, 00:24

    E se você manipular o campo lá no excel?

    Até onde eu sei você não vai conseguir formatar no modo aa-mm-dd, se você colocar esse número - 701 - no excel e formatar para
    aa-mm-dd o resultado será: 1/12/1901, isso porque o excel conta os dias como número a partir de 1900, hoje estamos no: 41112.

    Dessa forma você posso te dar uma opção usando algumas funções do excel, a saber as funções: SE, NUM.CARACT, ESQUERDA, DIREITA e EXT.TEXTO.

    Ex: Vamos supor que esse número esteja na célula A1.

    Se o número tiver 3 caracteres:
    =SE(NÚM.CARACT(A1)=3;"00-0"&ESQUERDA(A1;1)&"-"&DIREITA(A1;2))

    Se o número tiver 4 caracteres:
    =SE(NUM.CARACT(A1)=4;"00-"&ESQUERDA(A1;2)&"-"&DIREITA(A1;2))

    Se tiver Ano Mês e Dia em 5 caracteres:
    =SE(NUM.CARACT(A1)=5;"0"&ESQUERDA(A1;1)&"-"&EXT.TEXTO(A1;3;2)&"-"&DIREITA(A1;2))

    Se tiver Ano Mês e Dia em 6 caracteres:
    =SE(NUM.CARACT(A1)=6;ESQUERDA(A1;2)&"-"&EXT.TEXTO(A1;3;2)&"-"&DIREITA(A1;2))

    Aninhando tudo:

    =SE(NÚM.CARACT(A1)=3;"00-0"&ESQUERDA(A1;1)&"-"&DIREITA(A1;2);SE(NÚM.CARACT(A1)=4;"00-"&ESQUERDA(A1;2)&"-"&DIREITA(A1;2);SE(NÚM.CARACT(A1)=5;"0"&ESQUERDA(A1;1)&"-"&EXT.TEXTO(A1;3;2)&"-"&DIREITA(A1;2);SE(NÚM.CARACT(A1)=6;ESQUERDA(A1;2)&"-"&EXT.TEXTO(A1;3;2)&"-"&DIREITA(A1;2)))))

    NÃO ESQUEÇA DE INFORMAR A CÉLULA CORRETA!

    avatar
    VCF
    Novato
    Novato


    Respeito às regras : Respeito às Regras 100%

    Sexo : Masculino
    Localização : Portugal
    Mensagens : 11
    Registrado : 26/12/2011

    [Resolvido]Formatação de campo relativo a medição de tempo (em aa-mm-dd) Empty Re: [Resolvido]Formatação de campo relativo a medição de tempo (em aa-mm-dd)

    Mensagem  VCF 23/7/2012, 21:35

    Muito obrigado. De facto existem mais hipóteses que as mencionadas na fórmula, como sejam:
    Dado = 0 -> deve resultar em 00-00-00
    Dado = x -> deve resultar em 00-00-0x
    Dado = xx -> deve resultar em 00-00-xx
    Inseri a fórmula mas não resultou totalmente.
    Anexo exemplo.
    Anexos
    [Resolvido]Formatação de campo relativo a medição de tempo (em aa-mm-dd) AttachmentLivro1.xlsx
    Você não tem permissão para fazer download dos arquivos anexados.
    (12 Kb) Baixado 8 vez(es)
    Leandro
    Leandro
    Developer
    Developer


    Respeito às regras : Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 1601
    Registrado : 12/11/2009

    [Resolvido]Formatação de campo relativo a medição de tempo (em aa-mm-dd) Empty Re: [Resolvido]Formatação de campo relativo a medição de tempo (em aa-mm-dd)

    Mensagem  Leandro 23/7/2012, 23:26

    Boa noite,

    Criei mais uma condição nomeada que você pode ver apertando CTRL + F3, chama-se Condicao2, é um complemento para a primeira visto que está com muitos argumentos e o excel não consegue calculá-la.

    Dê uma olhada:

    avatar
    VCF
    Novato
    Novato


    Respeito às regras : Respeito às Regras 100%

    Sexo : Masculino
    Localização : Portugal
    Mensagens : 11
    Registrado : 26/12/2011

    [Resolvido]Formatação de campo relativo a medição de tempo (em aa-mm-dd) Empty Re: [Resolvido]Formatação de campo relativo a medição de tempo (em aa-mm-dd)

    Mensagem  VCF 24/7/2012, 19:45

    Mais uma vez obrigado.
    Já testei e o problema ficou resolvido.
    Leandro
    Leandro
    Developer
    Developer


    Respeito às regras : Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 1601
    Registrado : 12/11/2009

    [Resolvido]Formatação de campo relativo a medição de tempo (em aa-mm-dd) Empty Re: [Resolvido]Formatação de campo relativo a medição de tempo (em aa-mm-dd)

    Mensagem  Leandro 24/7/2012, 21:30

    Muito obrigado a você que seguiu as regras, voltou e deu o tópico como resolvido, isso torna nosso fórum cada vez melhor.

    E antes que eu esqueça,

    SEJA BEM-VINDO AO FÓRUM MAXIMO ACCESS!


      Data/hora atual: 22/1/2022, 17:44