MaximoAccess

Caro Usuário, antes de postar pela primeira vez, leia as regras do fórum.

https://www.maximoaccess.com/t48-regras-do-forum

Obrigado

Administração


Participe do fórum, é rápido e fácil

MaximoAccess

Caro Usuário, antes de postar pela primeira vez, leia as regras do fórum.

https://www.maximoaccess.com/t48-regras-do-forum

Obrigado

Administração

MaximoAccess

Gostaria de reagir a esta mensagem? Crie uma conta em poucos cliques ou inicie sessão para continuar.

Dicas Ms Access, Exemplos Ms Access, Codigos VBA Ms Access, SQL Ms Access

    [Resolvido]Anexo em relatório

    avatar
    sennyor_gmx
    Novato
    Novato

    Respeito às regras : Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 5
    Registrado : 30/12/2017

    [Resolvido]Anexo em relatório Empty [Resolvido]Anexo em relatório

    Mensagem  sennyor_gmx 30/12/2017, 14:48

    Bom dia a todos!
    Estou com um problema, que já tentei resolver e procurei soluções aqui e na net, mas, não consegui.
    A questão é a seguinte:
    Estou fazendo um cadastro que vai dar a possibilidade da pessoa incluir um logo seu nos relatórios.
    Criei uma tabela com um campo "anexo" para arquivar o logo;
    Criei um formulário, também com um campo "anexo", onde a pessoa vai anexar seu logo;
    O problema está no relatório!
    Preciso de um campo que se relacioe com o campo do logo no formulário e exiba o logo.
    Coloquei no relatório o campo para imagens, o campo para anexos e nenhum deles exibiu o logo.
    Se fizer um relatório direito do fomrulário que tem o anxo com o logo, dá certo.
    O problema é que o relatório gerado é de um formulário e o logo está em outro.
    Nesse caso, o campo do logo no relatório, em tese, teria de ser uma referência tipo [formulários]![logo]![campo do log], onde o formulário do logo estaria aberto no modo oculto.
    É nesse ponto que a coisa emperrou!
    Grato a todos!

    EM TEMPO!

    Agradeço a galera que viu meu apelo e deve estar quebrando a cabeça para me ajudar, mas, acabei de encontrar a solução.
    O código: Me."nome do campo no relatório".Picture = DLookup("nome do registro na tabela", "nome da tabela")
    Era mais fácil do que eu pensava, mas, quando não se sabe nada "é osso"!
    Obrigado a todos!
    ahteixeira
    ahteixeira
    Moderador Global
    Moderador Global

    Respeito às regras : Respeito às Regras 100%

    Sexo : Masculino
    Localização : Portugal
    Mensagens : 7178
    Registrado : 15/03/2013

    [Resolvido]Anexo em relatório Empty Re: [Resolvido]Anexo em relatório

    Mensagem  ahteixeira 3/1/2018, 08:39

    Olá Aparecido,

    Obrigado pelo retorno, o fórum agradece.

    Abraço

      Data/hora atual: 12/4/2021, 02:21