MaximoAccess

Caro Usuário, antes de postar pela primeira vez, leia as regras do fórum.

https://www.maximoaccess.com/t48-regras-do-forum

Obrigado

Administração


Participe do fórum, é rápido e fácil

MaximoAccess

Caro Usuário, antes de postar pela primeira vez, leia as regras do fórum.

https://www.maximoaccess.com/t48-regras-do-forum

Obrigado

Administração

MaximoAccess

Gostaria de reagir a esta mensagem? Crie uma conta em poucos cliques ou inicie sessão para continuar.

Dicas Ms Access, Exemplos Ms Access, Codigos VBA Ms Access, SQL Ms Access

    [Resolvido]Consulta com Tabelas Vinculadas sem registros

    avatar
    Chamon Consultoria
    Avançado
    Avançado

    Respeito às regras : Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 255
    Registrado : 31/08/2012

    [Resolvido]Consulta com Tabelas Vinculadas sem registros Empty [Resolvido]Consulta com Tabelas Vinculadas sem registros

    Mensagem  Chamon Consultoria 28/11/2018, 11:30

    Bom dia!

    Bd em Access 2010.

    No exemplo que segue em anexo, a consulta "Cs_xmlProdutos" não está listando os dados, pois não há registro na tabela XML_IPI. Isso porque no arquivo XML de origem, realmente não há dados do IPI para serem importados para sua respectiva tabela (XML_IPI).

    Como fazer para que a consulta Cs_xmlProdutos liste os demais dados das outras tabelas, mesmo quando não existirem dados em uma das tabelas, nesse caso a XML_IPI?

    Desde já agradeço!
    Anexos
    [Resolvido]Consulta com Tabelas Vinculadas sem registros AttachmentXML Tabelas vinculadas.zip
    Você não tem permissão para fazer download dos arquivos anexados.
    (38 Kb) Baixado 3 vez(es)
    avatar
    Chamon Consultoria
    Avançado
    Avançado

    Respeito às regras : Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 255
    Registrado : 31/08/2012

    [Resolvido]Consulta com Tabelas Vinculadas sem registros Empty Re: [Resolvido]Consulta com Tabelas Vinculadas sem registros

    Mensagem  Chamon Consultoria 29/11/2018, 14:37

    Resolvi o problema.

    criei uma outra consulta apenas com as tabelas XML_PROD e a XML_IPI... e depois incluir essa consulta na consulta Cs_xmlProdutos.

    Dessa forma funcionou perfeitamente.

      Data/hora atual: 18/9/2021, 23:43