MaximoAccess

Caro Usuário, antes de postar pela primeira vez, leia as regras do fórum.

https://www.maximoaccess.com/t48-regras-do-forum

Obrigado

Administração


Participe do fórum, é rápido e fácil

MaximoAccess

Caro Usuário, antes de postar pela primeira vez, leia as regras do fórum.

https://www.maximoaccess.com/t48-regras-do-forum

Obrigado

Administração

MaximoAccess

Gostaria de reagir a esta mensagem? Crie uma conta em poucos cliques ou inicie sessão para continuar.

Dicas Ms Access, Exemplos Ms Access, Codigos VBA Ms Access, SQL Ms Access

    [Resolvido]Relatório sai em branco quando um dos sub formulários não contém dados

    avatar
    acarlosvalente
    Novato
    Novato

    Respeito às regras : Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 16
    Registrado : 03/01/2020

    [Resolvido]Relatório sai em branco quando um dos sub formulários não contém dados Empty [Resolvido]Relatório sai em branco quando um dos sub formulários não contém dados

    Mensagem  acarlosvalente 13/2/2021, 12:13

    Bom dia Pessoal, tudo bem?

    Preciso buscar uma solução para o seguinte:

    Criei um formulário onde nele coloquei 5 subformulários no modo padrão folha de dados para analisar várias informações. Tudo vinculado e roda perfeito. Montei o relatório com os subrelatórios no mesm esquema e processa bacana.

    O que está pegando:

    Criei um botão de imprimir no formulário aonde tem estes subformulários, para imprimir o registro que está na tela, o código deu certo, só que, quando um destes subformulários não contém dados, o relatório sai todo em branco.

    Exemplo: Mostra na tela do formulário que o José tem dados para 4 subformulários e 1 não, ai quando clico em imprimir sai em branco.

    Teria uma forma de gerar o relatório somente dos que tem dados?

    É isso.

    Aguardo uma orientação.

    Antônio Carlos.


    Última edição por acarlosvalente em 13/2/2021, 15:50, editado 1 vez(es)
    Alexandre Neves
    Alexandre Neves
    Moderador Global
    Moderador Global

    Respeito às regras : Respeito às Regras 100%

    Sexo : Masculino
    Localização : Portugal
    Mensagens : 7930
    Registrado : 05/11/2009

    [Resolvido]Relatório sai em branco quando um dos sub formulários não contém dados Empty Re: [Resolvido]Relatório sai em branco quando um dos sub formulários não contém dados

    Mensagem  Alexandre Neves 13/2/2021, 14:11

    Boa tarde
    Leia as regras e cumpra-as
    Adeqúe o título por infringir as regras


    .................................................................................
    Access 2010. Mande bd que dê para testar (indique a versão). Não peça para fazer o que já tem feito. Dê todos os detalhes.
    Não coloquem entraves como senhas, esconder controlos, etc. Disponibilizem o mais limpo possível
    Só respondo a mensagens privadas, se forem de assunto privado; às outras não respondo.
    Quem trabalha e mata a fome não come o pão de ninguém; mas quem não trabalha e come, come sempre o pão de alguém. António Aleixo
    avatar
    acarlosvalente
    Novato
    Novato

    Respeito às regras : Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 16
    Registrado : 03/01/2020

    [Resolvido]Relatório sai em branco quando um dos sub formulários não contém dados Empty Re: [Resolvido]Relatório sai em branco quando um dos sub formulários não contém dados

    Mensagem  acarlosvalente 13/2/2021, 17:12

    Boa tarde.

    Criei um formulário onde nele coloquei 5 subformulários no modo padrão folha de dados para analisar várias informações. Tudo vinculado e roda perfeito. Montei o relatório com os subrelatórios no mesmo esquema e processa bacana.

    O que está pegando:

    Criei um botão de imprimir no formulário aonde tem estes subformulários, para imprimir o registro que está na tela, o código deu certo, só que, quando um destes subformulários não contém dados, o relatório sai todo em branco.

    Exemplo: Mostra na tela do formulário que o José tem dados em 4 subformulários e 1 não, ai quando clico em imprimir sai em branco.

    Teria como configurar para gerar o relatório nesta situação?

    Obrigado.

    Antônio Carlos.
    avatar
    acarlosvalente
    Novato
    Novato

    Respeito às regras : Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 16
    Registrado : 03/01/2020

    [Resolvido]Relatório sai em branco quando um dos sub formulários não contém dados Empty Re: [Resolvido]Relatório sai em branco quando um dos sub formulários não contém dados

    Mensagem  acarlosvalente 14/2/2021, 12:05

    OK Alexandre, fiz a alteração.
    avatar
    acarlosvalente
    Novato
    Novato

    Respeito às regras : Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 16
    Registrado : 03/01/2020

    [Resolvido]Relatório sai em branco quando um dos sub formulários não contém dados Empty Re: [Resolvido]Relatório sai em branco quando um dos sub formulários não contém dados

    Mensagem  acarlosvalente 15/2/2021, 10:08

    Bom dia.

    Alguém pode me ajudar?

    Antônio Carlos
    Noobezinho
    Noobezinho
    Moderador
    Moderador

    Respeito às regras : Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 3932
    Registrado : 29/06/2012

    [Resolvido]Relatório sai em branco quando um dos sub formulários não contém dados Empty Re: [Resolvido]Relatório sai em branco quando um dos sub formulários não contém dados

    Mensagem  Noobezinho 15/2/2021, 10:14

    Antônio Carlos

    Poste uma cópia do teu aplicativo com as tabelas, consultas, formulários, relatórios e afins , e alguns
    registros para que possamos manipular e chagar no resultado que você deseja.

    { }'s
    avatar
    acarlosvalente
    Novato
    Novato

    Respeito às regras : Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 16
    Registrado : 03/01/2020

    [Resolvido]Relatório sai em branco quando um dos sub formulários não contém dados Empty Postagem do banco

    Mensagem  acarlosvalente 15/2/2021, 14:46

    Bom dia Amigo, obrigado pela atenção.

    Segue postado o banco.

    Bom, revisando, quando abro o form principal de nome  Frm_FatPorEC, o primeiro cadastro mostra que não possui dados em => dados faturamento, domicílio, faturamento comercial – total por bandeira e faturamento comercial completo -com trava, mas preciso gerar o relatório das informações que constam que são => dados equipamentos, dados da agenda-antecipação e detalhes da antecipação, porém ao clicar em imprimir são tudo em branco.
    O próximo registro você já tem todos os subformulários com informações ai quando clico em imprimir sai o relatório.

    É isso, gentileza analisar.

    Saudações.

    Antônio Carlos
    Anexos
    [Resolvido]Relatório sai em branco quando um dos sub formulários não contém dados AttachmentANALISE EC.zip
    Você não tem permissão para fazer download dos arquivos anexados.
    (192 Kb) Baixado 5 vez(es)
    Alexandre Fim
    Alexandre Fim
    Developer
    Developer

    Respeito às regras : Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 1273
    Registrado : 13/12/2016

    [Resolvido]Relatório sai em branco quando um dos sub formulários não contém dados Empty Re: [Resolvido]Relatório sai em branco quando um dos sub formulários não contém dados

    Mensagem  Alexandre Fim 15/2/2021, 16:22

    Olá Carlos,

    Você mencionou que existem 5 sub formulários que conectam com o formulários principal.
    Acredito que o erro esteja no relacionamento da tabela que carrega o sub-formulário em branco.

    Poste aqui seu projeto para que possamos analisar e encontrar uma solução.

    Att,



    .................................................................................
    - Procure sempre anexar seu projeto para análise do problema/dúvida.
    - Ao copiar/colar um código VBA, procure entender seu funcionamento.
    - Se o problema foi resolvido, não se esqueça de marcar o tópico como RESOLVIDO.
    Alexandre Fim
    Alexandre Fim
    Developer
    Developer

    Respeito às regras : Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 1273
    Registrado : 13/12/2016

    [Resolvido]Relatório sai em branco quando um dos sub formulários não contém dados Empty Re: [Resolvido]Relatório sai em branco quando um dos sub formulários não contém dados

    Mensagem  Alexandre Fim 15/2/2021, 16:37

    Carlos,

    Abra o relatório no modo estrutura e entre na consulta que compõe o relatório e mude os relacionamentos conforme abaixo:

    [Resolvido]Relatório sai em branco quando um dos sub formulários não contém dados Juncao10

    E a instrução SQL ficou assim:

    SELECT tbl_base_credenciamento_mensal.ec,
          tbl_base_credenciamento_mensal.cpfcnpj,
          tbl_base_credenciamento_mensal.pa,
          tbl_base_credenciamento_mensal.razaosocial,
          tbl_base_credenciamento_mensal.pessoa,
          tbl_base_credenciamento_mensal.dt_credenciamento,
          tbl_base_credenciamento_mensal.status,
          tbl_base_credenciamento_mensal.bco_cred,
          tbl_base_credenciamento_mensal.ag_cred,
          tbl_base_credenciamento_mensal.mcc,
          tbl_base_credenciamento_mensal.desc_mcc,
          tbl_base_credenciamento_mensal.macro_seg,
          tbl_base_credenciamento_mensal.cnae,
          tbl_base_credenciamento_mensal.desc_cnae,
          tbl_base_credenciamento_mensal.e_commerce,
          tbl_detalhes_equip_mensal.dt_credenciamento,
          tbl_detalhes_equip_mensal.dt_inst_1�_equip,
          tbl_detalhes_equip_mensal.[terminal id],
          tbl_detalhes_equip_mensal.tecnologia,
          tbl_detalhes_equip_mensal.dt_inst_adicional,
          tbl_detalhes_equip_mensal.[valor aluguel],
          tbl_detalhes_f_acum_domicilio_mensal.bandeira,
          tbl_detalhes_f_acum_domicilio_mensal.produto,
          tbl_detalhes_f_acum_domicilio_mensal.bco,
          tbl_detalhes_f_acum_domicilio_mensal.ag,
          tbl_detalhes_f_acum_domicilio_mensal.cc,
          tbl_detalhes_a_agenda_semanal.data_base,
          tbl_detalhes_a_agenda_semanal.bandeira,
          tbl_detalhes_a_agenda_semanal.desc_a,
          tbl_detalhes_a_agenda_semanal.i_reserva,
          tbl_detalhes_a_agenda_semanal.i_a_automatica,
          tbl_detalhes_a_agenda_semanal.i_a_av,
          tbl_detalhes_a_agenda_semanal.i_a_parcelado,
          tbl_detalhes_a_agenda_semanal.vr_agenda_fi
    FROM   ((tbl_base_credenciamento_mensal
            LEFT JOIN tbl_detalhes_a_agenda_semanal
                   ON tbl_base_credenciamento_mensal.ec =
                  tbl_detalhes_a_agenda_semanal.ec)
           LEFT JOIN tbl_detalhes_equip_mensal
                  ON tbl_base_credenciamento_mensal.ec =
                     tbl_detalhes_equip_mensal.ec)
          LEFT JOIN tbl_detalhes_f_acum_domicilio_mensal
                 ON tbl_base_credenciamento_mensal.ec =
                    tbl_detalhes_f_acum_domicilio_mensal.ec;



    O LEFT JOIN faz com que carregue os dados da tabela principal, mesmo que não haja dados na tabela secundária.

    Espero ter ajudado.
    Boa sorte


    .................................................................................
    - Procure sempre anexar seu projeto para análise do problema/dúvida.
    - Ao copiar/colar um código VBA, procure entender seu funcionamento.
    - Se o problema foi resolvido, não se esqueça de marcar o tópico como RESOLVIDO.

    acarlosvalente gosta desta mensagem

    Noobezinho
    Noobezinho
    Moderador
    Moderador

    Respeito às regras : Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 3932
    Registrado : 29/06/2012

    [Resolvido]Relatório sai em branco quando um dos sub formulários não contém dados Empty Re: [Resolvido]Relatório sai em branco quando um dos sub formulários não contém dados

    Mensagem  Noobezinho 15/2/2021, 16:48

    Opa !

    O amigo Alexandre Fim , respondeu antes de eu ter visto o tópico. Smile

    Veja se o que ele postou resolve.

    Só um detalhe, se estiver programando para algum cliente, veja se ele tem monitores widscreen.

    Meu monitor é normal, teus formulários ultrapassam o tamanho dele.

    Aguardamos...
    avatar
    acarlosvalente
    Novato
    Novato

    Respeito às regras : Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 16
    Registrado : 03/01/2020

    [Resolvido]Relatório sai em branco quando um dos sub formulários não contém dados Empty Re: [Resolvido]Relatório sai em branco quando um dos sub formulários não contém dados

    Mensagem  acarlosvalente 15/2/2021, 16:57

    Boa tarde Alexandre, mandou bem.

    Funcionou agora, solucionado!

    Muito obrigado também ao Noobezinho pela atenção.

    Abraços.

    Antônio Carlos.
    Noobezinho
    Noobezinho
    Moderador
    Moderador

    Respeito às regras : Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 3932
    Registrado : 29/06/2012

    [Resolvido]Relatório sai em branco quando um dos sub formulários não contém dados Empty Re: [Resolvido]Relatório sai em branco quando um dos sub formulários não contém dados

    Mensagem  Noobezinho 15/2/2021, 16:59

    Ótimo Antonio Carlos

    Boa sorte!
    ahteixeira
    ahteixeira
    Moderador Global
    Moderador Global

    Respeito às regras : Respeito às Regras 100%

    Sexo : Masculino
    Localização : Portugal
    Mensagens : 7178
    Registrado : 15/03/2013

    [Resolvido]Relatório sai em branco quando um dos sub formulários não contém dados Empty Re: [Resolvido]Relatório sai em branco quando um dos sub formulários não contém dados

    Mensagem  ahteixeira 15/2/2021, 20:40

    Olá a todos,

    Antônio Valente, tópico foi fundido.
    Tenha mais atenção as Regras do fórum.

    Abraço
    Alexandre Fim
    Alexandre Fim
    Developer
    Developer

    Respeito às regras : Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 1273
    Registrado : 13/12/2016

    [Resolvido]Relatório sai em branco quando um dos sub formulários não contém dados Empty Re: [Resolvido]Relatório sai em branco quando um dos sub formulários não contém dados

    Mensagem  Alexandre Fim 16/2/2021, 11:04

    Valeu Carlos...o forum agradece.

    Meus cumprimentos, mestre Noobezinho !!!


    .................................................................................
    - Procure sempre anexar seu projeto para análise do problema/dúvida.
    - Ao copiar/colar um código VBA, procure entender seu funcionamento.
    - Se o problema foi resolvido, não se esqueça de marcar o tópico como RESOLVIDO.
    Noobezinho
    Noobezinho
    Moderador
    Moderador

    Respeito às regras : Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 3932
    Registrado : 29/06/2012

    [Resolvido]Relatório sai em branco quando um dos sub formulários não contém dados Empty Re: [Resolvido]Relatório sai em branco quando um dos sub formulários não contém dados

    Mensagem  Noobezinho 16/2/2021, 11:16

    Os meus cumprimentos a você também Mestre Alexandre Fim.

    Como pode ver sou um neófito, um noobezinho ainda, sempre aprendendo. Laughing

    { }'s

    Balem

      Data/hora atual: 12/4/2021, 01:38