MaximoAccess

Caro Usuário, antes de postar pela primeira vez, leia as regras do fórum.

https://www.maximoaccess.com/t48-regras-do-forum

Obrigado

Administração


Participe do fórum, é rápido e fácil

MaximoAccess

Caro Usuário, antes de postar pela primeira vez, leia as regras do fórum.

https://www.maximoaccess.com/t48-regras-do-forum

Obrigado

Administração

MaximoAccess

Gostaria de reagir a esta mensagem? Crie uma conta em poucos cliques ou inicie sessão para continuar.

Dicas Ms Access, Exemplos Ms Access, Codigos VBA Ms Access, SQL Ms Access

3 participantes

    [Resolvido]Erro: #Núm!

    cristiano.vaz
    cristiano.vaz
    Novato
    Novato

    Respeito às regras : Respeito às Regras 100%

    Sexo : Masculino
    Localização : Anónimo
    Mensagens : 49
    Registrado : 12/11/2020

    [Resolvido]Erro: #Núm! Empty [Resolvido]Erro: #Núm!

    Mensagem  cristiano.vaz 10/3/2021, 12:44

    Bom dia, Senhores.

    Estou fazendo uma consulta onde vou somar um campo de uma tabela com outro campo de outra consulta. Porem existem campos na consulta que não tem na tabela, e esses me acusam o erro de #Núm! na soma. Tentei usar NZ(), e todas as fórmulas que acusam erro em inspeção e mesmo assim retorna esse erro. Alguém tem uma solução?


    Última edição por cristiano.vaz em 11/3/2021, 11:37, editado 2 vez(es)
    Noobezinho
    Noobezinho
    Moderador
    Moderador

    Respeito às regras : Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 4144
    Registrado : 29/06/2012

    [Resolvido]Erro: #Núm! Empty Re: [Resolvido]Erro: #Núm!

    Mensagem  Noobezinho 10/3/2021, 13:09

    Olá Cristiano

    Provavelmente está como texto.

    Experimente colocar no lugar do Nz() o CLong()

    Mas, não na soma , e sim em cada valor que não está na tabela.

    Aguardamos ...

    Balem


    .................................................................................
    A pergunta que não quer calar:
    Por quê quando alguém vem pedir ajuda e conforme o caso pedimos
    para enviar parte do projeto, não temos mais continuidade do tópico?  
    Crê que temos bolas de cristal ou está com medo que "roubemos"  a
    idéia/projeto dele?  Twisted Evil
    Se é tão bom assim...


    Ajude a ser ajudado:
    Seja objetivo na dúvida, dê os detalhes do que precisa, sem rodeios.
    Quando anexar teu projeto, diga onde está o problema, ganhamos mais tempo
    sem precisar procurar o mesmo.
    cristiano.vaz
    cristiano.vaz
    Novato
    Novato

    Respeito às regras : Respeito às Regras 100%

    Sexo : Masculino
    Localização : Anónimo
    Mensagens : 49
    Registrado : 12/11/2020

    [Resolvido]Erro: #Núm! Empty Re: [Resolvido]Erro: #Núm!

    Mensagem  cristiano.vaz 10/3/2021, 13:20

    Noobezinho, não é isso, eu fiz no campo mesmo.
    Onde tem valor em comum na tabela e na consulta que estou usando, ele soma certinho nessa nova consulta. Questão são nos registros que tem valor somente na tabela.
    avatar
    Ismael Silva
    Super Avançado
    Super Avançado

    Respeito às regras : Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 759
    Registrado : 11/12/2017

    [Resolvido]Erro: #Núm! Empty Re: [Resolvido]Erro: #Núm!

    Mensagem  Ismael Silva 10/3/2021, 13:27

    cristiano.vaz
    cristiano.vaz
    Novato
    Novato

    Respeito às regras : Respeito às Regras 100%

    Sexo : Masculino
    Localização : Anónimo
    Mensagens : 49
    Registrado : 12/11/2020

    [Resolvido]Erro: #Núm! Empty Re: [Resolvido]Erro: #Núm!

    Mensagem  cristiano.vaz 10/3/2021, 13:37

    Eu tinha dado uma olha já nesse que você me mandou, mas não tem campo em branco onde estou fazendo a soma. O que acontece é que tem registro na tabela, que não possui junção com a consulta, esse eu quero que some somente o da tabela, aqui que acontece o erro. Quando tem nas duas, ela soma normalmente.
    Noobezinho
    Noobezinho
    Moderador
    Moderador

    Respeito às regras : Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 4144
    Registrado : 29/06/2012

    [Resolvido]Erro: #Núm! Empty Re: [Resolvido]Erro: #Núm!

    Mensagem  Noobezinho 10/3/2021, 14:44

    Se o campo estiver em branco, use o NZ()

    Ou envie parte do teu projeto pra gente analisar e ver onde tá pegando.
    Será bem mais fácil assim do que ficar na tentative e erro.




    .................................................................................
    A pergunta que não quer calar:
    Por quê quando alguém vem pedir ajuda e conforme o caso pedimos
    para enviar parte do projeto, não temos mais continuidade do tópico?  
    Crê que temos bolas de cristal ou está com medo que "roubemos"  a
    idéia/projeto dele?  Twisted Evil
    Se é tão bom assim...


    Ajude a ser ajudado:
    Seja objetivo na dúvida, dê os detalhes do que precisa, sem rodeios.
    Quando anexar teu projeto, diga onde está o problema, ganhamos mais tempo
    sem precisar procurar o mesmo.

      Data/hora atual: 18/9/2021, 18:43