MaximoAccess

Caro Usuário, antes de postar pela primeira vez, leia as regras do fórum.

https://www.maximoaccess.com/t48-regras-do-forum

Obrigado

Administração


Participe do fórum, é rápido e fácil

MaximoAccess

Caro Usuário, antes de postar pela primeira vez, leia as regras do fórum.

https://www.maximoaccess.com/t48-regras-do-forum

Obrigado

Administração

MaximoAccess

Gostaria de reagir a esta mensagem? Crie uma conta em poucos cliques ou inicie sessão para continuar.

Dicas Ms Access, Exemplos Ms Access, Codigos VBA Ms Access, SQL Ms Access

4 participantes

    [Resolvido]Leitor de Código de Barras não lê quando gerado no Access

    guilhas23
    guilhas23
    Novato
    Novato


    Respeito às regras : Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 27
    Registrado : 29/09/2015

    [Resolvido]Leitor de Código de Barras não lê quando gerado no Access Empty [Resolvido]Leitor de Código de Barras não lê quando gerado no Access

    Mensagem  guilhas23 24/12/2021, 02:29

    Olá, amigos

    Estou com um sistema de PDV que gera etiquetas. Gostaria que fossem criadas com códigos de barras que seriam impressos numa térmica e lidos quando necessário na leitora laser.

    Pois bem, tentei vários métodos aqui do fórum (frisando que antes de postar fui nas buscas). Tentei várias fontes (39, 128, EAN... - baixada em sites de download de fontes), tentei colocar * como postado aqui... porém, nunca consigo fazer com que a leitora identifique o código.

    Testei até mesmo copiando um código da internet como imagem, imprimi no mesmo programa (impressora e papel) no Access e ele foi lido. Porém quando eu mesmo tento gerar, não lê, eis aqui o problema.

    Conto com a ajuda ou direcionamento de vocês para que eu possa resolver isso. Obrigado.
    bigfill
    bigfill
    Avançado
    Avançado


    Respeito às regras : Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 448
    Registrado : 27/03/2015

    [Resolvido]Leitor de Código de Barras não lê quando gerado no Access Empty Re: [Resolvido]Leitor de Código de Barras não lê quando gerado no Access

    Mensagem  bigfill 24/12/2021, 11:24

    Bom dia guilhas23, Tenta mandar a parte do BD para que possamos analisar.

    Pode varias coisas

    Ex: Configuração do leitor; o código de barra deve ter um "*" no inicio e no fim para que o leitor identifique...

    Se puder postar

    abraços
    guilhas23
    guilhas23
    Novato
    Novato


    Respeito às regras : Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 27
    Registrado : 29/09/2015

    [Resolvido]Leitor de Código de Barras não lê quando gerado no Access Empty Re: [Resolvido]Leitor de Código de Barras não lê quando gerado no Access

    Mensagem  guilhas23 27/12/2021, 02:15

    O código é esse. Ele funciona bem.

    Tentei usar as fontes: 128 e 39 - versões normaois e extendidas.

    Tentei colocar o * antes e depois num código que achei aqui "*"&[codproduto]&"*".

    - - -

    A impressão de códigos gerados na net imprimem e funcionam perfeitamente pela térmica e etiqueta que tenho aqui. O leitor também lê perfeitamente esses códigos e o de embalagens que fiz testes.

    Acredito que realmente o problema está na sintaxe, porém não consegui descobri o erro que tenho cometido pra que o código criado e impresso por mim seja percebido pelo leitor.

    - - -

    Desde já agradeço aos colegas
    Anexos
    [Resolvido]Leitor de Código de Barras não lê quando gerado no Access AttachmentCB.zip
    Você não tem permissão para fazer download dos arquivos anexados.
    (124 Kb) Baixado 7 vez(es)
    avatar
    egnaldo
    Intermediário
    Intermediário


    Respeito às regras : Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 68
    Registrado : 11/03/2012

    [Resolvido]Leitor de Código de Barras não lê quando gerado no Access Empty Re: [Resolvido]Leitor de Código de Barras não lê quando gerado no Access

    Mensagem  egnaldo 27/12/2021, 10:34

    Bom dia, um exemplo de como eu uso
    Me.CodBarras = "*" & Format([codproduto], "00000") & "*"
    para fonte "Code39.ttf
    guilhas23
    guilhas23
    Novato
    Novato


    Respeito às regras : Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 27
    Registrado : 29/09/2015

    [Resolvido]Leitor de Código de Barras não lê quando gerado no Access Empty Re: [Resolvido]Leitor de Código de Barras não lê quando gerado no Access

    Mensagem  guilhas23 27/12/2021, 15:55

    egnaldo, tentei de várias formas com essa técnica do *, mas não consegui sucesso. Estarei tentando mais um pouco nos próximos dias.

    Se vc tiver como disponibilizar um arquivo exemplo pra eu testar aqui, agradeço.
    JPaulo
    JPaulo
    Moderador
    Moderador


    Respeito às regras : Respeito às Regras 100%

    Sexo : Masculino
    Localização : Portugal
    Mensagens : 10765
    Registrado : 04/11/2009

    [Resolvido]Leitor de Código de Barras não lê quando gerado no Access Empty Re: [Resolvido]Leitor de Código de Barras não lê quando gerado no Access

    Mensagem  JPaulo 27/12/2021, 17:33

    Hoje em dia, já não necessita de instalar qualquer fonte, nem de usar os asteriscos;

    Veja se ajuda;
    Anexos
    [Resolvido]Leitor de Código de Barras não lê quando gerado no Access AttachmentBC_Teste_OLD.zip
    Você não tem permissão para fazer download dos arquivos anexados.
    (158 Kb) Baixado 15 vez(es)


    .................................................................................
    Contribua com o maximoaccess nos links abaixo, ajude a melhorar este que é o seu site na NET.

    Pay-Pal R$ Aqui
    Pay-Pal € Aqui

    Ou ainda: Aqui (Novo)

    Sucesso e Bons Estudos
    Success and Good Studies

    [Resolvido]Leitor de Código de Barras não lê quando gerado no Access Folder_announce_new Utilize o Sistema de Busca do Fórum...
    [Resolvido]Leitor de Código de Barras não lê quando gerado no Access Folder_announce_new 102 Códigos VBA Gratuitos...
    [Resolvido]Leitor de Código de Barras não lê quando gerado no Access Folder_announce_new Instruções SQL como utilizar...
    guilhas23
    guilhas23
    Novato
    Novato


    Respeito às regras : Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 27
    Registrado : 29/09/2015

    [Resolvido]Leitor de Código de Barras não lê quando gerado no Access Empty Re: [Resolvido]Leitor de Código de Barras não lê quando gerado no Access

    Mensagem  guilhas23 27/12/2021, 19:19

    Jpaulo, MUITO OBRIGADO!!!

    Eu testei um código seu anteriormente, mas ele ficava muito fino, e eu não conseguia deixá-lo assim. Resolveu e agradeço muito por isso.

    Obrigado a todos que contribuíram!
    JPaulo
    JPaulo
    Moderador
    Moderador


    Respeito às regras : Respeito às Regras 100%

    Sexo : Masculino
    Localização : Portugal
    Mensagens : 10765
    Registrado : 04/11/2009

    [Resolvido]Leitor de Código de Barras não lê quando gerado no Access Empty Re: [Resolvido]Leitor de Código de Barras não lê quando gerado no Access

    Mensagem  JPaulo 27/12/2021, 21:42

    Fico feliz em ajudar.
    Obrigado pelo retorno, boas festas.


    .................................................................................
    Contribua com o maximoaccess nos links abaixo, ajude a melhorar este que é o seu site na NET.

    Pay-Pal R$ Aqui
    Pay-Pal € Aqui

    Ou ainda: Aqui (Novo)

    Sucesso e Bons Estudos
    Success and Good Studies

    [Resolvido]Leitor de Código de Barras não lê quando gerado no Access Folder_announce_new Utilize o Sistema de Busca do Fórum...
    [Resolvido]Leitor de Código de Barras não lê quando gerado no Access Folder_announce_new 102 Códigos VBA Gratuitos...
    [Resolvido]Leitor de Código de Barras não lê quando gerado no Access Folder_announce_new Instruções SQL como utilizar...

      Data/hora atual: 6/10/2022, 08:13