MaximoAccess

Caro Usuário, antes de postar pela primeira vez, leia as regras do fórum.

https://www.maximoaccess.com/t48-regras-do-forum

Obrigado

Administração


Participe do fórum, é rápido e fácil

MaximoAccess

Caro Usuário, antes de postar pela primeira vez, leia as regras do fórum.

https://www.maximoaccess.com/t48-regras-do-forum

Obrigado

Administração

MaximoAccess

Gostaria de reagir a esta mensagem? Crie uma conta em poucos cliques ou inicie sessão para continuar.

Dicas Ms Access, Exemplos Ms Access, Codigos VBA Ms Access, SQL Ms Access

3 participantes

    [Resolvido]SubFormulários não atualizam, não sei porque.

    Walter
    Walter
    Avançado
    Avançado

    Respeito às regras : Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 339
    Registrado : 17/04/2011

    [Resolvido]SubFormulários não atualizam, não sei porque. Empty [Resolvido]SubFormulários não atualizam, não sei porque.

    Mensagem  Walter 21/2/2015, 12:00

    O Aplicativo abre no Formulário "Fml_CadastroFamilias". Veja que há um subformulario inserido nele ("SubFml_MembrosDaFamilia"). Nesse subformulario ficam os nomes de todos os membros da familia que residem na mesma casa. Dê duplo-clique em um dos nomes e abrirá o "Fml_Individual" com os dados daquele Membro da Familia específico. Nesse formulário destaquei os dois subformularios que estão dando êrro. Se a pessoa que você abriu já tiver com "Estadiamento Renal Crônico" calculado o subformulario de cima mostrará os dados corretamente. O mesmo acontecerá com o do meio e o de baixo. Agora faça o teste: Clique no botão "Fazer estadiamento Renal Crônico". Vai abrir o "Fml_CalculaEstadiamRenalCronico" Insira uma data e os valores subsequentes (Por exemplo: 01/02/2015; Peso= 70; Creatinina=3,2) . O Formulario calcula a taxa de Filtração Glomerular dos Rins e o Estágio. Ao "Salvar e Fechar" esses valores deveriam ir para o Subformulario de cima, mas fica mostrando a data correta e erro nos outros campos!!!! Se você fechar e abrir o Fml_Individual os valores ficam corretos. O mesmo ocorre com 0 terceiro subformulario (de baixo). o Segundo funciona corretamente. No terceiro, pode testar com dados mais ou menos assim: Data (qualquer); Colesterol Total= 260 (por exemplo), HDL = 45 (por exemplo); Pressao Sistolica: 140; Outros campos responda sim ou não.

    Veja bem:

    Esses dois subformularios são baseados em Consultas e, em ambas as consultas há 2 campos calculados, um campo baseado no outro. Imagino que pode ser isso que pode estar dando o êrro, mas não consigo tira-lo.

    Tentei Recalc, Requery e Refresh em vários eventos e nada.

    O Aplicativo abre no Formulário "Fml_CadastroFamilias". Veja que há um subformulario inserido nele ("SubFml_MembrosDaFamilia"). Nesse subformulario ficam os nomes de todos os membros da familia que residem na mesma casa. Dê duplo-clique em um dos nomes e abrirá o "Fml_Individual" com os dados daquele Membro da Familia específico. Nesse formulário destaquei os dois subformularios que estão dando êrro.Se a pessoa que você abriu já tiver com "Estadiamento Renal Crônico" calculado o sufformulario de cima mostrará os dados corretamente. O mesmo acontecerá com o do meio e o de baixo. Agora faça o teste: Clique no botão "Fazer estadiamento Renal Crônico". Vai abrir o "Fml_Calcula EstadiamRenalCronico" Insira uma data e os valores subsequentes (Por exemplo: 01/02/2015; Peso= 70; Creatinina=3,2) . O Formulario calcula a taxa de Filtração Glomerular dos Rins e o Estágio. Ao "Salvar e Fechar" esses valores deveriam ir para o Subformulario de cima, mas fica mostrando a data correta e erro nos outros campos!!!! Se você fechar e abrir o Fml_Individual os valores ficam corretos. O mesmo ocorre com 0 terceiro subformulario (de baixo). o Segundo funciona corretamente. No terceiro, pode testar com dados mais ou menos assim: Data (qualquer); Colesterol Total= 260 (por exemplo), HDL = 45 (por exemplo); Pressao Sistolica: 140; Outros campos responda sim ou não.

    Veja bem:

    Esses dois subformularios são baseados em Consultas e, em ambas as consultas há 2 campos calculados, um campo baseado no outro. Imagino que pode ser isso que pode estar dando o êrro, mas não consigo tira-lo.

    Tentei Recalc, Requery e Refresh em vários eventos e nada.

    Link do Dropbox:

    https://www.dropbox.com/s/q1rfl59ntld1xbx/Cadastro%20PSF%20Versao51.rar?dl=

    Um abraço


    .................................................................................
    "A verdade é filha do tempo, e não da autoridade!"
    reynaldoas2012
    reynaldoas2012
    Novato
    Novato

    Respeito às regras : Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 39
    Registrado : 27/04/2012

    [Resolvido]SubFormulários não atualizam, não sei porque. Empty Refresh all

    Mensagem  reynaldoas2012 2/6/2015, 15:55

    Tente o código:

    DoCmd.RunCommand acCmdRefresh

    Vai atualizar todos os formulários abertos, inclusive os subform.


    .................................................................................
    "Carpe diem"
    Walter
    Walter
    Avançado
    Avançado

    Respeito às regras : Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 339
    Registrado : 17/04/2011

    [Resolvido]SubFormulários não atualizam, não sei porque. Empty Re: [Resolvido]SubFormulários não atualizam, não sei porque.

    Mensagem  Walter 3/8/2015, 11:03

    Não deu certo também...

    Obrigado.


    .................................................................................
    "A verdade é filha do tempo, e não da autoridade!"
    DamascenoJr.
    DamascenoJr.
    Moderador
    Moderador

    Respeito às regras : Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 3054
    Registrado : 22/11/2016

    [Resolvido]SubFormulários não atualizam, não sei porque. Empty Re: [Resolvido]SubFormulários não atualizam, não sei porque.

    Mensagem  DamascenoJr. 11/9/2021, 17:37

    Walter, como ficou essa situação? Resolveu?

    Aguardamos...


    .................................................................................
    Ajude-se a ser ajudado, anexe seu projeto.
    Sempre tente entender o código,
    não somente copie e cole.
    Positive as mensagens que achar útil clicando no '+' no canto superior direito delas.
    Walter
    Walter
    Avançado
    Avançado

    Respeito às regras : Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 339
    Registrado : 17/04/2011

    [Resolvido]SubFormulários não atualizam, não sei porque. Empty Re: [Resolvido]SubFormulários não atualizam, não sei porque.

    Mensagem  Walter 11/9/2021, 18:10

    Resolvido, Damasceno.

    Muito obrigado.

    Walter


    .................................................................................
    "A verdade é filha do tempo, e não da autoridade!"

      Data/hora atual: 18/9/2021, 17:30