MaximoAccess

Caro Usuário, antes de postar pela primeira vez, leia as regras do fórum.

Obrigado

Administração do MaximoAccess

Dicas Ms Access, Exemplos Ms Access, Codigos VBA Ms Access, SQL Ms Access


    Filtro em Formulário não funciona

    avatar
    AMarcos
    Intermediário
    Intermediário

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 175
    Registrado : 26/07/2016

    Filtro em Formulário não funciona Empty Filtro em Formulário não funciona

    Mensagem  AMarcos em 24/8/2018, 04:43

    Tenho um Formulário de nome informe Abastecimento e ele possui uma pesquisa (Pesquisa Abastecimento)que é acionado quando peço para visualizar relatório. Nessa pesquisa existe dois filtros para imprimir o tal relatório: por viatura e pelo período.
    Acontece que agora esle está só filtrando pelo período, pois quando seleciono uma viatura para aparecer tal relatório, é aberto um documento contendo todas viaturas em geral.

    Por favor alguém tente achar onde está o erro ou o que está faltando fazer para poder obter relatório por viatura específica.

    Abraço,


    AMarcos
    Anexos
    Filtro em Formulário não funciona AttachmentNew_Help.zip
    Você não tem permissão para fazer download dos arquivos anexados.
    (97 Kb) Baixado 14 vez(es)
    gilberlanio
    gilberlanio
    Super Avançado
    Super Avançado

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 761
    Registrado : 30/08/2010

    Filtro em Formulário não funciona Empty Re: Filtro em Formulário não funciona

    Mensagem  gilberlanio em 24/8/2018, 12:47

    Veja se era isso.
    Anexos
    Filtro em Formulário não funciona AttachmentNew_Help_2.zip
    Você não tem permissão para fazer download dos arquivos anexados.
    (90 Kb) Baixado 21 vez(es)


    .................................................................................
    Sistemas completos com fonte aberto (Apresentação)

    Vários Exemplos Grátis
    avatar
    AMarcos
    Intermediário
    Intermediário

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 175
    Registrado : 26/07/2016

    Filtro em Formulário não funciona Empty Re: Filtro em Formulário não funciona

    Mensagem  AMarcos em 25/8/2018, 15:36

    Caro Prof Gilberlanio, que bom ter sua orientação! Muito obg.

    Vi acontecer o filtro, mas acredite eu não consegui visualizar o que foi feito de correção do extrato do BD que postei aqui. O Sr pode me indicar os detalhes para que eu possa implementar a correção?

    Aguardo ancioso,


    AMarcos
    avatar
    AMarcos
    Intermediário
    Intermediário

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 175
    Registrado : 26/07/2016

    Filtro em Formulário não funciona Empty Re: Filtro em Formulário não funciona

    Mensagem  AMarcos em 28/8/2018, 18:33

    Caros amigos mestres!

    Alguém conseguiu ver o que o Prof Gilberlanio fez de correção no extrato do BD que postei aqui. Alguém pode me indicar os detalhes para filtrar por viatura para que eu possa implementar nos meus estudos?

    Fico no aguardo,


    AMarcos
    Alexandre Fim
    Alexandre Fim
    Developer
    Developer

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 856
    Registrado : 13/12/2016

    Filtro em Formulário não funciona Empty Re: Filtro em Formulário não funciona

    Mensagem  Alexandre Fim em 28/8/2018, 18:48

    Marcos,

    Ele alterou a consulta do relatório, referenciando o campo da tela (Viaturas):
    Filtro em Formulário não funciona Consul10


    Abraço
    avatar
    AMarcos
    Intermediário
    Intermediário

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 175
    Registrado : 26/07/2016

    Filtro em Formulário não funciona Empty Re: Filtro em Formulário não funciona

    Mensagem  AMarcos em 29/8/2018, 20:15

    Olá Alexandre, eu realmente suspeitei que fosse na consulta, mas com não consegui verificar a alteração sutil no filtro. Mesmo assim fiz a alteração, (retirando "*" &), mas nada aconteceu.

    Ainda não consigo puxar relatório por viaturas, sempre vem geral.

    AMarcos
    FranklinJSP
    FranklinJSP
    Avançado
    Avançado

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Anónimo
    Mensagens : 312
    Registrado : 25/02/2016

    Filtro em Formulário não funciona Empty Re: Filtro em Formulário não funciona

    Mensagem  FranklinJSP em 29/8/2018, 20:43

    Eu espero que seja o que você precisa

    Saludos desde Bolivia


    .................................................................................
    Meu Português não é muito bom,
    mas eu gosto de colaborar... em qualquer idioma
    Smile "Access... minha paixão"
    avatar
    AMarcos
    Intermediário
    Intermediário

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 175
    Registrado : 26/07/2016

    Filtro em Formulário não funciona Empty Re:Filtro em Formulário não funciona

    Mensagem  AMarcos em 30/8/2018, 00:35

    Infelizmente Franklin está ocorrendo erro e também não gostaria de radicalizar alterando os códigos usados já usados.  A autonomia já foi resolvido, o que eu gostaria era somente filtrar a impressão do Relatório por viatura.


    A Marcos
    Anexos
    Filtro em Formulário não funciona AttachmentERRO.zip
    Você não tem permissão para fazer download dos arquivos anexados.
    (390 Kb) Baixado 4 vez(es)
    FranklinJSP
    FranklinJSP
    Avançado
    Avançado

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Anónimo
    Mensagens : 312
    Registrado : 25/02/2016

    Filtro em Formulário não funciona Empty Re: Filtro em Formulário não funciona

    Mensagem  FranklinJSP em 30/8/2018, 01:13

    Eu acho que está fácil

    Saludos desde Bolivia


    .................................................................................
    Meu Português não é muito bom,
    mas eu gosto de colaborar... em qualquer idioma
    Smile "Access... minha paixão"
    avatar
    AMarcos
    Intermediário
    Intermediário

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 175
    Registrado : 26/07/2016

    Filtro em Formulário não funciona Empty Re: Filtro em Formulário não funciona

    Mensagem  AMarcos em 30/8/2018, 01:21

    Franklin meu amigo desse jeito não visuliza resultado nenhum no relatório. Tudo em branco

    AMarcos
    FranklinJSP
    FranklinJSP
    Avançado
    Avançado

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Anónimo
    Mensagens : 312
    Registrado : 25/02/2016

    Filtro em Formulário não funciona Empty Re: Filtro em Formulário não funciona

    Mensagem  FranklinJSP em 30/8/2018, 01:27

    Aqui está uma captura de pantalla

    Filtro em Formulário não funciona Captur13

    Pode ser pela versão de Acess. Eu utilizo 2016


    Última edição por FranklinJSP em 30/8/2018, 01:29, editado 1 vez(es) (Razão : Clarificar a versão)


    .................................................................................
    Meu Português não é muito bom,
    mas eu gosto de colaborar... em qualquer idioma
    Smile "Access... minha paixão"
    avatar
    AMarcos
    Intermediário
    Intermediário

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 175
    Registrado : 26/07/2016

    Filtro em Formulário não funciona Empty Re: Filtro em Formulário não funciona

    Mensagem  AMarcos em 30/8/2018, 01:55

    Mas meu amigo internacional Franklin, o que foi que você fez. Tem como colocar por imagem qual foi a alteração?

    Será que se eu quiser só filtrar por viatura eu conseguirei ter o relatório dessa viatura?

    AMarcos

    FranklinJSP
    FranklinJSP
    Avançado
    Avançado

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Anónimo
    Mensagens : 312
    Registrado : 25/02/2016

    Filtro em Formulário não funciona Empty Re: Filtro em Formulário não funciona

    Mensagem  FranklinJSP em 30/8/2018, 02:42

    Na origem do registro do relatorio:

    Filtro em Formulário não funciona Captur14


    .................................................................................
    Meu Português não é muito bom,
    mas eu gosto de colaborar... em qualquer idioma
    Smile "Access... minha paixão"
    avatar
    AMarcos
    Intermediário
    Intermediário

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 175
    Registrado : 26/07/2016

    Filtro em Formulário não funciona Empty Re: Filtro em Formulário não funciona

    Mensagem  AMarcos em 30/8/2018, 12:02

    Caros amigos, Franklin e demais mestres, fiz alterações mas ainda não consigo ver onde estou errando para que isso não aconteça quando implemento no meu BD.

    Ele está preenchendo todos os campos direitinho, fazendo o cálculo da Autonomia, mas filtrar por viatura somente ou viatura por data NÃO ACONTECE.

    Postei abaixo, outra vez a implementação do meu BD para que algum amigo mestre, possa conseguir desvendar o MISTERIO.

    Ficando doido,


    AMarcos
    Anexos
    Filtro em Formulário não funciona AttachmentMISTERIO.zip
    Você não tem permissão para fazer download dos arquivos anexados.
    (102 Kb) Baixado 5 vez(es)
    FranklinJSP
    FranklinJSP
    Avançado
    Avançado

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Anónimo
    Mensagens : 312
    Registrado : 25/02/2016

    Filtro em Formulário não funciona Empty Re: Filtro em Formulário não funciona

    Mensagem  FranklinJSP em 30/8/2018, 13:39

    Prezado AMarcos

    Voltei a corrigir e os filtros funcionam bem, envio o arquivo e uma captura de tela. Abraços

    Filtro em Formulário não funciona Captur15


    .................................................................................
    Meu Português não é muito bom,
    mas eu gosto de colaborar... em qualquer idioma
    Smile "Access... minha paixão"
    avatar
    AMarcos
    Intermediário
    Intermediário

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 175
    Registrado : 26/07/2016

    Filtro em Formulário não funciona Empty Re: Filtro em Formulário não funciona

    Mensagem  AMarcos em 30/8/2018, 15:46

    Excelente amigo Franklin, realmente vi seu Formulário filtrando por viatura e atrelado ao período, mas infelizmente agora me tirou a opotrunidade de obter o relatório geral com todas as viaturas juntas.

    Vou tentar buscar retornar essa possibilidade para o usuário...

    As telas que vc falou para mostrar as alterações não vieram, somente o BD.


    AMarcos
    avatar
    AMarcos
    Intermediário
    Intermediário

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 175
    Registrado : 26/07/2016

    Filtro em Formulário não funciona Empty Re: Filtro em Formulário não funciona

    Mensagem  AMarcos em 30/8/2018, 15:48

    Me desculpe a tela era só para exemplificar como ficou o filtro, demorou para abrir pra mim...

    Eu pensei que ia ver o que foi feito de correção!


    AMarcos
    FranklinJSP
    FranklinJSP
    Avançado
    Avançado

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Anónimo
    Mensagens : 312
    Registrado : 25/02/2016

    Filtro em Formulário não funciona Empty Re: Filtro em Formulário não funciona

    Mensagem  FranklinJSP em 30/8/2018, 16:41

    Olá AMarcos

    Agora com as duas opções. Se você escolher Viatura imprime somente dessa Viatura, se você deixar Viatura vazio imprime todas as Viaturas.
    Eu envio screenshots.

    Filtro em Formulário não funciona Captur20
    Filtro em Formulário não funciona Captur22
    Filtro em Formulário não funciona Captur21

    Saludos desde Bolivia


    Última edição por FranklinJSP em 30/8/2018, 16:43, editado 1 vez(es) (Razão : Faltou screenshots)


    .................................................................................
    Meu Português não é muito bom,
    mas eu gosto de colaborar... em qualquer idioma
    Smile "Access... minha paixão"
    avatar
    AMarcos
    Intermediário
    Intermediário

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 175
    Registrado : 26/07/2016

    Filtro em Formulário não funciona Empty Re: Filtro em Formulário não funciona

    Mensagem  AMarcos em 30/9/2018, 20:21

    Amigão vc poderia escrever a condição que vc colocou na Consulta nos campos Viaturas e Datas. O extrato que vc enviou não vem atualizado conforme a imagem colocada na sua resposta.

    Inclusive a parte que vc consertou para aparecer a autonomia também não aparece.

    Só estou precisando disso para acertar a alteração.


    AMarcos
    avatar
    AMarcos
    Intermediário
    Intermediário

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 175
    Registrado : 26/07/2016

    Filtro em Formulário não funciona Empty Re: Filtro em Formulário não funciona

    Mensagem  AMarcos em 3/10/2018, 05:08

    Caros amigos se alguém puder me ajudar a desvendar o que estar escrito dentro das condições dos atributos Viaturas e Data na Consulta do Banco de Dados colocado como imagem na resposta do nosso amigo da Bolívia FranklinJSP em Qui 30 Ago 2018, 3:41 pm, ficarei inteiramente grato.

    Preciso só disso pra fechar meus estudos!!!


    Att,


    AMarcos
    FranklinJSP
    FranklinJSP
    Avançado
    Avançado

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Anónimo
    Mensagens : 312
    Registrado : 25/02/2016

    Filtro em Formulário não funciona Empty Re: Filtro em Formulário não funciona

    Mensagem  FranklinJSP em 3/10/2018, 20:06

    Oi Marcos!

    Qual parte do critério você precisa entender?

    Em Viaturas eu uso o que vem a ser IIF
    Em Data uso o que vem a ser BETWEEN datas

    Saludos


    .................................................................................
    Meu Português não é muito bom,
    mas eu gosto de colaborar... em qualquer idioma
    Smile "Access... minha paixão"
    avatar
    AMarcos
    Intermediário
    Intermediário

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 175
    Registrado : 26/07/2016

    Filtro em Formulário não funciona Empty Re: Filtro em Formulário não funciona

    Mensagem  AMarcos em 4/10/2018, 03:09

    Amigão vc poderia escrever a condição que vc colocou na Consulta nos campos Viaturas e Datas. O extrato que vc enviou não vem atualizado conforme a imagem colocada na sua resposta.

    Inclusive a parte que vc consertou para aparecer a autonomia também não aparece.

    Só estou precisando disso para acertar a alteração.


    AMarcos

    avatar
    AMarcos
    Intermediário
    Intermediário

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 175
    Registrado : 26/07/2016

    Filtro em Formulário não funciona Empty Re: Filtro em Formulário não funciona

    Mensagem  AMarcos em 4/10/2018, 14:51

    Nesse dia 30 Ago vc postou como anexo o seguinte Banco de Dados MISTERIO (Com viatura e sem viatura).zip e não veio. O que veio foi o último sem a alteração feita na Consulta nos atributos "Viaturas" e "Data".

    O que eu precisava era esse banco MISTERIO (Com viatura e sem viatura).zip ou então escrever (mesmo em espanhol) qual foi o critério colocado nos atributos "Viaturas" e "Data".

    Só dá pra entender que começa assim: Como Si... ??? e Entre [Forms]... ???


    Me ajude por favor amigo!



    AMarcos
    avatar
    FabioGO
    Intermediário
    Intermediário

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 106
    Registrado : 22/08/2012

    Filtro em Formulário não funciona Empty Re: Filtro em Formulário não funciona

    Mensagem  FabioGO em 4/10/2018, 15:40

    O que pude perceber, estão colocados os critérios na consulta do RELATÓRIO Relatório de Abastecimento

    No campo Viaturas

    Como SeImed(ÉNulo([Forms]![Pesquisa Abastecimento]![comb_Vtr]);"*";([Forms]![Pesquisa Abastecimento]![comb_Vtr]))

    No campo Data

    Entre [Forms]![Pesquisa Abastecimento]![DataIni] E [Forms]![Pesquisa Abastecimento]![DataFim]

    Abra as colunas para você visualizar todo o texto do critério
    avatar
    AMarcos
    Intermediário
    Intermediário

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 175
    Registrado : 26/07/2016

    Filtro em Formulário não funciona Empty Re: Filtro em Formulário não funciona

    Mensagem  AMarcos em 6/10/2018, 15:36

    Meu amigo bom dia!

    Infelizmente ainda continua não filtrando por viatura mesmo realizando as alterações discriminadas em cima na Consulta Abastecimento.

    Por favor eu lhe peço encaricidamente, coloque o extrato em anexo coma as todas as alterações realizadas, pois fazendo alterações aos poucos não está funcionando.

    Por exemplo tem anexos que vc postou com a Autonomia, já os último com a solução dos filtros não consta essa cálculo.

    Se não for exigir demais poste o BD com a solução dos filtros, selecionando tudo sem intervalo de data e também filtrando por cada viatura dentro de um período de tempo (DataIni e DataFim).


    Att,



    ANTONIO MARCOS
    Anexos
    Filtro em Formulário não funciona AttachmentAbastecimento.zip
    Você não tem permissão para fazer download dos arquivos anexados.
    (95 Kb) Baixado 3 vez(es)
    FranklinJSP
    FranklinJSP
    Avançado
    Avançado

    Respeito às Regras 100%

    Sexo : Masculino
    Localização : Anónimo
    Mensagens : 312
    Registrado : 25/02/2016

    Filtro em Formulário não funciona Empty Re: Filtro em Formulário não funciona

    Mensagem  FranklinJSP em 8/10/2018, 13:56

    Bom día Marcos!!!

    Em anexo

    Filtro em Formulário não funciona Captur23
    Filtro em Formulário não funciona Captur24

    Têm que mexer no Origen do registro no Relatorio

    Viaturas:
    Código:
    Como SiInm(EsNulo([Forms]![Pesquisa Abastecimento]![comb_Vtr]);"*";([Forms]![Pesquisa Abastecimento]![comb_Vtr]))

    Data:
    Código:
    Entre [Forms]![Pesquisa Abastecimento]![DataIni] Y [Forms]![Pesquisa Abastecimento]![DataFim]

    Saludos desde Bolivia


    .................................................................................
    Meu Português não é muito bom,
    mas eu gosto de colaborar... em qualquer idioma
    Smile "Access... minha paixão"

    Conteúdo patrocinado

    Filtro em Formulário não funciona Empty Re: Filtro em Formulário não funciona

    Mensagem  Conteúdo patrocinado


      Data/hora atual: 13/12/2019, 08:03