MaximoAccess

Caro Usuário, antes de postar pela primeira vez, leia as regras do fórum.

https://www.maximoaccess.com/t48-regras-do-forum

Obrigado

Administração


Participe do fórum, é rápido e fácil

MaximoAccess

Caro Usuário, antes de postar pela primeira vez, leia as regras do fórum.

https://www.maximoaccess.com/t48-regras-do-forum

Obrigado

Administração

MaximoAccess

Gostaria de reagir a esta mensagem? Crie uma conta em poucos cliques ou inicie sessão para continuar.

Dicas Ms Access, Exemplos Ms Access, Codigos VBA Ms Access, SQL Ms Access


2 participantes

    [Resolvido]Caractere estranho ao editar consulta

    Waltair M Souza
    Waltair M Souza
    Intermediário
    Intermediário


    Respeito às regras : Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 105
    Registrado : 06/10/2012

    [Resolvido]Caractere estranho ao editar consulta Empty [Resolvido]Caractere estranho ao editar consulta

    Mensagem  Waltair M Souza 25/9/2018, 17:16

    Boa tarde amigos...

    Troquei meu computador estes dias e notei algo estranho em minhas consultas.
    No antigo quando abro as consultas em modo estrutura tenho a seguinte situação em uma coluna:

    Filtro: SeImed([empenho]<>"";"Sim";"")

    Já no computador novo percebi isto na mesma consulta:

    Filtro: SeImed([empenho]<>""|"Sim"|"") 'o ponto e virgula aparece como uma barra simples...

    E quando faço uma alteração qualquer não consigo salvar a consulta; porem sem alterar ela está funcionando normalmente.

    Alguém pode me dar um socorro...


    Sistema  Operacional Win7 64 Bits
    Pacote Microsoft Office Professional Plus 2013 32 Bits
    Alvaro Teixeira
    Alvaro Teixeira
    Moderador Global
    Moderador Global


    Respeito às regras : Respeito às Regras 100%

    Sexo : Masculino
    Localização : Portugal
    Mensagens : 7930
    Registrado : 15/03/2013

    [Resolvido]Caractere estranho ao editar consulta Empty Re: [Resolvido]Caractere estranho ao editar consulta

    Mensagem  Alvaro Teixeira 25/9/2018, 17:29

    Olá Waltair,

    Estranho, pode ser um problema de code page (idioma)
    Já verificou se tem atualizações todas, Verifique se tem algum serviço pack para a versão recentemente instalada.

    Uma questão, o campo da sua tabela é boleano (true/false) ou texto?

    Abraço
    Waltair M Souza
    Waltair M Souza
    Intermediário
    Intermediário


    Respeito às regras : Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 105
    Registrado : 06/10/2012

    [Resolvido]Caractere estranho ao editar consulta Empty Re: [Resolvido]Caractere estranho ao editar consulta

    Mensagem  Waltair M Souza 25/9/2018, 22:10

    Olá Teixeira, obrigado pelo retorno imediato

    Sim, verifiquei por atualizações

    e o campo é texto curto

    Abri outras consultas e notei que o mesmo ocorre em todos os campos com expressões tipo esta:

    TxtCampo5: [pedido] & " " & Format(Esquerda([pprproduto]|10)|"000") & Format(Direita([pprproduto]|3)|"000") & "-" & [pprseq]

    enquanto no outro pc antigo a mesma consulta:

    TxtCampo5: [pedido] & " " & Format(Esquerda([pprproduto];10);"000") & Format(Direita([pprproduto];3);"000") & "-" & [pprseq]


    Obs.: os dois estão rodando o mesmo windows e o mesmo pacote office.

    Está eu nunca tinha encontrado neste anos de sistema... Vou olhar mais de perto a questão das atualizações...
    Grato por hora.

    Sistema  Operacional Win7 64 Bits
    Pacote Microsoft Office Professional Plus 2013 32 Bits
    Alvaro Teixeira
    Alvaro Teixeira
    Moderador Global
    Moderador Global


    Respeito às regras : Respeito às Regras 100%

    Sexo : Masculino
    Localização : Portugal
    Mensagens : 7930
    Registrado : 15/03/2013

    [Resolvido]Caractere estranho ao editar consulta Empty Re: [Resolvido]Caractere estranho ao editar consulta

    Mensagem  Alvaro Teixeira 27/9/2018, 22:48

    Olá Waltair,

    Vou tentar fazer umas pesquisa.
    Ficamos aguardar se mais algum colega tem uma dica.

    Abraço
    Waltair M Souza
    Waltair M Souza
    Intermediário
    Intermediário


    Respeito às regras : Respeito às Regras 100%

    Sexo : Masculino
    Localização : Brasil
    Mensagens : 105
    Registrado : 06/10/2012

    [Resolvido]Caractere estranho ao editar consulta Empty Re: [Resolvido]Caractere estranho ao editar consulta

    Mensagem  Waltair M Souza 12/6/2019, 15:07

    Olá amigos

    Formatei está maquina está semana e o problema sitado acima desapareceu...

    Infelizmente não descobri o que causava o transtorno trocando o ";" por "|".

    Mas caso resolvido aqui

    Abraços

    Alvaro Teixeira
    Alvaro Teixeira
    Moderador Global
    Moderador Global


    Respeito às regras : Respeito às Regras 100%

    Sexo : Masculino
    Localização : Portugal
    Mensagens : 7930
    Registrado : 15/03/2013

    [Resolvido]Caractere estranho ao editar consulta Empty Re: [Resolvido]Caractere estranho ao editar consulta

    Mensagem  Alvaro Teixeira 12/6/2019, 15:59

    Olá Waltair,

    Obrigado pelo retorno, o fórum agradece.

    Abraço

    Conteúdo patrocinado


    [Resolvido]Caractere estranho ao editar consulta Empty Re: [Resolvido]Caractere estranho ao editar consulta

    Mensagem  Conteúdo patrocinado


      Data/hora atual: 17/6/2024, 05:19